aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVVD <vvd@unislabs.com>2022-05-31 15:43:06 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2022-05-31 15:49:39 +0000
commite6e83842d9749824da4e2da42f13b89883e73858 (patch)
treec6cfb77f18c9cb2cd97b45c87f93f8a061c4906a
parentc212e29dfc9d48f2999b16d110231f22439a2c78 (diff)
downloadports-e6e83842d9749824da4e2da42f13b89883e73858.tar.gz
ports-e6e83842d9749824da4e2da42f13b89883e73858.zip
www/gitlab-ce: added possibility to disabled kerberos
As this does not change the behaviour of port, no revision bump. PR: 263688
-rw-r--r--www/gitlab-ce/Makefile8
-rw-r--r--www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off11
2 files changed, 18 insertions, 1 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 038e9f7b9c11..4855c342d9c3 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -69,7 +69,6 @@ MY_DEPENDS= git>=2.32.0:devel/git \
rubygem-rack-oauth2>=1.16.0<1.17.0:security/rubygem-rack-oauth2 \
rubygem-jwt21>=2.1.0<2.2.0:www/rubygem-jwt21 \
rubygem-gssapi>0:security/rubygem-gssapi \
- rubygem-timfel-krb5-auth>=0.8<1:security/rubygem-timfel-krb5 \
rubygem-recaptcha>=4.11<5.0:devel/rubygem-recaptcha \
rubygem-akismet>=3.0<4.0:devel/rubygem-akismet \
rubygem-invisible_captcha>=1.1.0<1.2.0:graphics/rubygem-invisible_captcha \
@@ -291,6 +290,13 @@ NO_BUILD= yes
NO_ARCH= yes
+OPTIONS_DEFINE= KERBEROS
+OPTIONS_DEFAULT= KERBEROS
+
+KERBEROS_BUILD_DEPENDS= rubygem-timfel-krb5-auth>=0.8<1:security/rubygem-timfel-krb5
+KERBEROS_RUN_DEPENDS= rubygem-timfel-krb5-auth>=0.8<1:security/rubygem-timfel-krb5
+KERBEROS_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-patch-Gemfile-kerberos-off
+
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/config/gitlab.yml.example \
${WRKSRC}/config/puma.rb.example \
diff --git a/www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off b/www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off
new file mode 100644
index 000000000000..d80c80415ef3
--- /dev/null
+++ b/www/gitlab-ce/files/extra-patch-Gemfile-kerberos-off
@@ -0,0 +1,11 @@
+--- Gemfile.orig
++++ Gemfile
+@@ -60,7 +60,7 @@
+
+ # Kerberos authentication. EE-only
+ gem 'gssapi', group: :kerberos
+-gem 'timfel-krb5-auth', '~> 0.8', group: :kerberos
++#gem 'timfel-krb5-auth', '~> 0.8', group: :kerberos
+
+ # Spam and anti-bot protection
+ gem 'recaptcha', '~> 4.11', require: 'recaptcha/rails'