aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-30 12:57:27 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-30 15:10:20 +0000
commite717a9367f81224bf402a7b739d9b0e4a06c390b (patch)
tree5a802cd39ca8d628457181457d03904498b968b7
parent6808f9715428d490a044a5fe69fd11c735d94828 (diff)
downloadports-e717a9367f81224bf402a7b739d9b0e4a06c390b.tar.gz
ports-e717a9367f81224bf402a7b739d9b0e4a06c390b.zip
net/intel-*-kmod: Remove MAX_NETMAP_OSVERSION
ALl the version mentioned here for MAX_NETMAP_OSVERSION are unsupported by the ports tree. So remove the check and also remove the OPTION NETMAP_AUTO. Approved by: portmgr (blanket)
-rw-r--r--net/intel-em-kmod/Makefile2
-rw-r--r--net/intel-igb-kmod/Makefile2
-rw-r--r--net/intel-ixl-kmod/Makefile12
3 files changed, 2 insertions, 14 deletions
diff --git a/net/intel-em-kmod/Makefile b/net/intel-em-kmod/Makefile
index a1b5762493c3..e916c48512bd 100644
--- a/net/intel-em-kmod/Makefile
+++ b/net/intel-em-kmod/Makefile
@@ -9,8 +9,6 @@ COMMENT= Gigabit FreeBSD Base Drivers for Intel(R) Ethernet
BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
-MAX_NETMAP_OSVERSION= 1199999 # Doesn't build w/NETMAP on 12
-
MASTERDIR= ${.CURDIR}/../intel-ixl-kmod
PKGDIR= ${.CURDIR}
DISTINFO_FILE= ${.CURDIR}/distinfo
diff --git a/net/intel-igb-kmod/Makefile b/net/intel-igb-kmod/Makefile
index e9cbe341c92f..898ade9c2733 100644
--- a/net/intel-igb-kmod/Makefile
+++ b/net/intel-igb-kmod/Makefile
@@ -9,8 +9,6 @@ COMMENT= NIC Driver for Intel(R) 82575/6 and 82580-Based cards
BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
-MAX_NETMAP_OSVERSION= 1199999 # Doesn't build w/NETMAP on 12
-
MASTERDIR= ${.CURDIR}/../intel-ixl-kmod
PKGDIR= ${.CURDIR}
DISTINFO_FILE= ${.CURDIR}/distinfo
diff --git a/net/intel-ixl-kmod/Makefile b/net/intel-ixl-kmod/Makefile
index faba4ed0a3a1..5186968deb71 100644
--- a/net/intel-ixl-kmod/Makefile
+++ b/net/intel-ixl-kmod/Makefile
@@ -1,6 +1,6 @@
PORTNAME?= ixl
PORTVERSION?= 1.13.4
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net
MASTER_SITES?= https://downloadmirror.intel.com/${MASTER_SITE_SUBDIR}/ \
http://downloadmirror.intel.com/${MASTER_SITE_SUBDIR}/
@@ -17,10 +17,8 @@ LICENSE= BSD2CLAUSE
USES= kmod
OPTIONS_SINGLE= NETMAP
-OPTIONS_SINGLE_NETMAP= NETMAP_AUTO NETMAP_ON NETMAP_OFF
-OPTIONS_DEFAULT= NETMAP_AUTO
+OPTIONS_SINGLE_NETMAP= NETMAP_ON NETMAP_OFF
-NETMAP_AUTO_DESC= Enable netmap(4) support on supported OS versions
NETMAP_ON_DESC= Enable netmap(4) support unconditionally
NETMAP_OFF_DESC= Disable netmap(4) support unconditionally
@@ -41,8 +39,6 @@ MAKE_ENV+= WERROR=""
PLIST_FILES+= man/man4/${link}.4.gz
.endfor
-MAX_NETMAP_OSVERSION?= 1200500 # Maximum OSVERSION for which NETMAP support works
-
.include <bsd.port.pre.mk>
# Fixup for slave ports that use this as a master port. sbruno
@@ -51,10 +47,6 @@ ONLY_FOR_ARCHS= aarch64 amd64 powerpc64 powerpc64le riscv64
ONLY_FOR_ARCHS_REASON= only supported on 32-bit architectures
.endif
-.if ${PORT_OPTIONS:MNETMAP_AUTO} && ${OSVERSION} <= ${MAX_NETMAP_OSVERSION}
-CFLAGS+= -DDEV_NETMAP
-.endif
-
do-install:
${INSTALL_KLD} ${WRKSRC}/if_${PORTNAME}.ko ${STAGEDIR}${KMODDIR}/if_${PORTNAME}_updated.ko
${INSTALL_MAN} ${WRKSRC}/${MANPAGENAME}.4 ${STAGEDIR}${MAN4PREFIX}/man/man4/