aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 08:39:46 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-12-30 09:04:05 +0000
commite73ed31d9f444ad5a59d89f6651a35a0bc18629a (patch)
tree7a027ff0253ee6e7e3ec4ad764e48b059a581fee
parent7593d64d4f264340c8e8fb6ce9cc6316f2d48945 (diff)
downloadports-e73ed31d9f444ad5a59d89f6651a35a0bc18629a.tar.gz
ports-e73ed31d9f444ad5a59d89f6651a35a0bc18629a.zip
astro/cfitsio: Update to 4.2.0
- Convert REINPLACE_CMD to patch file - Bump PORTREVISION of dependent ports for shlib change Changes: https://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/docs/changes.txt
-rw-r--r--astro/astrometry/Makefile1
-rw-r--r--astro/cfitsio/Makefile10
-rw-r--r--astro/cfitsio/distinfo6
-rw-r--r--astro/cfitsio/files/patch-configure15
-rw-r--r--astro/cfitsio/pkg-plist4
-rw-r--r--astro/gnuastro/Makefile1
-rw-r--r--astro/kstars/Makefile1
-rw-r--r--astro/oskar/Makefile2
-rw-r--r--astro/p5-Astro-FITS-CFITSIO/Makefile1
-rw-r--r--astro/phd2/Makefile2
-rw-r--r--astro/siril/Makefile1
-rw-r--r--astro/stellarsolver/Makefile1
-rw-r--r--astro/wcslib/Makefile1
-rw-r--r--devel/indi/Makefile1
-rw-r--r--graphics/luminance-qt5/Makefile2
-rw-r--r--graphics/ufraw/Makefile2
-rw-r--r--math/labplot/Makefile2
-rw-r--r--math/octave-forge-cfitsio/Makefile1
-rw-r--r--math/octave-forge-fits/Makefile2
-rw-r--r--science/healpix/Makefile2
-rw-r--r--science/kst2/Makefile2
21 files changed, 41 insertions, 19 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index b0a927a84f3e..73d6c0494f69 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -1,5 +1,6 @@
PORTNAME= astrometry
PORTVERSION= 0.92
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= http://astrometry.net/downloads/
DISTNAME= ${PORTNAME}.net-${PORTVERSION}
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index 988bdbf15325..6c95a96fd1ca 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -1,6 +1,5 @@
PORTNAME= cfitsio
-PORTVERSION= 4.1.0
-PORTREVISION= 1
+PORTVERSION= 4.2.0
CATEGORIES= astro
MASTER_SITES= https://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/ \
https://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/oldvers/ \
@@ -30,15 +29,14 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/*.[chl]
- @${REINPLACE_CMD} -e '/#define _XOPEN_SOURCE 700/d' ${WRKSRC}/configure
do-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} drvrsmem.h fitsio.h fitsio2.h longnam.h ${STAGEDIR}${PREFIX}/include/
${INSTALL_DATA} ${WRKSRC}/libcfitsio.a ${STAGEDIR}${PREFIX}/lib/
- ${INSTALL_LIB} ${WRKSRC}/libcfitsio.so.9.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/
+ ${INSTALL_LIB} ${WRKSRC}/libcfitsio.so.10.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/
${INSTALL_DATA} ${WRKSRC}/cfitsio.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/
- ${LN} -fs libcfitsio.so.9.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libcfitsio.so.9
- ${LN} -fs libcfitsio.so.9.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libcfitsio.so
+ ${LN} -fs libcfitsio.so.10.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libcfitsio.so.10
+ ${LN} -fs libcfitsio.so.10.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libcfitsio.so
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
diff --git a/astro/cfitsio/distinfo b/astro/cfitsio/distinfo
index 39ee2ab85e37..39a9400708b3 100644
--- a/astro/cfitsio/distinfo
+++ b/astro/cfitsio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649423660
-SHA256 (cfitsio-4.1.0.tar.gz) = b367c695d2831958e7166921c3b356d5dfa51b1ecee505b97416ba39d1b6c17a
-SIZE (cfitsio-4.1.0.tar.gz) = 4305184
+TIMESTAMP = 1669057507
+SHA256 (cfitsio-4.2.0.tar.gz) = eba53d1b3f6e345632bb09a7b752ec7ced3d63ec5153a848380f3880c5d61889
+SIZE (cfitsio-4.2.0.tar.gz) = 4356372
diff --git a/astro/cfitsio/files/patch-configure b/astro/cfitsio/files/patch-configure
new file mode 100644
index 000000000000..bf8aab7b576d
--- /dev/null
+++ b/astro/cfitsio/files/patch-configure
@@ -0,0 +1,15 @@
+Fix build with Clang 15
+
+Reference: https://cgit.freebsd.org/ports/commit/astro/cfitsio/Makefile?id=7eda11c87c30c735058e9393d54b631a74cf566a
+
+--- configure.orig 2022-10-31 18:40:23 UTC
++++ configure
+@@ -5606,8 +5606,6 @@ fi
+ if test "x$BUILD_REENTRANT" = xyes; then
+ printf "%s\n" "#define _REENTRANT 1" >>confdefs.h
+
+- printf "%s\n" "#define _XOPEN_SOURCE 700" >>confdefs.h
+-
+ # Additional definition needed to get 'union semun' when using
+ # _XOPEN_SOURCE on a Mac:
+ if test "x$EXT" = xdarwin; then
diff --git a/astro/cfitsio/pkg-plist b/astro/cfitsio/pkg-plist
index c91dfcd3843b..5412f9229d38 100644
--- a/astro/cfitsio/pkg-plist
+++ b/astro/cfitsio/pkg-plist
@@ -4,8 +4,8 @@ include/fitsio2.h
include/longnam.h
lib/libcfitsio.a
lib/libcfitsio.so
-lib/libcfitsio.so.9
-lib/libcfitsio.so.9.%%PORTVERSION%%
+lib/libcfitsio.so.10
+lib/libcfitsio.so.10.%%PORTVERSION%%
libdata/pkgconfig/cfitsio.pc
%%PORTDOCS%%%%DOCSDIR%%/cfortran.doc
%%PORTDOCS%%%%DOCSDIR%%/fitsio.doc
diff --git a/astro/gnuastro/Makefile b/astro/gnuastro/Makefile
index 323b000dc8bc..fb998163bcb0 100644
--- a/astro/gnuastro/Makefile
+++ b/astro/gnuastro/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gnuastro
PORTVERSION= 0.19
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= GNU
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index d95c705e1a60..d54c306962db 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kstars
DISTVERSION= 3.6.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= astro kde
MASTER_SITES= KDE/stable/${PORTNAME}
diff --git a/astro/oskar/Makefile b/astro/oskar/Makefile
index 2d159a84b4e1..3ee914634f9b 100644
--- a/astro/oskar/Makefile
+++ b/astro/oskar/Makefile
@@ -1,6 +1,6 @@
PORTNAME= OSKAR
DISTVERSION= 2.8.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro
MAINTAINER= yuri@FreeBSD.org
diff --git a/astro/p5-Astro-FITS-CFITSIO/Makefile b/astro/p5-Astro-FITS-CFITSIO/Makefile
index 46f5250931ab..7db9fdef6ead 100644
--- a/astro/p5-Astro-FITS-CFITSIO/Makefile
+++ b/astro/p5-Astro-FITS-CFITSIO/Makefile
@@ -1,5 +1,6 @@
PORTNAME= Astro-FITS-CFITSIO
PORTVERSION= 1.16
+PORTREVISION= 1
CATEGORIES= astro perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/astro/phd2/Makefile b/astro/phd2/Makefile
index cb9c8e6117a1..053d6bb9d3f3 100644
--- a/astro/phd2/Makefile
+++ b/astro/phd2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= phd2
DISTVERSIONPREFIX=v
DISTVERSION= 2.6.10
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= astro
MAINTAINER= acm@FreeBSD.org
diff --git a/astro/siril/Makefile b/astro/siril/Makefile
index bd8d5a72053c..c7ece8c4fec5 100644
--- a/astro/siril/Makefile
+++ b/astro/siril/Makefile
@@ -1,5 +1,6 @@
PORTNAME= siril
DISTVERSION= 1.0.6
+PORTREVISION= 1
CATEGORIES= astro graphics
MASTER_SITES= https://free-astro.org/download/
diff --git a/astro/stellarsolver/Makefile b/astro/stellarsolver/Makefile
index 93434f654700..1f312de9d0f8 100644
--- a/astro/stellarsolver/Makefile
+++ b/astro/stellarsolver/Makefile
@@ -1,5 +1,6 @@
PORTNAME= stellarsolver
DISTVERSION= 2.4
+PORTREVISION= 1
CATEGORIES= astro
MAINTAINER= acm@FreeBSD.org
diff --git a/astro/wcslib/Makefile b/astro/wcslib/Makefile
index b5e8a27f778d..8b118868d4e8 100644
--- a/astro/wcslib/Makefile
+++ b/astro/wcslib/Makefile
@@ -1,5 +1,6 @@
PORTNAME= wcslib
PORTVERSION= 7.12
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= ftp://ftp.atnf.csiro.au/pub/software/wcslib/
diff --git a/devel/indi/Makefile b/devel/indi/Makefile
index 956a86a3cad0..4c205b1aacf7 100644
--- a/devel/indi/Makefile
+++ b/devel/indi/Makefile
@@ -1,6 +1,7 @@
PORTNAME= indi
DISTVERSIONPREFIX= v
DISTVERSION= 1.9.6
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= acm@FreeBSD.org
diff --git a/graphics/luminance-qt5/Makefile b/graphics/luminance-qt5/Makefile
index e4d05afd981e..d3005c17a597 100644
--- a/graphics/luminance-qt5/Makefile
+++ b/graphics/luminance-qt5/Makefile
@@ -1,6 +1,6 @@
PORTNAME= luminance-hdr
DISTVERSION= 2.6.1.1
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index bf89506024ba..9e9177b57cea 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ufraw
PORTVERSION= 0.22.20210424
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MAINTAINER= rodrigo@FreeBSD.org
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index 85b18978d6eb..a3f58a774006 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -1,6 +1,6 @@
PORTNAME= labplot
DISTVERSION= 2.9.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
diff --git a/math/octave-forge-cfitsio/Makefile b/math/octave-forge-cfitsio/Makefile
index e6f22928098b..41fca05002e4 100644
--- a/math/octave-forge-cfitsio/Makefile
+++ b/math/octave-forge-cfitsio/Makefile
@@ -1,5 +1,6 @@
PORTNAME= octave-forge-cfitsio
PORTVERSION= 0.0.4
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF
MASTER_SITE_SUBDIR=octave-cfitsio/v${PORTVERSION}
diff --git a/math/octave-forge-fits/Makefile b/math/octave-forge-fits/Makefile
index 9cf3c33cf528..863ecbeceae0 100644
--- a/math/octave-forge-fits/Makefile
+++ b/math/octave-forge-fits/Makefile
@@ -1,6 +1,6 @@
PORTNAME= octave-forge-fits
PORTVERSION= 1.0.7
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= math
MASTER_SITES= SF/octave/Octave%20Forge%20Packages/Individual%20Package%20Releases
DISTNAME= ${OCTAVE_PKGNAME}-${DISTVERSIONFULL}
diff --git a/science/healpix/Makefile b/science/healpix/Makefile
index cf058d23f85b..92f6cbda719f 100644
--- a/science/healpix/Makefile
+++ b/science/healpix/Makefile
@@ -1,7 +1,7 @@
PORTNAME= healpix
DISTVERSION= 3.50
DISTVERSIONSUFFIX= _2018Dec10
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science
MASTER_SITES= SF/${PORTNAME}/Healpix_${DISTVERSION}/
DISTNAME= Healpix_${DISTVERSIONFULL}
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 2074f7dc4790..907755cdba19 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kst
DISTVERSION= ${KST_VERSION}.${KST_DATE}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MAINTAINER= makc@FreeBSD.org