aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2024-02-02 06:54:46 +0000
committerWen Heping <wen@FreeBSD.org>2024-02-02 12:02:46 +0000
commite75633175dd6a376cb4040fbeb89e13e6d08e6f1 (patch)
tree95ebdfa3c86385735693d3bc39c9885b7f6b2acd
parent711371627da86899d5ed6e6688c394920e8c0f4f (diff)
downloadports-e75633175dd6a376cb4040fbeb89e13e6d08e6f1.tar.gz
ports-e75633175dd6a376cb4040fbeb89e13e6d08e6f1.zip
graphics/py-pandana: Fix build with python-3.11
PR: 275494 Approved by: portmgr(blanket, fix build)
-rw-r--r--graphics/py-pandana/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/py-pandana/Makefile b/graphics/py-pandana/Makefile
index f9e40afb8bd6..47f196c66352 100644
--- a/graphics/py-pandana/Makefile
+++ b/graphics/py-pandana/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pandana
PORTVERSION= 0.6.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,8 +17,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BROKEN= requires OpenMP support that is missing on this architecture
.endif
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.25.2:lang/cython@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}numpy>=1.8,1:math/py-numpy@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython3>=0:lang/cython3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.8,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.8,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>=0.17,1:math/py-pandas@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.0:www/py-requests@${PY_FLAVOR} \
@@ -26,7 +27,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.8,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tables>=3.1:devel/py-tables@${PY_FLAVOR}
USES= compiler:c++11-lang python
-USE_PYTHON= autoplist concurrent cython distutils
+USE_PYTHON= autoplist concurrent pep517
post-install:
${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +