aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-10-22 18:30:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-10-22 18:30:51 +0000
commite79df2beed06349cb8f5af30a6518689400b5bf7 (patch)
tree565f80714d50d0aed1516b3871598a5fabf90eec
parenteef70d0994e8679736c31865acf0d1a93c04bac3 (diff)
downloadports-e79df2beed06349cb8f5af30a6518689400b5bf7.tar.gz
ports-e79df2beed06349cb8f5af30a6518689400b5bf7.zip
textproc/py-faust-cchardet: New port: High speed universal character encoding detector
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-faust-cchardet/Makefile26
-rw-r--r--textproc/py-faust-cchardet/distinfo3
-rw-r--r--textproc/py-faust-cchardet/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 84a88103d5be..ecfd81186be0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1359,6 +1359,7 @@
SUBDIR += py-evtx2splunk
SUBDIR += py-extract-msg
SUBDIR += py-fastavro
+ SUBDIR += py-faust-cchardet
SUBDIR += py-feedparser
SUBDIR += py-fingerprints
SUBDIR += py-fluent.syntax
diff --git a/textproc/py-faust-cchardet/Makefile b/textproc/py-faust-cchardet/Makefile
new file mode 100644
index 000000000000..23af33824f41
--- /dev/null
+++ b/textproc/py-faust-cchardet/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= faust-cchardet
+DISTVERSION= 2.1.19
+CATEGORIES= textproc python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= High speed universal character encoding detector
+WWW= https://github.com/faust-streaming/cChardet
+
+LICENSE= MPL11
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}pkgconfig>0:devel/py-pkgconfig@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 cython concurrent autoplist pytest
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/cchardet/_cchardet${PYTHON_EXT_SUFFIX}.so
+
+.include <bsd.port.mk>
diff --git a/textproc/py-faust-cchardet/distinfo b/textproc/py-faust-cchardet/distinfo
new file mode 100644
index 000000000000..00e2b5549b5c
--- /dev/null
+++ b/textproc/py-faust-cchardet/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1697998709
+SHA256 (faust-cchardet-2.1.19.tar.gz) = f89386297cde0c8e0f5e21464bc2d6d0e4a4fc1b1d77cdb238ca24d740d872e0
+SIZE (faust-cchardet-2.1.19.tar.gz) = 678871
diff --git a/textproc/py-faust-cchardet/pkg-descr b/textproc/py-faust-cchardet/pkg-descr
new file mode 100644
index 000000000000..1257dd1bf3e2
--- /dev/null
+++ b/textproc/py-faust-cchardet/pkg-descr
@@ -0,0 +1,3 @@
+faust-cchardet, and called cChardet, is a universal character encoding detector.
+
+It supports a lot of languages and encodings.