aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2023-02-18 17:50:56 +0000
committerCharlie Li <vishwin@FreeBSD.org>2023-02-18 17:50:56 +0000
commite7a9ba1fecd9209fbb4b669ccb283cb1862c4a2a (patch)
treec3b6b20e9954be973ad064370090b760321022db
parentb16091e19db403fa19c514ec5ac4c15045e402ef (diff)
downloadports-e7a9ba1fecd9209fbb4b669ccb283cb1862c4a2a.tar.gz
ports-e7a9ba1fecd9209fbb4b669ccb283cb1862c4a2a.zip
devel/py-typing-extensions: unbreak circular dependency
This is part of the PEP-517 bootstrap chain on older Python, so do not use devel/py-build to build the wheel. While here, add USE_PYTHON=allflavors With hat: python
-rw-r--r--devel/py-typing-extensions/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/py-typing-extensions/Makefile b/devel/py-typing-extensions/Makefile
index 4c7e712a13f5..eb9be6e72d75 100644
--- a/devel/py-typing-extensions/Makefile
+++ b/devel/py-typing-extensions/Makefile
@@ -13,10 +13,11 @@ WWW= https://github.com/python/typing_extensions
LICENSE= PSFL
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.4<4:devel/py-flit-core@${PY_FLAVOR}
-
USES= python:3.7+
-USE_PYTHON= autoplist concurrent pep517
+USE_PYTHON= allflavors autoplist concurrent pep517
+
+PEP517_BUILD_CMD= ${PYTHON_CMD} -m flit_core.wheel
+PEP517_BUILD_DEPEND= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.4<4:devel/py-flit-core@${PY_FLAVOR}
NO_ARCH= yes