aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-01-29 08:22:46 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-01-29 08:22:46 +0000
commite82ca7d300f8d5884d84a9718c30a60769a801f0 (patch)
treecb854df8f0ba47a1b1167d0b7848030ba6758d3d
parent0b74a808da7243ddb4f6c16763f91ebfdde25ce9 (diff)
downloadports-e82ca7d300f8d5884d84a9718c30a60769a801f0.tar.gz
ports-e82ca7d300f8d5884d84a9718c30a60769a801f0.zip
security/blst: Implementation of BLS12-381
-rw-r--r--security/Makefile1
-rw-r--r--security/blst/Makefile32
-rw-r--r--security/blst/distinfo3
-rw-r--r--security/blst/files/libblst.pc.in11
-rw-r--r--security/blst/pkg-descr3
-rw-r--r--security/blst/pkg-plist5
6 files changed, 55 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d7ab7b4ed8c2..99ec5c3a1f7b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -55,6 +55,7 @@
SUBDIR += bfbtester
SUBDIR += binwalk
SUBDIR += bitwarden-cli
+ SUBDIR += blst
SUBDIR += boringssl
SUBDIR += botan2
SUBDIR += botan3
diff --git a/security/blst/Makefile b/security/blst/Makefile
new file mode 100644
index 000000000000..8d1737f2128a
--- /dev/null
+++ b/security/blst/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= blst
+PORTVERSION= 0.3.11
+CATEGORIES= security devel
+
+MAINTAINER= arrowd@FreeBSD.org
+COMMENT= Implementation of BLS12-381 signature algorithm
+WWW= https://github.com/supranational/blst
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= supranational
+GH_TAGNAME= v${PORTVERSION}
+
+USE_LDCONFIG= yes
+
+SUB_FILES= libblst.pc
+
+do-build:
+ cd ${WRKSRC} && ./build.sh -shared
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/libblst
+ ${INSTALL_DATA} ${WRKSRC}/bindings/blst_aux.h \
+ ${WRKSRC}/bindings/blst.h \
+ ${WRKSRC}/bindings/blst.hpp \
+ ${STAGEDIR}${PREFIX}/include/libblst
+ ${INSTALL_DATA} ${WRKDIR}/libblst.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig
+ ${INSTALL_LIB} ${WRKSRC}/libblst.so ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/security/blst/distinfo b/security/blst/distinfo
new file mode 100644
index 000000000000..dc8038c42b5d
--- /dev/null
+++ b/security/blst/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1706466871
+SHA256 (supranational-blst-0.3.11-v0.3.11_GH0.tar.gz) = d0a6e2a69490cc45f0a531a684a225e56fe22303665157cfa397ba5605447eb9
+SIZE (supranational-blst-0.3.11-v0.3.11_GH0.tar.gz) = 564973
diff --git a/security/blst/files/libblst.pc.in b/security/blst/files/libblst.pc.in
new file mode 100644
index 000000000000..61ebd55a98bb
--- /dev/null
+++ b/security/blst/files/libblst.pc.in
@@ -0,0 +1,11 @@
+prefix=%%PREFIX%%
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include/libblst
+
+Name: libblst
+Description: Multilingual BLS12-381 signature library
+URL: https://github.com/supranational/blst
+Version: 0.3.11
+Cflags: -I${includedir}
+Libs: -L${libdir} -lblst
diff --git a/security/blst/pkg-descr b/security/blst/pkg-descr
new file mode 100644
index 000000000000..a05e8c4691ed
--- /dev/null
+++ b/security/blst/pkg-descr
@@ -0,0 +1,3 @@
+blst (pronounced 'blast') is a BLS12-381 signature library focused on
+performance and security. It is written in C and assembly and has bindings to
+various languages.
diff --git a/security/blst/pkg-plist b/security/blst/pkg-plist
new file mode 100644
index 000000000000..cfe6284b630d
--- /dev/null
+++ b/security/blst/pkg-plist
@@ -0,0 +1,5 @@
+include/libblst/blst.h
+include/libblst/blst.hpp
+include/libblst/blst_aux.h
+lib/libblst.so
+libdata/pkgconfig/libblst.pc