aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2023-08-28 14:19:35 +0000
committerCy Schubert <cy@FreeBSD.org>2023-08-28 16:35:26 +0000
commite84a58d2b6b18c6f3bf8fc335a53788953cb325b (patch)
tree7f6acde6cf92abfcea4296dc243151d6e656a8e7
parent3a86f14adefaed32f83737b359f80d80f28eec53 (diff)
downloadports-e84a58d2b6b18c6f3bf8fc335a53788953cb325b.tar.gz
ports-e84a58d2b6b18c6f3bf8fc335a53788953cb325b.zip
devel/bitkeeper: Fix LLVM15 build
Fix many of the following: CC tclStubInit.c /export/wrkdir/amd64/export/freebsd/git/ports/devel/bitkeeper/work/bk-7.3.3/src/gui/tcltk/tcl/generic/tclStubInit.c:693:5: error: incompatible function pointer types initializing 'int (*)(const mp_int *, const mp_int *)' (aka 'int (*)(const struct mp_int *, const struct mp_int *)') with an expression of type 'int (mp_int *, mp_int *)' (aka 'int (struct mp_int *, struct mp_int *)') [-Wincompatible-function-pointer-types] TclBN_mp_cmp, /* 8 */
-rw-r--r--devel/bitkeeper/files/patch-src_gui_tcltk_Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/devel/bitkeeper/files/patch-src_gui_tcltk_Makefile b/devel/bitkeeper/files/patch-src_gui_tcltk_Makefile
new file mode 100644
index 000000000000..aee0c762bff0
--- /dev/null
+++ b/devel/bitkeeper/files/patch-src_gui_tcltk_Makefile
@@ -0,0 +1,10 @@
+--- gui/tcltk/Makefile.orig 2023-08-28 07:06:54.841207000 -0700
++++ gui/tcltk/Makefile 2023-08-28 07:10:54.236984000 -0700
+@@ -117,6 +117,7 @@
+ if [ -n "$$TCLVER" -a -f "$$TCLVER" -a -z "$$FORCE_REBUILD" ]; \
+ then gunzip < "$$TCLVER" | tar -xf -; true; \
+ else unset CC LD CCXTRA CFLAGS; \
++ export CFLAGS=-Wno-incompatible-function-pointer-types; \
+ MAKEFLAGS=`echo "$$MAKEFLAGS" | sed 's/ -- .*//'`; \
+ $(MAKE) Q=$(Q) populate ; \
+ $(MAKE) Q=$(Q) bin/tclsh$(EXE) || exit 1; \