aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2022-05-13 22:26:30 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-05-13 22:26:30 +0000
commite8e6fba878cf12df83a4bc2ef8f378b8335d8975 (patch)
treedb658e1648cc62449ea2e56736132437c354f07b
parent39f5f92774571ccfbccb21811c2f9ec730c1002e (diff)
downloadports-e8e6fba878cf12df83a4bc2ef8f378b8335d8975.tar.gz
ports-e8e6fba878cf12df83a4bc2ef8f378b8335d8975.zip
net/asterisk16: Update to 16.26.0
- Embedded pjproject updated from 2.10 to 2.12 - Fix terminfo detection by adding the correct path to detection code [1] - Add note to pkg-descr to explain that the misc/terminfo-db port is required to get color in the console Reported by: ogogon@ogogon.org (via email) [1]
-rw-r--r--net/asterisk16/Makefile5
-rw-r--r--net/asterisk16/distinfo10
-rw-r--r--net/asterisk16/files/asterisk.in4
-rw-r--r--net/asterisk16/files/patch-configure49
-rw-r--r--net/asterisk16/files/patch-main_term.c10
-rw-r--r--net/asterisk16/pkg-message4
6 files changed, 49 insertions, 33 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 18692c23e44d..2e818c1bbb99 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -1,5 +1,5 @@
PORTNAME= asterisk
-PORTVERSION= 16.25.3
+PORTVERSION= 16.26.0
CATEGORIES= net
MASTER_SITES= https://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
MASTER_SITE_SUBDIR= asterisk/ \
@@ -27,7 +27,7 @@ USE_GITHUB= nodefault
EXTRACT_ONLY:= ${DISTNAME}${EXTRACT_SUFX}
-PJSIP_VERSION= 2.10
+PJSIP_VERSION= 2.12
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datarootdir=${DATADIR} \
--with-ilbc=internal \
@@ -246,6 +246,7 @@ post-extract-OPUS-on:
post-patch:
@${REINPLACE_CMD} -e 's|/var/lib|${PREFIX}/share|g' ${WRKSRC}/configs/samples/musiconhold.conf.sample
@${REINPLACE_CMD} -e 's/@XMLSTARLET@//' ${WRKSRC}/makeopts.in
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/main/term.c
.if exists(${FILESDIR}/.asterisk.makeopts)
${CP} ${FILESDIR}/.asterisk.makeopts ${WRKSRC}/menuselect.makeopts
.endif
diff --git a/net/asterisk16/distinfo b/net/asterisk16/distinfo
index 8d5bd68a7cd9..7df31e3c1032 100644
--- a/net/asterisk16/distinfo
+++ b/net/asterisk16/distinfo
@@ -1,11 +1,11 @@
-TIMESTAMP = 1650998838
-SHA256 (asterisk/asterisk-16.25.3.tar.gz) = 9b839b0d3e3329e35f16b850886e53b1ce51ee93212a1e83eede3b372ea52d22
-SIZE (asterisk/asterisk-16.25.3.tar.gz) = 27994773
+TIMESTAMP = 1652367006
+SHA256 (asterisk/asterisk-16.26.0.tar.gz) = b7bb24d246542ff7393dd13e7e8c40c27e16668d9145c18e1970e5a8df8c3650
+SIZE (asterisk/asterisk-16.26.0.tar.gz) = 28014144
SHA256 (asterisk/asterisk-core-sounds-en-g729-1.5.tar.gz) = 8b28a59cfa53b59c76e0a191704f0708e3d83acffab8c5e6f25dfc599f0123f9
SIZE (asterisk/asterisk-core-sounds-en-g729-1.5.tar.gz) = 1551123
SHA256 (asterisk/asterisk-moh-opsound-g729-2.03.tar.gz) = 0147ca9a97f0c550227aacb7793499057c4d2c64e021c95f93722f27d5549585
SIZE (asterisk/asterisk-moh-opsound-g729-2.03.tar.gz) = 1103000
SHA256 (asterisk/traud-asterisk-opus-83e1b458c77e0e287adeca494eeb79edb077b0ff_GH0.tar.gz) = 572a3c956371ed62b44a4bcd973db10eb4c84f3040cf7156e3acfad3b6bf3ded
SIZE (asterisk/traud-asterisk-opus-83e1b458c77e0e287adeca494eeb79edb077b0ff_GH0.tar.gz) = 24044
-SHA256 (asterisk/pjsip-pjproject-2.10_GH0.tar.gz) = 936a4c5b98601b52325463a397ddf11ab4106c6a7b04f8dc7cdd377efbb597de
-SIZE (asterisk/pjsip-pjproject-2.10_GH0.tar.gz) = 8768705
+SHA256 (asterisk/pjsip-pjproject-2.12_GH0.tar.gz) = b3b94d9be4aba8f6d2d1cb164603e81b0a6ee17352f9e2ba5b58e325e610ca5a
+SIZE (asterisk/pjsip-pjproject-2.12_GH0.tar.gz) = 9658564
diff --git a/net/asterisk16/files/asterisk.in b/net/asterisk16/files/asterisk.in
index aaa2ce8cdd8f..5fab82c5700e 100644
--- a/net/asterisk16/files/asterisk.in
+++ b/net/asterisk16/files/asterisk.in
@@ -69,7 +69,7 @@ asterisk_stop()
if [ ${asterisk_stopsleep} -gt 0 ]; then
sleep ${asterisk_stopsleep}
fi
- $command -nqrx 'core stop now'
+ $command -rx 'core stop now'
wait_for_pids $rc_pid
}
@@ -80,7 +80,7 @@ asterisk_reload()
return 1
fi
echo 'Reloading asterisk.'
- $command -nqrx 'reload'
+ $command -rx 'reload'
}
run_rc_command "$1"
diff --git a/net/asterisk16/files/patch-configure b/net/asterisk16/files/patch-configure
index 423e14aad59a..035ad3df2fe0 100644
--- a/net/asterisk16/files/patch-configure
+++ b/net/asterisk16/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2020-07-09 15:39:17 UTC
+--- configure.orig 2022-05-05 14:21:18 UTC
+++ configure
-@@ -4687,8 +4687,6 @@ case "${host_os}" in
+@@ -5148,8 +5148,6 @@ case "${host_os}" in
;;
dragonfly*|freebsd*)
ac_default_prefix=/usr/local
@@ -9,7 +9,7 @@
;;
openbsd*)
ac_default_prefix=/usr/local
-@@ -20355,6 +20353,8 @@ $as_echo_n "checking for getifaddrs() support... " >&6
+@@ -22951,6 +22949,8 @@ printf %s "checking for getifaddrs() support... " >&6;
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -17,34 +17,35 @@
+ #include <sys/socket.h>
#include <ifaddrs.h>
int
- main ()
-@@ -29514,6 +29514,8 @@ fi
+ main (void)
+@@ -32266,6 +32266,8 @@ for ver in ${LUA_VERSIONS:-5.4 5.3 5.2 5.1}; do
- for ver in 5.3 5.2 5.1; do
+ for ver in ${LUA_VERSIONS:-5.4 5.3 5.2 5.1}; do
+vernodot=`echo ${ver} | sed 's/\.//'`
+
if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no"; then
pbxlibdir=""
# if --with-LUA=DIR has been specified, use it.
-@@ -29528,13 +29530,13 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
+@@ -32280,14 +32282,14 @@ if test "x${PBX_LUA}" != "x1" -a "${USE_LUA}" != "no";
ast_ext_lib_check_save_CFLAGS="${CFLAGS}"
CFLAGS="${CFLAGS} "
- as_ac_Lib=`$as_echo "ac_cv_lib_lua${ver}''_luaL_newstate" | $as_tr_sh`
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua${ver}" >&5
--$as_echo_n "checking for luaL_newstate in -llua${ver}... " >&6; }
-+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua-${ver}" >&5
-+$as_echo_n "checking for luaL_newstate in -llua-${ver}... " >&6; }
- if eval \${$as_ac_Lib+:} false; then :
- $as_echo_n "(cached) " >&6
- else
+ as_ac_Lib=`printf "%s\n" "ac_cv_lib_lua${ver}""_luaL_newstate" | $as_tr_sh`
+-{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua${ver}" >&5
+-printf %s "checking for luaL_newstate in -llua${ver}... " >&6; }
++{ printf "%s\n" "$as_me:${as_lineno-$LINENO}: checking for luaL_newstate in -llua-${ver}" >&5
++printf %s "checking for luaL_newstate in -llua-${ver}... " >&6; }
+ if eval test \${$as_ac_Lib+y}
+ then :
+ printf %s "(cached) " >&6
+ else $as_nop
ac_check_lib_save_LIBS=$LIBS
-LIBS="-llua${ver} ${pbxlibdir} -lm $LIBS"
+LIBS="-llua-${ver} ${pbxlibdir} -lm $LIBS"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -29576,7 +29578,7 @@ fi
+@@ -32328,7 +32330,7 @@ fi
# now check for the header.
if test "${AST_LUA_FOUND}" = "yes"; then
@@ -53,18 +54,18 @@
# if --with-LUA=DIR has been specified, use it.
if test "x${LUA_DIR}" != "x"; then
LUA_INCLUDE="-I${LUA_DIR}/include"
-@@ -29586,8 +29588,8 @@ fi
+@@ -32338,8 +32340,8 @@ fi
# check for the header
ast_ext_lib_check_saved_CPPFLAGS="${CPPFLAGS}"
CPPFLAGS="${CPPFLAGS} ${LUA_INCLUDE}"
-- as_ac_Header=`$as_echo "ac_cv_header_lua${ver}/lua.h" | $as_tr_sh`
--ac_fn_c_check_header_mongrel "$LINENO" "lua${ver}/lua.h" "$as_ac_Header" "$ac_includes_default"
-+ as_ac_Header=`$as_echo "ac_cv_header_lua${vernodot}/lua.h" | $as_tr_sh`
-+ac_fn_c_check_header_mongrel "$LINENO" "lua${vernodot}/lua.h" "$as_ac_Header" "$ac_includes_default"
- if eval test \"x\$"$as_ac_Header"\" = x"yes"; then :
+- as_ac_Header=`printf "%s\n" "ac_cv_header_lua${ver}/lua.h" | $as_tr_sh`
+-ac_fn_c_check_header_compile "$LINENO" "lua${ver}/lua.h" "$as_ac_Header" "$ac_includes_default"
++ as_ac_Header=`printf "%s\n" "ac_cv_header_lua${vernodot}/lua.h" | $as_tr_sh`
++ac_fn_c_check_header_compile "$LINENO" "lua${vernodot}/lua.h" "$as_ac_Header" "$ac_includes_default"
+ if eval test \"x\$"$as_ac_Header"\" = x"yes"
+ then :
LUA_HEADER_FOUND=1
- else
-@@ -29614,9 +29616,9 @@ fi
+@@ -32366,9 +32368,9 @@ fi
if test "x${PBX_LUA}" = "x1" ; then
if test x"${LUA_DIR}" = x; then
diff --git a/net/asterisk16/files/patch-main_term.c b/net/asterisk16/files/patch-main_term.c
new file mode 100644
index 000000000000..dc7ede7d4e12
--- /dev/null
+++ b/net/asterisk16/files/patch-main_term.c
@@ -0,0 +1,10 @@
+--- main/term.c.orig 2022-04-14 21:53:34 UTC
++++ main/term.c
+@@ -46,6 +46,7 @@ static const char * const termpath[] = {
+ static char quitdata[80] = "";
+
+ static const char * const termpath[] = {
++ "%%LOCALBASE%%/share/terminfo",
+ "/usr/share/terminfo",
+ "/usr/local/share/misc/terminfo",
+ "/usr/lib/terminfo",
diff --git a/net/asterisk16/pkg-message b/net/asterisk16/pkg-message
index 5b79202b6b21..c32bcc7656ec 100644
--- a/net/asterisk16/pkg-message
+++ b/net/asterisk16/pkg-message
@@ -33,6 +33,10 @@
* https://wiki.asterisk.org/wiki/display/AST/Using+Menuselect+to+Select+Asterisk+Options
* http://www.asteriskdocs.org/en/3rd_Edition/asterisk-book-html-chunk/installing_base_configuration.html#Installing_id293213
+
+ NOTE: To get color output in the asterisk console you need to install
+ the misc/terminfo-db port
+
EOM
}
]