aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-06-27 09:03:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-06-27 09:03:02 +0000
commite9946a7d27c82dbab07c6bd8d37ec10a14692c40 (patch)
tree17869dd3e3b233190a8a1a8bfc5e47cf34bc9d7e
parentf40672c41cf7479c86b77e61e02a2733d97a00e1 (diff)
downloadports-e9946a7d27c82dbab07c6bd8d37ec10a14692c40.tar.gz
ports-e9946a7d27c82dbab07c6bd8d37ec10a14692c40.zip
audio/psindustrializer: Add audio backend options
PR: 256859 Suggested by: p5B2E9A8F@t-online.de
-rw-r--r--audio/psindustrializer/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/audio/psindustrializer/Makefile b/audio/psindustrializer/Makefile
index c5d6c378a188..6f69f724b5c7 100644
--- a/audio/psindustrializer/Makefile
+++ b/audio/psindustrializer/Makefile
@@ -1,6 +1,7 @@
PORTNAME= psindustrializer
DISTVERSION= 0.2.7
DISTVERSIONSUFFIX= -pre2
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/industrializer/
@@ -14,9 +15,7 @@ LIB_DEPENDS= libaudiofile.so:audio/libaudiofile \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libgtkglext-x11-1.0.so:x11-toolkits/gtkglext \
- libharfbuzz.so:print/harfbuzz \
- libjack.so:audio/jack \
- libpulse.so:audio/pulseaudio
+ libharfbuzz.so:print/harfbuzz
USES= gettext-runtime gl gmake gnome libtool pkgconfig tar:xz xorg
USE_GNOME= atk cairo gdkpixbuf2 gtk20 libxml2 pango pangox-compat
@@ -27,6 +26,19 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsa
-INSTALL_TARGET=install-strip
+INSTALL_TARGET= install-strip
+
+OPTIONS_MULTI= BACKEND
+OPTIONS_MULTI_BACKEND= JACK PULSE
+OPTIONS_DEFAULT= PULSE
+
+BACKEND_DESC= Audio Backend
+
+JACK_CONFIGURE_ENABLE= jack
+JACK_LIB_DEPENDS= libjack.so:audio/jack
+
+PULSE_DESC= PulseAudio support
+PULSE_CONFIGURE_ENABLE= pulse
+PULSE_LIB_DEPENDS= libpulse.so:audio/pulseaudio
.include <bsd.port.mk>