aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2024-03-25 15:17:59 +0000
committerBrooks Davis <brooks@FreeBSD.org>2024-03-25 15:19:30 +0000
commite9a704b9b21d08d3402411d37dd4e3b11b7aa9b0 (patch)
tree16c39157f742c49e81471a741ea8d3aa22b1cd18
parent667277248f7eeb1d5a6c2514b1db3d107d13cb16 (diff)
downloadports-e9a704b9b21d08d3402411d37dd4e3b11b7aa9b0.tar.gz
ports-e9a704b9b21d08d3402411d37dd4e3b11b7aa9b0.zip
devel/llvm-devel: add py-pexpect build dep
LLDB now requires pexpect to build. I forgot to add this dependency after completing the rest of the update.
-rw-r--r--devel/llvm-devel/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 93b1635b876a..45c3ae492dc8 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -157,7 +157,9 @@ LIT_DESC= Install lit and FileCheck test tools
LIT_VARS= _USES_PYTHON=python
LIT_PLIST_SUB= LIT_MOD_NAME=${LIT_MOD_NAME}
LLD_DESC= Install lld, the LLVM linker
-LLDB_BUILD_DEPENDS= swig:devel/swig
+LLDB_BUILD_DEPENDS= \
+ {PYTHON_PKGNAMEPREFIX}pexpect>0:misc/py-pexpect@${PY_FLAVOR} \
+ swig:devel/swig
LLDB_DESC= Install lldb, the LLVM debugger
LLDB_IMPLIES= CLANG
LLDB_PLIST_SUB= PYTHON_ABIVER=${PYTHON_ABIVER}