aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLewis Cook <lcook@FreeBSD.org>2023-07-15 16:39:21 +0000
committerLewis Cook <lcook@FreeBSD.org>2023-07-15 16:40:37 +0000
commite9e4112b1ece6e5abd2c6acff78e134d0e0d44bf (patch)
treee18952115ee7169191924b6cff1dc8e08defaef8
parentc01f4e1770f0aa27aaf4bb46f5a63c69b64717ae (diff)
downloadports-e9e4112b1ece6e5abd2c6acff78e134d0e0d44bf.tar.gz
ports-e9e4112b1ece6e5abd2c6acff78e134d0e0d44bf.zip
www/lagrange: Update to 1.16.5
-rw-r--r--www/lagrange/Makefile18
-rw-r--r--www/lagrange/distinfo6
-rw-r--r--www/lagrange/files/patch-lib_the__Foundation_CheckSSE.cmake36
-rw-r--r--www/lagrange/files/patch-lib_the__Foundation_Depends.cmake17
4 files changed, 11 insertions, 66 deletions
diff --git a/www/lagrange/Makefile b/www/lagrange/Makefile
index 8af76b4b7d98..73dddd1179e1 100644
--- a/www/lagrange/Makefile
+++ b/www/lagrange/Makefile
@@ -1,5 +1,5 @@
PORTNAME= lagrange
-DISTVERSION= 1.15.9
+DISTVERSION= 1.16.5
CATEGORIES= www
MASTER_SITES= https://git.skyjake.fi/gemini/${PORTNAME}/releases/download/v${DISTVERSION}/
@@ -10,23 +10,21 @@ WWW= https://gmi.skyjake.fi/lagrange/
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-BROKEN_SSL= libressl openssl30 openssl31
-BROKEN_SSL_REASON_libressl= needs features only available in OpenSSL
-BROKEN_SSL_REASON_openssl30= Fails to build with undefined symbol: ERR_load_BIO_strings
-BROKEN_SSL_REASON_openssl31= Fails to build with undefined symbol: ERR_load_BIO_strings
-
BUILD_DEPENDS= zip>0:archivers/zip
LIB_DEPENDS= libfribidi.so:converters/fribidi \
libharfbuzz.so:print/harfbuzz \
libmpg123.so:audio/mpg123 \
libpcre2-8.so:devel/pcre2 \
- libunistring.so:devel/libunistring
+ libunistring.so:devel/libunistring \
+ libwebp.so:graphics/webp
USES= cmake compiler:c11 desktop-file-utils pkgconfig sdl ssl xorg
-USE_SDL= sdl2
-USE_XORG= x11 xext
-LDFLAGS+= -lssl -lcrypto
+BROKEN_SSL= libressl
+BROKEN_SSL_REASON_libressl= needs features only available in OpenSSL
+
+USE_SDL= sdl2
+USE_XORG= ice sm x11 xext
OPTIONS_DEFINE= SSE41
diff --git a/www/lagrange/distinfo b/www/lagrange/distinfo
index 1626ab93e0bd..75d42456062b 100644
--- a/www/lagrange/distinfo
+++ b/www/lagrange/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1683054333
-SHA256 (lagrange-1.15.9.tar.gz) = 43cb380c19fc51a2b7fda80e49956f1782b5012b6f271d0c3fd24f4dad2df6a6
-SIZE (lagrange-1.15.9.tar.gz) = 9987069
+TIMESTAMP = 1689437065
+SHA256 (lagrange-1.16.5.tar.gz) = c8d37a32d99ff444e4e61d73269f6244e08a5232c91bb97e2b74823dc6e29d53
+SIZE (lagrange-1.16.5.tar.gz) = 10141202
diff --git a/www/lagrange/files/patch-lib_the__Foundation_CheckSSE.cmake b/www/lagrange/files/patch-lib_the__Foundation_CheckSSE.cmake
deleted file mode 100644
index 2cac873b549c..000000000000
--- a/www/lagrange/files/patch-lib_the__Foundation_CheckSSE.cmake
+++ /dev/null
@@ -1,36 +0,0 @@
-Disable SSE4.1 by default and make it opt-in only.
-
-Older class AMD64 and i386 CPUs do not support the
-feature-set, this becomes a problem when a build
-hosts support it, whilst package consumers do not,
-causing an instant crash upon startup.
-
---- lib/the_Foundation/CheckSSE.cmake.orig 2023-05-02 19:35:44 UTC
-+++ lib/the_Foundation/CheckSSE.cmake
-@@ -1,26 +1 @@
- set (SSE41_FOUND NO)
--if (DEFINED TFDN_ENABLE_SSE41 AND NOT TFDN_ENABLE_SSE41)
-- return ()
--endif ()
--
--try_run (
-- sseRunCode
-- sseCompiled
-- ${CMAKE_CURRENT_BINARY_DIR}
-- ${CMAKE_CURRENT_LIST_DIR}/ssecheck.c
-- RUN_OUTPUT_VARIABLE sseOutput
--)
--string (STRIP "${sseOutput}" sseOutput)
--# message (STATUS "sseCompiled: ${sseCompiled}")
--# message (STATUS "sseRunCode: ${sseRunCode}")
--# message (STATUS "sseOutput: ${sseOutput}")
--
--if (sseCompiled AND sseOutput STREQUAL "1")
-- set (SSE41_FOUND YES)
--endif ()
--
--if (SSE41_FOUND)
-- message (STATUS "CPU supports SSE 4.1")
--else ()
-- message (STATUS "CPU does not support SSE 4.1")
--endif ()
diff --git a/www/lagrange/files/patch-lib_the__Foundation_Depends.cmake b/www/lagrange/files/patch-lib_the__Foundation_Depends.cmake
deleted file mode 100644
index 0c374da92768..000000000000
--- a/www/lagrange/files/patch-lib_the__Foundation_Depends.cmake
+++ /dev/null
@@ -1,17 +0,0 @@
---- lib/the_Foundation/Depends.cmake.orig 2023-05-02 20:08:20 UTC
-+++ lib/the_Foundation/Depends.cmake
-@@ -24,13 +24,12 @@ if (NOT IOS AND NOT ANDROID)
- target_link_libraries (libssl INTERFACE ${LIBSSL} ${LIBCRYPTO})
- set (OPENSSL_FOUND YES)
- else ()
-- pkg_check_modules (OPENSSL eopenssl11)
- if (OPENSSL_FOUND)
- set (EOPENSSL_FOUND YES)
- endif ()
- endif ()
- else ()
-- pkg_check_modules (OPENSSL openssl)
-+ find_package (OpenSSL REQUIRED)
- endif ()
- endif ()
- # Unicode text strings