aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-27 13:21:44 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-27 13:21:44 +0000
commitea1f1a378283c4107450456000ad15b2fb38f7bc (patch)
treea9730f51c504e382b76f712c644cca16c76daf47
parent656c1fb5dc8dbbebc13d98dc5564708fe7fbd8d7 (diff)
downloadports-ea1f1a378283c4107450456000ad15b2fb38f7bc.tar.gz
ports-ea1f1a378283c4107450456000ad15b2fb38f7bc.zip
devel/dmlc-core: use clang on architectures without openmp and disable openmp
-rw-r--r--devel/dmlc-core/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/devel/dmlc-core/Makefile b/devel/dmlc-core/Makefile
index dee6e22f06c6..053d2fac69e8 100644
--- a/devel/dmlc-core/Makefile
+++ b/devel/dmlc-core/Makefile
@@ -9,19 +9,15 @@ COMMENT= Common library for scalable and portable distributed machine learning
LICENSE= APACHE20
-USES= cmake
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= dmlc
USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == powerpc
-USES+= compiler:gcc-c++11-lib
-.else
-USES+= compiler:c++11-lang
+.if !exists(/usr/include/omp.h)
+CMAKE_ARGS+= -DUSE_OPENMP:BOOL=OFF
.endif
.include <bsd.port.mk>