aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-01-07 19:21:19 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-01-07 20:40:49 +0000
commitead5a433bb01375f134714d73e5047817f93e00f (patch)
tree60dcfac3e02b9eefe15834d37ed6f59452e3fbd3
parentcf32d424195e2314e3b7eb9f83584af6e697b51c (diff)
downloadports-ead5a433bb01375f134714d73e5047817f93e00f.tar.gz
ports-ead5a433bb01375f134714d73e5047817f93e00f.zip
x11/darktile: New port: Golang terminal emulator from scratch
-rw-r--r--x11/Makefile1
-rw-r--r--x11/darktile/Makefile26
-rw-r--r--x11/darktile/distinfo5
-rw-r--r--x11/darktile/pkg-descr16
4 files changed, 48 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 85d748ae781f..78da8ef01995 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -50,6 +50,7 @@
SUBDIR += cool-retro-term
SUBDIR += coreterminal
SUBDIR += damask
+ SUBDIR += darktile
SUBDIR += deforaos-integration
SUBDIR += deforaos-keyboard
SUBDIR += deforaos-libdesktop
diff --git a/x11/darktile/Makefile b/x11/darktile/Makefile
new file mode 100644
index 000000000000..84eba904c4f7
--- /dev/null
+++ b/x11/darktile/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= darktile
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.0.11
+CATEGORIES= x11
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Golang terminal emulator from scratch
+WWW= https://github.com/liamg/darktile
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libglfw.so:graphics/glfw
+
+USES= gl go:modules pkgconfig xorg
+USE_GL= gl
+USE_XORG= x11 xcursor xi xinerama xrandr xxf86vm
+
+GO_MODULE= github.com/liamg/darktile
+GO_TARGET= ./cmd/darktile \
+ ./cmd/packfont
+
+PLIST_FILES= bin/${PORTNAME} \
+ bin/packfont
+
+.include <bsd.port.mk>
diff --git a/x11/darktile/distinfo b/x11/darktile/distinfo
new file mode 100644
index 000000000000..f4d7a4712951
--- /dev/null
+++ b/x11/darktile/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1704654814
+SHA256 (go/x11_darktile/darktile-v0.0.11/v0.0.11.mod) = 57ea986ff47ce6a2541b42c2d06423ca03055da0d276c9a86146e4ab9c1eb0d4
+SIZE (go/x11_darktile/darktile-v0.0.11/v0.0.11.mod) = 784
+SHA256 (go/x11_darktile/darktile-v0.0.11/v0.0.11.zip) = 56810fe77706e39014754e2c4ecc3f802d1b0843f0595402b5105ccd9e88a285
+SIZE (go/x11_darktile/darktile-v0.0.11/v0.0.11.zip) = 7551233
diff --git a/x11/darktile/pkg-descr b/x11/darktile/pkg-descr
new file mode 100644
index 000000000000..507bd6afa4e9
--- /dev/null
+++ b/x11/darktile/pkg-descr
@@ -0,0 +1,16 @@
+Darktile is a GPU rendered terminal emulator designed for tiling window
+managers.
+
+Features:
+* GPU rendering
+* Unicode support
+* Variety of themes available (or build your own!)
+* Compiled-in powerline font
+* Works with your favourite monospaced TTF/OTF fonts
+* Font ligatures (turn it off if you're not a ligature fan)
+* Hints: Context-aware overlays e.g. hex colour viewer, octal permission
+ annotation
+* Take screenshots with a single key-binding
+* Sixels
+* Window transparency (0-100%)
+* Customisable cursor (most popular image formats supported)