aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2023-07-03 00:02:57 +0000
committerMatthias Andree <mandree@FreeBSD.org>2023-07-09 22:09:05 +0000
commiteadb1e6037c802f9224cc541e4a2d74a0aabf064 (patch)
tree46153362e2082d5150805e437af2e014db8a0834
parent8870a6436d134814a551bb5d30c37a05968d428b (diff)
downloadports-eadb1e6037c802f9224cc541e4a2d74a0aabf064.tar.gz
ports-eadb1e6037c802f9224cc541e4a2d74a0aabf064.zip
graphics/qgis: make compatible with exiv2 0.28
PR: 272311
-rw-r--r--graphics/qgis/Makefile1
-rw-r--r--graphics/qgis/files/patch-src_core_raster_qgsexiftools.cpp38
-rw-r--r--graphics/qgis/pkg-plist1
3 files changed, 40 insertions, 0 deletions
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index fe59a7ba82be..7b23636144c0 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -1,5 +1,6 @@
PORTNAME= qgis
DISTVERSION= 3.32.0
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= https://qgis.org/downloads/
diff --git a/graphics/qgis/files/patch-src_core_raster_qgsexiftools.cpp b/graphics/qgis/files/patch-src_core_raster_qgsexiftools.cpp
new file mode 100644
index 000000000000..20e191c481ee
--- /dev/null
+++ b/graphics/qgis/files/patch-src_core_raster_qgsexiftools.cpp
@@ -0,0 +1,38 @@
+--- src/core/raster/qgsexiftools.cpp.orig 2023-05-26 12:01:43 UTC
++++ src/core/raster/qgsexiftools.cpp
+@@ -66,7 +66,7 @@ QVariant decodeXmpData( const QString &key, Exiv2::Xmp
+ case Exiv2::signedLong:
+ case Exiv2::unsignedLongLong:
+ case Exiv2::signedLongLong:
+- val = QVariant::fromValue( it->toLong() );
++ val = QVariant::fromValue( it->toInt64() );
+ break;
+
+ case Exiv2::tiffDouble:
+@@ -80,7 +80,7 @@ QVariant decodeXmpData( const QString &key, Exiv2::Xmp
+ case Exiv2::signedByte:
+ case Exiv2::tiffIfd:
+ case Exiv2::tiffIfd8:
+- val = QVariant::fromValue( static_cast< int >( it->toLong() ) );
++ val = QVariant::fromValue( static_cast< int >( it->toInt64() ) );
+ break;
+
+ case Exiv2::date:
+@@ -182,7 +182,7 @@ QVariant decodeExifData( const QString &key, Exiv2::Ex
+ case Exiv2::signedLong:
+ case Exiv2::unsignedLongLong:
+ case Exiv2::signedLongLong:
+- val = QVariant::fromValue( it->toLong() );
++ val = QVariant::fromValue( it->toInt64() );
+ break;
+
+ case Exiv2::tiffDouble:
+@@ -196,7 +196,7 @@ QVariant decodeExifData( const QString &key, Exiv2::Ex
+ case Exiv2::signedByte:
+ case Exiv2::tiffIfd:
+ case Exiv2::tiffIfd8:
+- val = QVariant::fromValue( static_cast< int >( it->toLong() ) );
++ val = QVariant::fromValue( static_cast< int >( it->toInt64() ) );
+ break;
+
+ case Exiv2::date:
diff --git a/graphics/qgis/pkg-plist b/graphics/qgis/pkg-plist
index 8c3c4063dd8e..219fbed9ee81 100644
--- a/graphics/qgis/pkg-plist
+++ b/graphics/qgis/pkg-plist
@@ -1,5 +1,6 @@
%%SERVER%%bin/admin.sld
bin/qgis
+bin/qgis_bench
%%SERVER%%bin/qgis_mapserv.fcgi
%%SERVER%%bin/qgis_mapserver
bin/qgis_process