aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Nagy <rnagy@FreeBSD.org>2023-04-11 05:30:15 +0000
committerRobert Nagy <rnagy@FreeBSD.org>2023-04-11 05:30:15 +0000
commiteb0137c80b62d36627495966580bced84518cfea (patch)
tree587afe3082b638df5ff4063a535993b536d13173
parent590f792451dc897562d1ff15414196aa9394a61b (diff)
downloadports-eb0137c80b62d36627495966580bced84518cfea.tar.gz
ports-eb0137c80b62d36627495966580bced84518cfea.zip
www/{*chromium,iridium}: switch to USES=iconv:wchar_t to fixup library deps
Approved by: rene (mentor)
-rw-r--r--www/chromium/Makefile3
-rw-r--r--www/iridium/Makefile4
-rw-r--r--www/ungoogled-chromium/Makefile3
3 files changed, 6 insertions, 4 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 2b50fcb2ab80..f00ed3a7bdb0 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -1,5 +1,6 @@
PORTNAME= chromium
PORTVERSION= 112.0.5615.49
+PORTREVISION= 1
CATEGORIES= www wayland
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
https://nerd.hu/distfiles/:external
@@ -68,7 +69,7 @@ LIB_DEPENDS= libatk-bridge-2.0.so:accessibility/at-spi2-core \
RUN_DEPENDS= xdg-open:devel/xdg-utils \
noto-basic>0:x11-fonts/noto-basic
-USES= bison compiler:c++17-lang cpe desktop-file-utils gl gnome iconv jpeg \
+USES= bison compiler:c++17-lang cpe desktop-file-utils gl gnome iconv:wchar_t jpeg \
localbase:ldflags ninja perl5 pkgconfig python:3.7+,build qt:5 shebangfix \
tar:xz xorg
diff --git a/www/iridium/Makefile b/www/iridium/Makefile
index 75b2465e9f2d..af7d6b001b82 100644
--- a/www/iridium/Makefile
+++ b/www/iridium/Makefile
@@ -1,6 +1,6 @@
PORTNAME= iridium
PORTVERSION= 2023.03.111
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www wayland
MASTER_SITES= https://downloads.iridiumbrowser.de/source/
PKGNAMESUFFIX= -browser
@@ -71,7 +71,7 @@ LIB_DEPENDS= libatk-bridge-2.0.so:accessibility/at-spi2-core \
RUN_DEPENDS= xdg-open:devel/xdg-utils \
noto-basic>0:x11-fonts/noto-basic
-USES= bison compiler:c++17-lang cpe desktop-file-utils gl gnome iconv jpeg \
+USES= bison compiler:c++17-lang cpe desktop-file-utils gl gnome iconv:wchar_t jpeg \
localbase:ldflags ninja perl5 pkgconfig python:3.7+,build qt:5 shebangfix \
tar:xz xorg
diff --git a/www/ungoogled-chromium/Makefile b/www/ungoogled-chromium/Makefile
index bb66f8067267..730ae6392b1b 100644
--- a/www/ungoogled-chromium/Makefile
+++ b/www/ungoogled-chromium/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ungoogled-chromium
PORTVERSION= 112.0.5615.49
+PORTREVISION= 1
UGVERSION= ${DISTVERSION}-1
CATEGORIES= www wayland
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
@@ -72,7 +73,7 @@ LIB_DEPENDS= libatk-bridge-2.0.so:accessibility/at-spi2-core \
RUN_DEPENDS= xdg-open:devel/xdg-utils \
noto-basic>0:x11-fonts/noto-basic
-USES= bison compiler:c++17-lang cpe desktop-file-utils gl gnome iconv jpeg \
+USES= bison compiler:c++17-lang cpe desktop-file-utils gl gnome iconv:wchar_t jpeg \
localbase:ldflags ninja perl5 pkgconfig python:3.7+,build qt:5 shebangfix \
tar:xz xorg