aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-11-20 22:19:19 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-11-20 22:30:28 +0000
commiteb2c8f8f277508cb76b4936ea1b06d41c59294e3 (patch)
tree3227c107f0885a9f05edaa2da87de354b8557ce7
parentba53edfff7f33f38bb7ecf19f813d39ba5729edd (diff)
downloadports-eb2c8f8f277508cb76b4936ea1b06d41c59294e3.tar.gz
ports-eb2c8f8f277508cb76b4936ea1b06d41c59294e3.zip
net-im/nheko: update to 0.9.0, latest upstream
This pulls in an update to mtxclient (which then needs coeurl...). E2E encryption is now fully supported (but not audited). There is VOIP support which is switched off right now because our gstreamer seems to be too old.
-rw-r--r--net-im/mtxclient/Makefile13
-rw-r--r--net-im/mtxclient/distinfo6
-rw-r--r--net-im/mtxclient/files/patch-lib_crypto_client.cpp21
-rw-r--r--net-im/mtxclient/pkg-plist5
-rw-r--r--net-im/nheko/Makefile16
-rw-r--r--net-im/nheko/distinfo6
6 files changed, 18 insertions, 49 deletions
diff --git a/net-im/mtxclient/Makefile b/net-im/mtxclient/Makefile
index 80018d91262a..b9b7d0c048aa 100644
--- a/net-im/mtxclient/Makefile
+++ b/net-im/mtxclient/Makefile
@@ -1,7 +1,6 @@
PORTNAME= mtxclient
DISTVERSIONPREFIX= v
-DISTVERSION= 0.5.1
-PORTREVISION= 1
+DISTVERSION= 0.6.0
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@@ -11,14 +10,10 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json
-LIB_DEPENDS= libsodium.so:security/libsodium \
- libboost_date_time.so:devel/boost-libs \
- libboost_chrono.so:devel/boost-libs \
- libboost_iostreams.so:devel/boost-libs \
- libboost_regex.so:devel/boost-libs \
- libboost_system.so:devel/boost-libs \
- libboost_thread.so:devel/boost-libs \
+LIB_DEPENDS= \
+ libcoeurl.so:ftp/coeurl \
libolm.so:security/olm \
+ libsodium.so:security/libsodium \
libspdlog.so:devel/spdlog
USES= cmake compiler:c++17-lang pkgconfig ssl \
diff --git a/net-im/mtxclient/distinfo b/net-im/mtxclient/distinfo
index 25b6be0ad72a..39943e35643c 100644
--- a/net-im/mtxclient/distinfo
+++ b/net-im/mtxclient/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1635443137
-SHA256 (Nheko-Reborn-mtxclient-v0.5.1_GH0.tar.gz) = 9478d870296ebe7679c90f563cb798eb3cdd3f9c4578ceea5af75b66f456baaa
-SIZE (Nheko-Reborn-mtxclient-v0.5.1_GH0.tar.gz) = 582367
+TIMESTAMP = 1637417996
+SHA256 (Nheko-Reborn-mtxclient-v0.6.0_GH0.tar.gz) = 4245feb0bd4ae8e026c01f546a6bea45bc9d9d57d13430b8ba446b0aec4915c4
+SIZE (Nheko-Reborn-mtxclient-v0.6.0_GH0.tar.gz) = 593602
diff --git a/net-im/mtxclient/files/patch-lib_crypto_client.cpp b/net-im/mtxclient/files/patch-lib_crypto_client.cpp
deleted file mode 100644
index 83412307b762..000000000000
--- a/net-im/mtxclient/files/patch-lib_crypto_client.cpp
+++ /dev/null
@@ -1,21 +0,0 @@
---- lib/crypto/client.cpp.orig 2021-10-28 17:44:28 UTC
-+++ lib/crypto/client.cpp
-@@ -37,15 +37,15 @@ static const std::array olmErrorStrings{
-
- };
-
--OlmErrorCode
-+mtx::crypto::OlmErrorCode
- olm_exception::ec_from_string(std::string_view error)
- {
- for (size_t i = 0; i < olmErrorStrings.size(); i++) {
- if (olmErrorStrings[i] == error)
-- return static_cast<OlmErrorCode>(i);
-+ return static_cast<mtx::crypto::OlmErrorCode>(i);
- }
-
-- return OlmErrorCode::UNKNOWN_ERROR;
-+ return mtx::crypto::OlmErrorCode::UNKNOWN_ERROR;
- }
-
- void
diff --git a/net-im/mtxclient/pkg-plist b/net-im/mtxclient/pkg-plist
index 11c806a2efbb..2a5caddac874 100644
--- a/net-im/mtxclient/pkg-plist
+++ b/net-im/mtxclient/pkg-plist
@@ -22,6 +22,7 @@ include/mtx/events/messages/audio.hpp
include/mtx/events/messages/emote.hpp
include/mtx/events/messages/file.hpp
include/mtx/events/messages/image.hpp
+include/mtx/events/messages/location.hpp
include/mtx/events/messages/notice.hpp
include/mtx/events/messages/text.hpp
include/mtx/events/messages/video.hpp
@@ -33,6 +34,7 @@ include/mtx/events/power_levels.hpp
include/mtx/events/presence.hpp
include/mtx/events/reaction.hpp
include/mtx/events/redaction.hpp
+include/mtx/events/spaces.hpp
include/mtx/events/tag.hpp
include/mtx/events/tombstone.hpp
include/mtx/events/topic.hpp
@@ -48,6 +50,7 @@ include/mtx/responses.hpp
include/mtx/responses/common.hpp
include/mtx/responses/create_room.hpp
include/mtx/responses/crypto.hpp
+include/mtx/responses/device.hpp
include/mtx/responses/empty.hpp
include/mtx/responses/groups.hpp
include/mtx/responses/login.hpp
@@ -67,11 +70,9 @@ include/mtxclient/crypto/client.hpp
include/mtxclient/crypto/objects.hpp
include/mtxclient/crypto/types.hpp
include/mtxclient/crypto/utils.hpp
-include/mtxclient/http/asio_overrides.hpp
include/mtxclient/http/client.hpp
include/mtxclient/http/client_impl.hpp
include/mtxclient/http/errors.hpp
-include/mtxclient/http/session.hpp
include/mtxclient/utils.hpp
lib/cmake/MatrixClient/MatrixClientConfig.cmake
lib/cmake/MatrixClient/MatrixClientConfigVersion.cmake
diff --git a/net-im/nheko/Makefile b/net-im/nheko/Makefile
index 4e0892baef42..4bb2aa4f3457 100644
--- a/net-im/nheko/Makefile
+++ b/net-im/nheko/Makefile
@@ -1,7 +1,6 @@
PORTNAME= nheko
DISTVERSIONPREFIX=v
-DISTVERSION= 0.8.2
-PORTREVISION= 4
+DISTVERSION= 0.9.0
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@@ -14,13 +13,8 @@ BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json
# All those boost-libs are pulled in through mtxclient, which
# links to them but stage-qa still complains.
LIB_DEPENDS= \
- libboost_chrono.so:devel/boost-libs \
- libboost_date_time.so:devel/boost-libs \
- libboost_iostreams.so:devel/boost-libs \
- libboost_regex.so:devel/boost-libs \
- libboost_system.so:devel/boost-libs \
- libboost_thread.so:devel/boost-libs \
libcmark.so:textproc/cmark \
+ libcoeurl.so:ftp/coeurl \
libfmt.so:devel/libfmt \
liblmdb.so:databases/lmdb \
libmatrix_client.so:net-im/mtxclient \
@@ -28,8 +22,8 @@ LIB_DEPENDS= \
libqt5keychain.so:security/qtkeychain \
libspdlog.so:devel/spdlog
-USES= cmake compiler:c++17-lang pkgconfig \
- localbase:ldflags qt:5 ssl tar:xz
+USES= cmake compiler:c++17-lang desktop-file-utils \
+ localbase:ldflags pkgconfig qt:5 ssl tar:xz
USE_QT= concurrent core dbus declarative gui multimedia network \
quickcontrols2 svg widgets \
graphicaleffects_run \
@@ -37,7 +31,7 @@ USE_QT= concurrent core dbus declarative gui multimedia network \
# There is one external dependencie: lmdb++
# - lmdb++ is a single header file, it just needs to be included
-CMAKE_ARGS= -DLMDBXX_INCLUDE_DIR=${WRKSRC}/deps/lmdb
+CMAKE_ARGS= -DLMDBXX_INCLUDE_DIR=${WRKSRC}/deps/lmdb -DVOIP=OFF
CFLAGS+= -DSPDLOG_FMT_EXTERNAL=1
LDFLAGS+= -L${LOCALBASE}/lib -lfmt
diff --git a/net-im/nheko/distinfo b/net-im/nheko/distinfo
index 47e12fe616e9..90c16e52dc6b 100644
--- a/net-im/nheko/distinfo
+++ b/net-im/nheko/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1619428220
-SHA256 (Nheko-Reborn-nheko-v0.8.2_GH0.tar.gz) = df4575c47daab47d418637a4637b599e3848dd749132ca1e92f981d9212eabb2
-SIZE (Nheko-Reborn-nheko-v0.8.2_GH0.tar.gz) = 1232245
+TIMESTAMP = 1637416915
+SHA256 (Nheko-Reborn-nheko-v0.9.0_GH0.tar.gz) = 309505f13d3b65ea23c0db19e59e469905b1ae437d2d6c7d1b496ac0921fb141
+SIZE (Nheko-Reborn-nheko-v0.9.0_GH0.tar.gz) = 1398941
SHA256 (hoytech-lmdbxx-029fb681213af3020f5e3a86045445552bd024c5_GH0.tar.gz) = f1d048d7ec720667a3ea091ed44f06eb79171e77d646a59dac45b9e5ff75f33b
SIZE (hoytech-lmdbxx-029fb681213af3020f5e3a86045445552bd024c5_GH0.tar.gz) = 52468