aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-01-31 15:17:52 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-01-31 15:17:52 +0000
commiteb340a643efc7a5d40858fb9abc059bb9face05c (patch)
treeb654a2bcf5e2d59a39bc2429d9a05b6e399da21e
parent79faae646a94eae357a955659fa7c41417a9c2a0 (diff)
downloadports-eb340a643efc7a5d40858fb9abc059bb9face05c.tar.gz
ports-eb340a643efc7a5d40858fb9abc059bb9face05c.zip
biology/wfa2-lib: Unbreak build on aarch64, probably others
Patch out hard-coded -march=native, not supported by clang aarch64 Reported by: pkg-fallout
-rw-r--r--biology/wfa2-lib/Makefile1
-rw-r--r--biology/wfa2-lib/files/patch-CMakeLists.txt11
2 files changed, 12 insertions, 0 deletions
diff --git a/biology/wfa2-lib/Makefile b/biology/wfa2-lib/Makefile
index cb334b9bf0c3..2300f379ec6f 100644
--- a/biology/wfa2-lib/Makefile
+++ b/biology/wfa2-lib/Makefile
@@ -1,6 +1,7 @@
PORTNAME= wfa2-lib
DISTVERSIONPREFIX= v
DISTVERSION= 2.3.2
+PORTREVISION= 1
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
diff --git a/biology/wfa2-lib/files/patch-CMakeLists.txt b/biology/wfa2-lib/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..8b71ad656f0a
--- /dev/null
+++ b/biology/wfa2-lib/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2023-01-31 15:02:27 UTC
++++ CMakeLists.txt
+@@ -55,7 +55,7 @@ if(NOT CMAKE_BUILD_TYPE)
+ endif()
+
+ if (${CMAKE_BUILD_TYPE} MATCHES Release)
+- set(OPTIMIZE_FLAGS "${OPTIMIZE_FLAGS} -march=native -D_FILE_OFFSET_BITS=64")
++ set(OPTIMIZE_FLAGS "${OPTIMIZE_FLAGS} -D_FILE_OFFSET_BITS=64")
+ endif()
+
+ if ((${CMAKE_BUILD_TYPE} MATCHES Release) OR (${CMAKE_BUILD_TYPE} MATCHES RelWithDebInfo))