aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 23:24:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 23:44:07 +0000
commiteb436378224a1565912bbe4c175ee81ad5906054 (patch)
treed046338c6fe3bd80e61c28566dbff36bf6088f52
parentfe487292fe61af367aa8bf96f9e73cd75a1acfa2 (diff)
downloadports-eb436378224a1565912bbe4c175ee81ad5906054.tar.gz
ports-eb436378224a1565912bbe4c175ee81ad5906054.zip
print/py-fonttools: Update
- Build and install extra modules - Add USE_PYTHON=cython - Remove NO_ARCH - Strip shared library - Update manpage location (003a571d1d6585196545295efc181514f171c4c4, r523104) - Bump PORTREVISION for dependency and package change
-rw-r--r--print/py-fonttools/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/print/py-fonttools/Makefile b/print/py-fonttools/Makefile
index 1e648e42a20c..366d2e342744 100644
--- a/print/py-fonttools/Makefile
+++ b/print/py-fonttools/Makefile
@@ -1,5 +1,6 @@
PORTNAME= fonttools
PORTVERSION= 4.39.4
+PORTREVISION= 1
CATEGORIES= print python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,10 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ufolib2>=0:print/py-ufolib2@${PY_FLAVOR}
USES= python:3.7+ zip
-USE_PYTHON= autoplist concurrent distutils
-
-MAKE_ENV= FONTTOOLS_MANPATH="man"
-NO_ARCH= yes
+USE_PYTHON= autoplist concurrent cython distutils
OPTIONS_DEFINE= GRAPHITE INTERPOLATABLE LXML PLOT REPACKER SYMFONT UFO UNICODE WOFF
OPTIONS_DEFAULT=LXML UFO UNICODE
@@ -47,4 +45,7 @@ WOFF_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}brotli>=1.0.1:archivers/py-brotli@${PY_
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}unicodedata2>=15.0.0:devel/py-unicodedata2@${PY_FLAVOR}
.endif
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
.include <bsd.port.post.mk>