aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonald Klop <ronald-lists@klop.ws>2021-08-05 07:54:49 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-08-05 07:54:49 +0000
commitebd908b18a541438ff40eb2357885ea33f0359eb (patch)
treea790c01ebf8570afe357ae52c3eeb42346df4773
parent262409455f118d2e98a99f5f412a21dfaf658a81 (diff)
downloadports-ebd908b18a541438ff40eb2357885ea33f0359eb.tar.gz
ports-ebd908b18a541438ff40eb2357885ea33f0359eb.zip
databases/mongodb42: Update to 4.2.15
-rw-r--r--databases/mongodb42/Makefile6
-rw-r--r--databases/mongodb42/distinfo6
-rw-r--r--databases/mongodb42/files/patch-SConstruct18
3 files changed, 21 insertions, 9 deletions
diff --git a/databases/mongodb42/Makefile b/databases/mongodb42/Makefile
index 7d5c9fe391e4..26f7e9247f89 100644
--- a/databases/mongodb42/Makefile
+++ b/databases/mongodb42/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mongodb
DISTVERSIONPREFIX= r
-DISTVERSION= 4.2.14
+DISTVERSION= 4.2.15
CATEGORIES= databases net
MASTER_SITES= https://fastdl.mongodb.org/src/ \
http://fastdl.mongodb.org/src/
@@ -29,7 +29,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libcurl.so:ftp/curl \
libsnappy.so:archivers/snappy
-USES= compiler:c++17-lang cpe python:3.5+,build scons
+USES= compiler:c++17-lang cpe python:3.5+,build scons shebangfix
USE_RC_SUBR= mongod
CONFLICTS_BUILD= mongo-cxx-driver
@@ -38,6 +38,8 @@ CONFLICTS_INSTALL= mongodb36 mongodb4[04]
OPTIONS_DEFINE= LTO SASL SSL
OPTIONS_DEFAULT=LTO SASL SSL
+SHEBANG_FILES= src/mongo/installer/compass/install_compass
+python_OLD_CMD= @python_interpreter@
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
--use-system-zlib \
--use-system-pcre \
diff --git a/databases/mongodb42/distinfo b/databases/mongodb42/distinfo
index 2586859a4786..565217003185 100644
--- a/databases/mongodb42/distinfo
+++ b/databases/mongodb42/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620128994
-SHA256 (mongodb-src-r4.2.14.tar.gz) = f804f0d2eb8d7f19911fbef320719a42d19f8f11a4fb9b85695b7ec39ca00cab
-SIZE (mongodb-src-r4.2.14.tar.gz) = 62132935
+TIMESTAMP = 1626038087
+SHA256 (mongodb-src-r4.2.15.tar.gz) = 22f704dd35c0abe182cfd244ce08f43783c1ece6be23e47a6f1872798c312deb
+SIZE (mongodb-src-r4.2.15.tar.gz) = 62187847
diff --git a/databases/mongodb42/files/patch-SConstruct b/databases/mongodb42/files/patch-SConstruct
index 011674b57ac9..47fc2da88d30 100644
--- a/databases/mongodb42/files/patch-SConstruct
+++ b/databases/mongodb42/files/patch-SConstruct
@@ -1,6 +1,6 @@
---- SConstruct.orig 2019-08-08 20:06:23 UTC
+--- SConstruct.orig 2021-06-30 17:39:08 UTC
+++ SConstruct
-@@ -1068,9 +1068,9 @@ if has_option('variables-help'):
+@@ -1092,9 +1092,9 @@ if has_option('variables-help'):
print((env_vars.GenerateHelpText(env)))
Exit(0)
@@ -13,7 +13,7 @@
def set_config_header_define(env, varname, varval = 1):
env['CONFIG_HEADER_DEFINES'][varname] = varval
-@@ -1851,7 +1851,7 @@ if env.TargetOSIs('posix'):
+@@ -1884,7 +1884,7 @@ if env.TargetOSIs('posix'):
# If runtime hardening is requested, then build anything
# destined for an executable with the necessary flags for PIE.
env.AppendUnique(
@@ -22,7 +22,7 @@
PROGLINKFLAGS=['-pie'],
)
-@@ -1865,7 +1865,7 @@ if env.TargetOSIs('posix'):
+@@ -1898,7 +1898,7 @@ if env.TargetOSIs('posix'):
"-Wno-unknown-pragmas",
"-Winvalid-pch"] )
# env.Append( " -Wconversion" ) TODO: this doesn't really work yet
@@ -31,3 +31,13 @@
if not has_option("disable-warnings-as-errors"):
env.Append( CCFLAGS=["-Werror"] )
+@@ -3627,7 +3627,8 @@ def doConfigure(myenv):
+ myenv = conf.Finish()
+
+ if env['TARGET_ARCH'] == "aarch64":
+- AddToCCFLAGSIfSupported(myenv, "-moutline-atomics")
++ # https://lists.freebsd.org/archives/freebsd-ports/2021-July/000431.html
++ AddToCCFLAGSIfSupported(myenv, "-mno-outline-atomics")
+
+ return myenv
+