aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2024-05-30 05:55:16 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2024-05-30 05:58:48 +0000
commitebe45e7ceb45c5f3b2ff91433942d06ff1fd837f (patch)
treee152a7d3537fb2ccbb4287fe7e4ca70cd7c9e862
parentd2749ec0735c69172fa362082cdf06ced5f259fe (diff)
downloadports-ebe45e7ceb45c5f3b2ff91433942d06ff1fd837f.tar.gz
ports-ebe45e7ceb45c5f3b2ff91433942d06ff1fd837f.zip
deskutils/calibre: Remove Python 3.9 compatibility patches
Align minimum Python requirement with upstream, not that 3.11 is the default. Removed patches to make it compatible with 3.9.
-rw-r--r--deskutils/calibre/Makefile3
-rw-r--r--deskutils/calibre/files/patch-src_calibre_db_cache.py11
-rw-r--r--deskutils/calibre/files/patch-src_calibre_db_notes_exim.py11
3 files changed, 2 insertions, 23 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index a7efa6a8b51c..b65ce3a76bc9 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -1,5 +1,6 @@
PORTNAME= calibre
PORTVERSION= 7.11.0
+PORTREVISION= 1
CATEGORIES= deskutils python
MASTER_SITES= http://download.calibre-ebook.com/${PORTVERSION}/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -61,7 +62,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}apsw>=3.43.0.0:databases/py-apsw@${PY_FLAVO
xdg-open:devel/xdg-utils
USES= desktop-file-utils gettext-runtime:build gl localbase:ldflags \
- pkgconfig pyqt:6 python qt:6 shared-mime-info shebangfix sqlite ssl \
+ pkgconfig pyqt:6 python:3.11+ qt:6 shared-mime-info shebangfix sqlite ssl \
tar:xz xorg
USE_GL= opengl
USE_PYQT= pyqt6 pysip qtbuilder sip webengine
diff --git a/deskutils/calibre/files/patch-src_calibre_db_cache.py b/deskutils/calibre/files/patch-src_calibre_db_cache.py
deleted file mode 100644
index fc499931f82e..000000000000
--- a/deskutils/calibre/files/patch-src_calibre_db_cache.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/calibre/db/cache.py.orig 2023-11-17 06:02:05 UTC
-+++ src/calibre/db/cache.py
-@@ -687,7 +687,7 @@ class Cache:
- return self.backend.notes_data_for(field, item_id)
-
- @read_api
-- def get_all_items_that_have_notes(self, field_name=None) -> set[int] | dict[str, set[int]]:
-+ def get_all_items_that_have_notes(self, field_name=None) -> "set[int] | dict[str, set[int]]":
- ' Return all item_ids for items that have notes in the specified field or all fields if field_name is None '
- return self.backend.get_all_items_that_have_notes(field_name)
-
diff --git a/deskutils/calibre/files/patch-src_calibre_db_notes_exim.py b/deskutils/calibre/files/patch-src_calibre_db_notes_exim.py
deleted file mode 100644
index 5df66446d3d3..000000000000
--- a/deskutils/calibre/files/patch-src_calibre_db_notes_exim.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/calibre/db/notes/exim.py.orig 2023-11-17 06:02:05 UTC
-+++ src/calibre/db/notes/exim.py
-@@ -41,7 +41,7 @@ def export_note(note_doc: str, get_resource) -> str:
- return html.tostring(root, encoding='unicode')
-
-
--def import_note(shtml: str | bytes, basedir: str, add_resource) -> tuple[str, str, set[str]]:
-+def import_note(shtml: "str | bytes", basedir: str, add_resource) -> tuple[str, str, set[str]]:
- shtml = xml_to_unicode(shtml, strip_encoding_pats=True, assume_utf8=True)[0]
- basedir = os.path.normcase(get_long_path_name(os.path.abspath(basedir)) + os.sep)
- root = parse_html(shtml)