aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-07-02 17:33:00 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-07-02 17:33:00 +0000
commitec3fcf55ba7b3d3570a342f364ee1026956ef615 (patch)
treec19d5914474fad5e47a62c0d41c5e07234d6d3d8
parent8b48d38ecee37869f24ce0cb1c7ec43037d9d479 (diff)
downloadports-ec3fcf55ba7b3d3570a342f364ee1026956ef615.tar.gz
ports-ec3fcf55ba7b3d3570a342f364ee1026956ef615.zip
math/dsdp: fix the shared library
PR: 256938 Approved by: yuri (maintainer)
-rw-r--r--math/dsdp/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/math/dsdp/Makefile b/math/dsdp/Makefile
index 45df457c53c6..e130396ed9da 100644
--- a/math/dsdp/Makefile
+++ b/math/dsdp/Makefile
@@ -1,6 +1,6 @@
PORTNAME= dsdp
DISTVERSION= 5.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= https://www.mcs.anl.gov/hs/software/${PORTNAME:tu}/
DISTNAME= ${PORTNAME:tu}${DISTVERSION}
@@ -31,6 +31,7 @@ PLIST_FILES= bin/dsdp5 \
include/dsdp/dsdplapack.h \
include/dsdp/dsdpmem.h \
include/dsdp/dsdpsys.h \
+ lib/libdsdp.so.0 \
lib/libdsdp.so
do-build: # the build fails to build all binaries without being called twice due to makefile convolution
@@ -40,7 +41,8 @@ do-build: # the build fails to build all binaries without being called twice due
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/dsdp
${INSTALL_PROGRAM} ${WRKSRC}/bin/dsdp5 ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_LIB} ${WRKSRC}/lib/libdsdp.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/lib/libdsdp.so ${STAGEDIR}${PREFIX}/lib/libdsdp.so.0
+ (cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s libdsdp.so.0 libdsdp.so)
${INSTALL_DATA} ${WRKSRC}/include/*.h ${STAGEDIR}${PREFIX}/include/dsdp
.include <bsd.port.mk>