aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-05-06 12:19:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-05-06 12:23:36 +0000
commitec55e2f5214a088ac0c052c2102bc85fb80947c5 (patch)
tree6ab770a578a31094c8d905147a4af55f271cf968
parent5be116444693389c61fe2cc56d8add238c2f5199 (diff)
downloadports-ec55e2f5214a088ac0c052c2102bc85fb80947c5.tar.gz
ports-ec55e2f5214a088ac0c052c2102bc85fb80947c5.zip
net-mgmt/mbrowse: reduce overlinking and remove pkg dep
First no ports should ever be depending on pkg directly because it prevents building with WITH_PKG=devel, they should depend on ${PKG_ORIGIN}. Second, netsnmp do not expose the pkg API but only consume it, so program linking to netsnmp should not end up being directly linked to libpkg! Patch the configure script to stop asking net-snmp-config for extra libs which will faultly bring in linking against -lpkg and -lelf, and remove entirely libpkg as a dependency on the package
-rw-r--r--net-mgmt/mbrowse/Makefile8
-rw-r--r--net-mgmt/mbrowse/files/patch-configure12
2 files changed, 14 insertions, 6 deletions
diff --git a/net-mgmt/mbrowse/Makefile b/net-mgmt/mbrowse/Makefile
index b06c8224f5d9..986765ca92c6 100644
--- a/net-mgmt/mbrowse/Makefile
+++ b/net-mgmt/mbrowse/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mbrowse
PORTVERSION= 0.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
@@ -13,8 +13,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp \
libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2 \
- libpkg.so:ports-mgmt/pkg
+ libfreetype.so:print/freetype2
USES= gnome pkgconfig ssl
USE_GNOME= cairo gdkpixbuf2 gtk20
@@ -22,9 +21,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-snmp-prefix=${PREFIX} --with-snmp-type=net
-CPPFLAGS+= `net-snmp-config --cflags`
-LDFLAGS+= `net-snmp-config --libs`
-
PLIST_FILES= bin/mbrowse
.include <bsd.port.mk>
diff --git a/net-mgmt/mbrowse/files/patch-configure b/net-mgmt/mbrowse/files/patch-configure
new file mode 100644
index 000000000000..4a7bba697d6e
--- /dev/null
+++ b/net-mgmt/mbrowse/files/patch-configure
@@ -0,0 +1,12 @@
+--- configure.orig 2011-01-28 12:10:11 UTC
++++ configure
+@@ -5354,8 +5354,7 @@ $as_echo_n "checking for snmp-type... " >&6; }
+ if test "x$snmp_prefix" != "x" ; then
+ if test -x "$snmp_prefix/bin/net-snmp-config" ; then
+ SNMP_NET_LIBS=`$snmp_prefix/bin/net-snmp-config --netsnmp-libs`
+- SNMP_EXT_LIBS=`$snmp_prefix/bin/net-snmp-config --external-libs`
+- SNMP_LIBS="$SNMP_NET_LIBS $SNMP_EXT_LIBS"
++ SNMP_LIBS="$SNMP_NET_LIBS"
+ SNMP_CFLAGS="$SNMP_CFLAGS -DHAVE_NETSNMP"
+ else
+ guess_type="ucd"