aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-05-06 20:37:10 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-05-06 21:00:01 +0000
commitec8086c7b0a2a4a690da5efde8aa1df4555a8f58 (patch)
tree344cf0830346ce7028525a0964a36d77e92cb171
parentd1755a0e8502d47300996e72a868b578a499a07b (diff)
downloadports-ec8086c7b0a2a4a690da5efde8aa1df4555a8f58.tar.gz
ports-ec8086c7b0a2a4a690da5efde8aa1df4555a8f58.zip
math/sympow: respect user-provided CFLAGS
And also resolve a warning when building data files.
-rw-r--r--math/sympow/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/math/sympow/Makefile b/math/sympow/Makefile
index 8d3f73bdcae6..821c1a95c4d5 100644
--- a/math/sympow/Makefile
+++ b/math/sympow/Makefile
@@ -2,8 +2,8 @@
PORTNAME= sympow
PORTVERSION= 2.023.6
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= thierry@FreeBSD.org
@@ -25,11 +25,16 @@ GL_COMMIT= 7fd4d97cabc07951200b98ee841afc4151c2c287
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
+CONFIGURE_ENV= CFLAGS="${CFLAGS}"
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|-O3 ||' ${WRKSRC}/${CONFIGURE_SCRIPT}
post-build:
- mkdir -p ${WRKDIR}/home
+ ${MKDIR} ${WRKDIR}/home ${WRKDIR}/var/cache/sympow/datafiles
for file in `${LS} ${WRKSRC}/datafiles/*.txt`; do \
- env HOME=${WRKDIR}/home ${WRKSRC}/sympow -txt2bin "`${GREP} -c AT $${file}`" <$${file} $${file%txt}bin; \
+ ${SETENV} HOME=${WRKDIR}/home SYMPOW_PKGCACHEDIR="${WRKDIR}/var/cache/sympow" \
+ ${WRKSRC}/sympow -txt2bin "`${GREP} -c AT $${file}`" <$${file} $${file%txt}bin; \
done
post-install: