aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-10 12:52:55 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-10 12:52:55 +0000
commitecaea182fad3e8fd41af193c1721b5e272d73bbe (patch)
tree7b121bfa7c521575607258b643b5ccf0f5bcb312
parent0da3feba78437ddde7a9d5310903f71d14aa5e75 (diff)
downloadports-ecaea182fad3e8fd41af193c1721b5e272d73bbe.tar.gz
ports-ecaea182fad3e8fd41af193c1721b5e272d73bbe.zip
devel/libdatadog: Simplify Makefile
-rw-r--r--devel/libdatadog/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/libdatadog/Makefile b/devel/libdatadog/Makefile
index 41b254b232c5..8776ed92577e 100644
--- a/devel/libdatadog/Makefile
+++ b/devel/libdatadog/Makefile
@@ -162,14 +162,14 @@ post-patch:
${SED} -e 's|@DDog_VERSION@|${PORTVERSION}|' ${WRKSRC}/profiling-ffi/datadog_profiling_with_rpath.pc.in > ${WRKSRC}/datadog_profiling_with_rpath.pc
post-build:
- @cd ${WRKSRC} && cbindgen --crate ddcommon-ffi --config ddcommon-ffi/cbindgen.toml --output ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/include/datadog/common.h
- @cd ${WRKSRC} && cbindgen --crate datadog-profiling-ffi --config profiling-ffi/cbindgen.toml --output ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/include/datadog/profiling.h
- @${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/release/dedup_headers ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/include/datadog/common.h ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/include/datadog/profiling.h
+ @cd ${WRKSRC} && cbindgen --crate ddcommon-ffi --config ddcommon-ffi/cbindgen.toml --output ${WRKSRC}/common.h
+ @cd ${WRKSRC} && cbindgen --crate datadog-profiling-ffi --config profiling-ffi/cbindgen.toml --output ${WRKSRC}/profiling.h
+ @${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/release/dedup_headers ${WRKSRC}/common.h ${WRKSRC}/profiling.h
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/datadog/
${MKDIR} ${STAGEDIR}${PREFIX}/libdata/pkgconfig/
- ${INSTALL_DATA} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/include/datadog/*.h ${STAGEDIR}${PREFIX}/include/datadog/
+ ${INSTALL_DATA} ${WRKSRC}/common.h ${WRKSRC}/profiling.h ${STAGEDIR}${PREFIX}/include/datadog/
${INSTALL_DATA} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/release/libdatadog_profiling_ffi.a ${STAGEDIR}${PREFIX}/lib/
${INSTALL_LIB} ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/release/libdatadog_profiling_ffi.so ${STAGEDIR}${PREFIX}/lib/
${INSTALL_DATA} ${WRKSRC}/datadog_profiling*.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/