aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-04 04:46:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-04 05:13:08 +0000
commitecd20221e83e8d746d56685c86ca1e138548adee (patch)
treece05be8ae5616a76778c8bd3f466616259041bc1
parent866f06f1596aa688d63f919ec5e28fe6bad187cb (diff)
downloadports-ecd20221e83e8d746d56685c86ca1e138548adee.tar.gz
ports-ecd20221e83e8d746d56685c86ca1e138548adee.zip
math/ensmallen: Fix tests
-rw-r--r--math/ensmallen/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/math/ensmallen/Makefile b/math/ensmallen/Makefile
index 3672862896fd..463b2f26c926 100644
--- a/math/ensmallen/Makefile
+++ b/math/ensmallen/Makefile
@@ -13,15 +13,14 @@ BUILD_DEPENDS= ${LOCALBASE}/include/armadillo_bits/config.hpp:math/armadillo
RUN_DEPENDS= ${LOCALBASE}/include/armadillo_bits/config.hpp:math/armadillo
USES= cmake compiler:c++11-lang localbase
-CMAKE_OFF= BUILD_TESTS
+CMAKE_ON= BUILD_TESTS # will be removed
NO_BUILD= yes
NO_ARCH= yes
-do-test: # due to a regression the test executable isn't built, see https://github.com/mlpack/ensmallen/issues/312
+do-test:
@cd ${BUILD_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ensmallen_tests && \
+ ./ensmallen_tests
.include <bsd.port.mk>