aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-07-27 19:25:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-27 19:26:35 +0000
commited2471eb113a28112b33111fd0c53f1ee554c2f0 (patch)
tree8e16f9d078c767acd81db7d9c82b1035f5d55ec5
parentdc9b2008be0178312c3f2813310942d61db0dfed (diff)
downloadports-ed2471eb113a28112b33111fd0c53f1ee554c2f0.tar.gz
ports-ed2471eb113a28112b33111fd0c53f1ee554c2f0.zip
math/gismo: Fix build on armv6/armv7
PR: 265467 (cherry picked from commit cc4c20c65b775f0a95be0fd92c887150b6266676)
-rw-r--r--math/gismo/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/math/gismo/Makefile b/math/gismo/Makefile
index 8e475658d7fc..185fea56b531 100644
--- a/math/gismo/Makefile
+++ b/math/gismo/Makefile
@@ -9,8 +9,6 @@ COMMENT= C++ library for isogeometric analysis (IGA)
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BROKEN_armv7= unknown target architecture: "generic". Please set TARGET_ARCHITECTURE to a supported value, see https://github.com/gismo/gismo/issues/541
-
USES= cmake:testing compiler:c++14-lang
USE_GITHUB= yes
USE_GCC= yes # clang-11 crashes: https://bugs.llvm.org/show_bug.cgi?id=51468
@@ -27,6 +25,11 @@ GH_TUPLE= gismo:gsElasticity:a94347d:gsElasticity/extensions/gsElasticity \
.if ${ARCH} == aarch64
CMAKE_ARGS+= -DTARGET_ARCHITECTURE="cortex-a53"
+.elif ${ARCH} == armv6
+# Raspberry Pi 1, the only supported armv6 target
+CMAKE_ARGS+= -DTARGET_ARCHITECTURE="arm1176jzf-s"
+.elif ${ARCH} == armv7
+CMAKE_ARGS+= -DTARGET_ARCHITECTURE="cortex-a7"
.endif
.include <bsd.port.post.mk>