aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesús Daniel Colmenares Oviedo <DtxdF@riseup.net>2022-08-18 19:33:22 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-08-20 03:36:48 +0000
commited5b9ccf964d53da04bf7deae22244890b9d1548 (patch)
tree3e5e5cc027adba7894f2a4a94e82f585b308b2ba
parent56fcee100c534084730a5c2070f1ce41b4b69212 (diff)
downloadports-ed5b9ccf964d53da04bf7deae22244890b9d1548.tar.gz
ports-ed5b9ccf964d53da04bf7deae22244890b9d1548.zip
sysutils/py-howdoi: new port
Howdoi is an open source command line tool that gives answers to your questions right on the command line. Howdoi can be used by anyone and everyone who finds themselves Googling for answers to their basic programming questions. WWW: https://github.com/gleitz/howdoi PR: 265935
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-howdoi/Makefile25
-rw-r--r--sysutils/py-howdoi/distinfo3
-rw-r--r--sysutils/py-howdoi/pkg-descr6
4 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index e8df5a101d6a..e24e970733af 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1068,6 +1068,7 @@
SUBDIR += py-hared
SUBDIR += py-hcloud
SUBDIR += py-honcho
+ SUBDIR += py-howdoi
SUBDIR += py-hpilo
SUBDIR += py-iowait
SUBDIR += py-ioztat
diff --git a/sysutils/py-howdoi/Makefile b/sysutils/py-howdoi/Makefile
new file mode 100644
index 000000000000..1dc68fcf43f8
--- /dev/null
+++ b/sysutils/py-howdoi/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= howdoi
+PORTVERSION= 2.0.19
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= DtxdF@riseup.net
+COMMENT= Instant coding answers via the command line
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>0:textproc/py-pygments@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cssselect>0:www/py-cssselect@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyquery>0:devel/py-pyquery@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cachelib>0:www/py-cachelib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}appdirs>0:devel/py-appdirs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}keep>0:sysutils/py-keep@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-howdoi/distinfo b/sysutils/py-howdoi/distinfo
new file mode 100644
index 000000000000..f2b464804421
--- /dev/null
+++ b/sysutils/py-howdoi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660847590
+SHA256 (howdoi-2.0.19.tar.gz) = 4baa5270a98e9d001094d873a5a1b6a32eac021009cfc40cd9aeede633cb7556
+SIZE (howdoi-2.0.19.tar.gz) = 27109
diff --git a/sysutils/py-howdoi/pkg-descr b/sysutils/py-howdoi/pkg-descr
new file mode 100644
index 000000000000..8598e5e3b7c1
--- /dev/null
+++ b/sysutils/py-howdoi/pkg-descr
@@ -0,0 +1,6 @@
+Howdoi is an open source command line tool that gives answers to
+your questions right on the command line. Howdoi can be used by
+anyone and everyone who finds themselves Googling for answers to
+their basic programming questions.
+
+WWW: https://github.com/gleitz/howdoi