aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-08-22 17:39:21 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-08-22 17:48:51 +0000
commitee64b8a7794a7af2891483909852c59b1045e655 (patch)
treeb1d67b080d989224d2ad98655131c38093f7513b
parenta321ea99f0a9de91584d4f8991001a93be95ddf3 (diff)
downloadports-ee64b8a7794a7af2891483909852c59b1045e655.tar.gz
ports-ee64b8a7794a7af2891483909852c59b1045e655.zip
security/*gpgme*: Update to 1.22.0
gpgme-qt: Fix COMMENT when FLAVOR is not explicitly set and use just one PORTREVISION line to avoid confusing bumping tools. https://dev.gnupg.org/T6668
-rw-r--r--security/gpgme-cpp/pkg-plist2
-rw-r--r--security/gpgme-qt/Makefile8
-rw-r--r--security/gpgme-qt/pkg-plist2
-rw-r--r--security/gpgme/Makefile8
-rw-r--r--security/gpgme/distinfo6
-rw-r--r--security/gpgme/files/patch-configure4
-rw-r--r--security/gpgme/files/patch-lang_python_Makefile.in6
-rw-r--r--security/gpgme/files/patch-lang_qt_tests_Makefile.in32
-rw-r--r--security/gpgme/pkg-plist2
9 files changed, 49 insertions, 21 deletions
diff --git a/security/gpgme-cpp/pkg-plist b/security/gpgme-cpp/pkg-plist
index c5eb9f270964..bfc7b2f3befe 100644
--- a/security/gpgme-cpp/pkg-plist
+++ b/security/gpgme-cpp/pkg-plist
@@ -44,4 +44,4 @@ lib/cmake/Gpgmepp/GpgmeppConfig.cmake
lib/cmake/Gpgmepp/GpgmeppConfigVersion.cmake
lib/libgpgmepp.so
lib/libgpgmepp.so.6
-lib/libgpgmepp.so.6.18.0
+lib/libgpgmepp.so.6.19.0
diff --git a/security/gpgme-qt/Makefile b/security/gpgme-qt/Makefile
index 354fd2ccc31a..961e7768dfbd 100644
--- a/security/gpgme-qt/Makefile
+++ b/security/gpgme-qt/Makefile
@@ -1,12 +1,6 @@
-.if ${FLAVOR:U} == qt5
PORTREVISION= 0
-COMMENT= Gpgme Qt5 bindings
-.else
-PORTREVISION= 0
-
-COMMENT= Gpgme Qt6 bindings
-.endif
+COMMENT= Gpgme ${QT_STR} bindings
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/security/gpgme-qt/pkg-plist b/security/gpgme-qt/pkg-plist
index 4d404382a6cb..b783f7213e81 100644
--- a/security/gpgme-qt/pkg-plist
+++ b/security/gpgme-qt/pkg-plist
@@ -2,4 +2,4 @@ lib/cmake/QGpgme%%QT_SUFFIX%%/QGpgme%%QT_SUFFIX%%Config.cmake
lib/cmake/QGpgme%%QT_SUFFIX%%/QGpgme%%QT_SUFFIX%%ConfigVersion.cmake
lib/libqgpgme%%qt_SUFFIX%%.so
lib/libqgpgme%%qt_SUFFIX%%.so.15
-lib/libqgpgme%%qt_SUFFIX%%.so.15.3.0
+lib/libqgpgme%%qt_SUFFIX%%.so.15.4.0
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 4096220f0cb3..fc91141527f7 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gpgme
-PORTVERSION= 1.21.0
-PORTREVISION?= 1
+PORTVERSION= 1.22.0
+PORTREVISION?= 0
CATEGORIES?= security
MASTER_SITES= GNUPG/gpgme
@@ -82,6 +82,8 @@ FLAVOR?= ${FLAVORS:[1]}
qt5_PKGNAMESUFFIX= -qt5
qt6_PKGNAMESUFFIX= -qt6
+QT_STR= Qt${FLAVOR:S/qt//}
+
. if ${FLAVOR:U} == "qt5"
USES+= compiler:c++11-lib pkgconfig qt:5
USE_QT= buildtools:build core
@@ -91,7 +93,7 @@ PLIST_SUB= QT_SUFFIX="" qt_SUFFIX=""
USES+= compiler:c++17-lang pkgconfig qt:6
USE_QT= base
USE_CXXSTD= c++17
-PLIST_SUB= QT_SUFFIX="Qt6" qt_SUFFIX="qt6"
+PLIST_SUB= QT_SUFFIX="${QT_STR}" qt_SUFFIX="${FLAVOR}"
. endif
CONFIGURE_ARGS+=--enable-languages="cpp ${FLAVOR}"
diff --git a/security/gpgme/distinfo b/security/gpgme/distinfo
index 6a1ca470392a..58bf10398d2a 100644
--- a/security/gpgme/distinfo
+++ b/security/gpgme/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1688831601
-SHA256 (gpgme-1.21.0.tar.bz2) = 416e174e165734d84806253f8c96bda2993fd07f258c3aad5f053a6efd463e88
-SIZE (gpgme-1.21.0.tar.bz2) = 1830113
+TIMESTAMP = 1692699022
+SHA256 (gpgme-1.22.0.tar.bz2) = 9551e37081ad3bde81018a0d24f245c3f8206990549598fb31a97a68380a7b71
+SIZE (gpgme-1.22.0.tar.bz2) = 1717836
diff --git a/security/gpgme/files/patch-configure b/security/gpgme/files/patch-configure
index d54dc9867a9c..c459227ace77 100644
--- a/security/gpgme/files/patch-configure
+++ b/security/gpgme/files/patch-configure
@@ -4,9 +4,9 @@ of a clean environment since the ports system can only build a package for one
Python flavor at a time. The found versions of Python are overridden by
environment variables set in the port Makefile.
---- configure.orig 2019-03-26 17:29:46 UTC
+--- configure.orig 2023-08-21 07:46:33 UTC
+++ configure
-@@ -23851,6 +23851,10 @@ $as_echo "$as_me: WARNING:
+@@ -31342,6 +31342,10 @@ printf "%s\n" "$as_me: WARNING:
fi
diff --git a/security/gpgme/files/patch-lang_python_Makefile.in b/security/gpgme/files/patch-lang_python_Makefile.in
index 227ab2c55e59..e78760200c2a 100644
--- a/security/gpgme/files/patch-lang_python_Makefile.in
+++ b/security/gpgme/files/patch-lang_python_Makefile.in
@@ -6,9 +6,9 @@ unable to execute 'swig': No such file or directory
Second hunk:
Fix staging and build the *.pyc and *.pyo files
---- lang/python/Makefile.in.orig 2017-12-12 11:56:08 UTC
+--- lang/python/Makefile.in.orig 2023-08-21 07:46:32 UTC
+++ lang/python/Makefile.in
-@@ -740,7 +740,7 @@ all-local: copystamp
+@@ -768,7 +768,7 @@ all-local: copystamp
CFLAGS="$(CFLAGS)" \
srcdir="$(srcdir)" \
top_builddir="$(top_builddir)" \
@@ -17,7 +17,7 @@ Fix staging and build the *.pyc and *.pyo files
done
python$(PYTHON_VERSION)-gpg/dist/gpg-$(VERSION).tar.gz.asc: copystamp
-@@ -782,7 +782,8 @@ install-exec-local:
+@@ -811,7 +811,8 @@ install-exec-local:
build \
--build-base="$$(basename "$${PYTHON}")-gpg" \
install \
diff --git a/security/gpgme/files/patch-lang_qt_tests_Makefile.in b/security/gpgme/files/patch-lang_qt_tests_Makefile.in
new file mode 100644
index 000000000000..ffc5f0ef5c55
--- /dev/null
+++ b/security/gpgme/files/patch-lang_qt_tests_Makefile.in
@@ -0,0 +1,32 @@
+Fix build of Qt tests.
+
+This fixes the problem that the debug.h in the C sources was found
+before the one in the Qt bindings.
+
+Based on upstream commits:
+https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=commit;h=d23528cadf4284f508bc4ba05e1b5c14b46bd354
+https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=commit;h=aee18a2ab2498bc6092bef518c532796bbe5b502
+
+--- lang/qt/tests/Makefile.in.orig 2023-08-21 07:46:32 UTC
++++ lang/qt/tests/Makefile.in
+@@ -796,16 +796,16 @@ AM_LDFLAGS = -no-install
+ @WANT_QT6_TRUE@ ../../../src/libgpgme.la @GPGME_QT6_LIBS@ @GPG_ERROR_LIBS@ \
+ @WANT_QT6_TRUE@ @GPGME_QT6TEST_LIBS@ @LDADD_FOR_TESTS_KLUDGE@ -lstdc++
+
+-@WANT_QT5_TRUE@AM_CPPFLAGS = -I$(top_srcdir)/lang/cpp/src -I$(top_builddir)/src \
++@WANT_QT5_TRUE@AM_CPPFLAGS = -I$(top_srcdir)/lang/qt/src -I$(top_srcdir)/lang/cpp/src \
++@WANT_QT5_TRUE@ -I$(top_builddir)/src \
+ @WANT_QT5_TRUE@ @GPG_ERROR_CFLAGS@ @GPGME_QT5_CFLAGS@ @GPG_ERROR_CFLAGS@ \
+ @WANT_QT5_TRUE@ @LIBASSUAN_CFLAGS@ @GPGME_QT5TEST_CFLAGS@ -DBUILDING_QGPGME \
+-@WANT_QT5_TRUE@ -I$(top_srcdir)/lang/qt/src \
+ @WANT_QT5_TRUE@ -DTOP_SRCDIR="$(top_srcdir)"
+
+-@WANT_QT6_TRUE@AM_CPPFLAGS = -I$(top_srcdir)/lang/cpp/src -I$(top_builddir)/src \
++@WANT_QT6_TRUE@AM_CPPFLAGS = -I$(top_srcdir)/lang/qt/src -I$(top_srcdir)/lang/cpp/src \
++@WANT_QT6_TRUE@ -I$(top_builddir)/src \
+ @WANT_QT6_TRUE@ @GPG_ERROR_CFLAGS@ @GPGME_QT6_CFLAGS@ @GPG_ERROR_CFLAGS@ \
+ @WANT_QT6_TRUE@ @LIBASSUAN_CFLAGS@ @GPGME_QT6TEST_CFLAGS@ -DBUILDING_QGPGME \
+-@WANT_QT6_TRUE@ -I$(top_srcdir)/lang/qt/src \
+ @WANT_QT6_TRUE@ -DTOP_SRCDIR="$(top_srcdir)"
+
+ support_src = t-support.h t-support.cpp
diff --git a/security/gpgme/pkg-plist b/security/gpgme/pkg-plist
index 7477164b34fb..808091e29330 100644
--- a/security/gpgme/pkg-plist
+++ b/security/gpgme/pkg-plist
@@ -8,7 +8,7 @@ lib/common-lisp/gpgme/gpgme.asd
lib/common-lisp/gpgme/gpgme.lisp
lib/libgpgme.so
lib/libgpgme.so.11
-lib/libgpgme.so.11.30.0
+lib/libgpgme.so.11.31.0
libdata/pkgconfig/gpgme-glib.pc
libdata/pkgconfig/gpgme.pc
share/aclocal/gpgme.m4