aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:13:03 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:07 +0000
commiteeb13706e36700007f3ad4740b7158e801197ba8 (patch)
tree6437226fab95129ce0205ab0be0df48d2e1827f1
parent21b9950f5eb1eac3e6f5b01866ed970cf7492ba6 (diff)
downloadports-eeb13706e36700007f3ad4740b7158e801197ba8.tar.gz
ports-eeb13706e36700007f3ad4740b7158e801197ba8.zip
math/py-pyprobables: Add py-pyprobables 0.6.0
pyprobables is a pure-python library for probabilistic data structures. The goal is to provide the developer with a pure-python implementation of common probabilistic data-structures to use in their work. To achieve better raw performance, it is recommended supplying an alternative hashing algorithm that has been compiled in C. This could include using the MD5 and SHA512 algorithms provided or installing a third party package and writing your own hashing strategy. Some options include the murmur hash mmh3 or those from the pyhash library. Each data object in pyprobables makes it easy to pass in a custom hashing function.
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pyprobables/Makefile23
-rw-r--r--math/py-pyprobables/distinfo3
-rw-r--r--math/py-pyprobables/pkg-descr10
4 files changed, 37 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index c62c66cc61b2..22e036769902 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -1035,6 +1035,7 @@
SUBDIR += py-pynndescent
SUBDIR += py-pyodeint
SUBDIR += py-pyodesys
+ SUBDIR += py-pyprobables
SUBDIR += py-pyreadr
SUBDIR += py-pyrr
SUBDIR += py-pysmt
diff --git a/math/py-pyprobables/Makefile b/math/py-pyprobables/Makefile
new file mode 100644
index 000000000000..17301a3275bf
--- /dev/null
+++ b/math/py-pyprobables/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= pyprobables
+PORTVERSION= 0.6.0
+CATEGORIES= math python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Probabilistic data structures in python
+WWW= https://pyprobables.readthedocs.io/en/latest/ \
+ https://github.com/barrust/pyprobables
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.2.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-pyprobables/distinfo b/math/py-pyprobables/distinfo
new file mode 100644
index 000000000000..18c54f3fad3c
--- /dev/null
+++ b/math/py-pyprobables/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708448834
+SHA256 (pyprobables-0.6.0.tar.gz) = a4e72bdb4d3513121b33377728c9eafd2ae8495d5201d6a90abc3d52d9a17901
+SIZE (pyprobables-0.6.0.tar.gz) = 33638
diff --git a/math/py-pyprobables/pkg-descr b/math/py-pyprobables/pkg-descr
new file mode 100644
index 000000000000..554724a7ab5d
--- /dev/null
+++ b/math/py-pyprobables/pkg-descr
@@ -0,0 +1,10 @@
+pyprobables is a pure-python library for probabilistic data structures. The goal
+is to provide the developer with a pure-python implementation of common
+probabilistic data-structures to use in their work.
+
+To achieve better raw performance, it is recommended supplying an alternative
+hashing algorithm that has been compiled in C. This could include using the MD5
+and SHA512 algorithms provided or installing a third party package and writing
+your own hashing strategy. Some options include the murmur hash mmh3 or those
+from the pyhash library. Each data object in pyprobables makes it easy to pass
+in a custom hashing function.