aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-09-15 11:03:25 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-09-15 11:04:37 +0000
commiteef6e5bcefda2b8b5734f00aea99d1ce3ac30a21 (patch)
tree6693e265b6a21d1ce23a3d8c18801da1175cb61d
parentf22a5cdccbe2521f0eea3611c8891e799ee73da7 (diff)
downloadports-eef6e5bcefda2b8b5734f00aea99d1ce3ac30a21.tar.gz
ports-eef6e5bcefda2b8b5734f00aea99d1ce3ac30a21.zip
deskutils/xfce4-notifyd: Properly handle libcanberra dependency
xfce4-notifyd configure script automatically adds a dependency on libcanberra-gtk3 if found on the system. To have control on this I added a new CANBERRA option (disabled by default) to the port to control configure behavior and ensure that the port does not link to it if the option is disabled. PR: 273805 MFH: 2023Q3 (cherry picked from commit 4018c2022be41e2e634d970655cfe78c4b997dc0)
-rw-r--r--deskutils/xfce4-notifyd/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index 39c19495bdb7..4b42748113fe 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -5,7 +5,7 @@
PORTNAME= xfce4-notifyd
PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils xfce
MASTER_SITES= XFCE/apps
DIST_SUBDIR= xfce4
@@ -29,9 +29,15 @@ USE_XORG= ice sm x11
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= CANBERRA NLS
OPTIONS_SUB= yes
+CANBERRA_DESC= Sound (audio) support via canberra
+
+CANBERRA_LIB_DEPENDS= libcanberra.so:audio/libcanberra \
+ libcanberra-gtk3.so:audio/libcanberra-gtk3
+CANBERRA_CONFIGURE_ENABLE= canberra
+
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls