aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2022-01-07 04:42:11 +0000
committerWen Heping <wen@FreeBSD.org>2022-01-07 04:42:11 +0000
commiteefd07e31a45bc31d18df442e2a474c6e2d7506e (patch)
treee9d59353da78670ca833d1025fdd739d14964231
parent1ac20aeca1ae85522b512f2f32aae515f0ede432 (diff)
downloadports-eefd07e31a45bc31d18df442e2a474c6e2d7506e.tar.gz
ports-eefd07e31a45bc31d18df442e2a474c6e2d7506e.zip
devel/py-tables: Update to 3.7.0
-rw-r--r--devel/py-tables/Makefile11
-rw-r--r--devel/py-tables/distinfo6
-rw-r--r--devel/py-tables/files/patch-setup.py14
3 files changed, 7 insertions, 24 deletions
diff --git a/devel/py-tables/Makefile b/devel/py-tables/Makefile
index d1d4e59fb306..0bd37464bdb2 100644
--- a/devel/py-tables/Makefile
+++ b/devel/py-tables/Makefile
@@ -1,8 +1,7 @@
# Created by: ijliao@FreeBSD.org
PORTNAME= tables
-PORTVERSION= 3.6.1
-PORTREVISION= 1
+PORTVERSION= 3.7.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +12,8 @@ COMMENT= Hierarchical database for Python
LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}numexpr>=1.4.1:math/py-numexpr@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}numexpr>=1.4.1:math/py-numexpr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR}
LIB_DEPENDS= libhdf5.so:science/hdf5 \
liblzo2.so:archivers/lzo2 \
libucl.so:archivers/ucl
@@ -23,7 +23,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
CONFLICTS_BUILD= zstd # conflicting version of zstd is bundled
-USES= fortran python:3.6+
+USES= fortran localbase python:3.6+ localbase
USE_PYTHON= autoplist concurrent distutils cython
PORTEXAMPLES= *
@@ -39,9 +39,6 @@ AVX2_DESC= Enable Haswell New Instructions (AVX2) support
# See also: https://github.com/PyTables/PyTables/issues/841
AVX2_VARS_OFF= MAKE_ENV+=DISABLE_AVX2=yes
-post-patch:
- @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE}," ${WRKSRC}/setup.py
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/tables/*.so
diff --git a/devel/py-tables/distinfo b/devel/py-tables/distinfo
index 5c36a473d0d5..0c2ff5f9641f 100644
--- a/devel/py-tables/distinfo
+++ b/devel/py-tables/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1603187407
-SHA256 (tables-3.6.1.tar.gz) = 49a972b8a7c27a8a173aeb05f67acb45fe608b64cd8e9fa667c0962a60b71b49
-SIZE (tables-3.6.1.tar.gz) = 4641089
+TIMESTAMP = 1641524945
+SHA256 (tables-3.7.0.tar.gz) = e92a887ad6f2a983e564a69902de4a7645c30069fc01abd353ec5da255c5e1fe
+SIZE (tables-3.7.0.tar.gz) = 8227955
diff --git a/devel/py-tables/files/patch-setup.py b/devel/py-tables/files/patch-setup.py
deleted file mode 100644
index cb3166dc1121..000000000000
--- a/devel/py-tables/files/patch-setup.py
+++ /dev/null
@@ -1,14 +0,0 @@
---- setup.py.orig 2019-03-19 12:02:31 UTC
-+++ setup.py
-@@ -124,8 +124,9 @@ if __name__ == '__main__':
- debug = '--debug' in sys.argv
-
- # Global variables
-- lib_dirs = []
-- inc_dirs = [os.path.join('hdf5-blosc', 'src')]
-+ lib_dirs = ['%%LOCALBASE%%/lib']
-+ inc_dirs = [os.path.join('hdf5-blosc', 'src'),'%%LOCALBASE%%/include']
-+
- optional_libs = []
- data_files = [] # list of data files to add to packages (mainly for DLL's)
-