aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-02-28 11:18:56 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-02-28 11:18:56 +0000
commitef0d5b3097b5b191e4cd1b0eb7b396fca230971f (patch)
treebc85c481e26a895f0c8b5c4e9fb19e688f2f644a
parent2fe1c1f478a8430d1be861aad7ecf7a0d425079b (diff)
downloadports-ef0d5b3097b5b191e4cd1b0eb7b396fca230971f.tar.gz
ports-ef0d5b3097b5b191e4cd1b0eb7b396fca230971f.zip
audio/py-pyogg: new port had been added (+)
PyOgg provides bindings for Xiph.org's OGG Vorbis, OGG Opus, and FLAC audio file formats. All the functions, structures, and datatypes are the same as in the C++ implementation, except for some that could not be translated. WWW: https://pypi.org/project/PyOgg/
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-pyogg/Makefile23
-rw-r--r--audio/py-pyogg/distinfo3
-rw-r--r--audio/py-pyogg/pkg-descr7
4 files changed, 34 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f72412261b57..0fabeaca61c7 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -660,6 +660,7 @@
SUBDIR += py-pylast
SUBDIR += py-pyliblo
SUBDIR += py-pymad
+ SUBDIR += py-pyogg
SUBDIR += py-pysndfile
SUBDIR += py-python-mpd2
SUBDIR += py-soundcloud
diff --git a/audio/py-pyogg/Makefile b/audio/py-pyogg/Makefile
new file mode 100644
index 000000000000..5a370e5f033c
--- /dev/null
+++ b/audio/py-pyogg/Makefile
@@ -0,0 +1,23 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+
+PORTNAME= PyOgg
+DISTVERSION= 0.6.14a1
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Xiph.org's Ogg Vorbis, Opus, and FLAC for Python
+
+LICENSE= UNLICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libFLAC.so:audio/flac \
+ libogg.so:audio/libogg \
+ libopusfile.so:audio/opusfile \
+ libvorbis.so:audio/libvorbis
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/audio/py-pyogg/distinfo b/audio/py-pyogg/distinfo
new file mode 100644
index 000000000000..f7d4bffff9fc
--- /dev/null
+++ b/audio/py-pyogg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1593175918
+SHA256 (PyOgg-0.6.14a1.tar.gz) = 8294b34aa59c90200c4630c2cc4a5b84407209141e8e5d069d7a5be358e94262
+SIZE (PyOgg-0.6.14a1.tar.gz) = 35091
diff --git a/audio/py-pyogg/pkg-descr b/audio/py-pyogg/pkg-descr
new file mode 100644
index 000000000000..334b4ab1178a
--- /dev/null
+++ b/audio/py-pyogg/pkg-descr
@@ -0,0 +1,7 @@
+PyOgg provides bindings for Xiph.org's OGG Vorbis, OGG Opus, and FLAC
+audio file formats.
+
+All the functions, structures, and datatypes are the same as in the C++
+implementation, except for some that could not be translated.
+
+WWW: https://pypi.org/project/PyOgg/