aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 13:48:36 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-03-09 14:06:06 +0000
commitef96763bf3cb98e3cd7ca4f4d989afde749c9353 (patch)
tree2a0258c9ed960f5394bc3f1ae2d108e709df0675
parentc8724967d7d69645afa9c1cd5685a75b032dacf0 (diff)
downloadports-ef96763bf3cb98e3cd7ca4f4d989afde749c9353.tar.gz
ports-ef96763bf3cb98e3cd7ca4f4d989afde749c9353.zip
devel/py-sniffio: Update to 1.3.1
-rw-r--r--devel/py-sniffio/Makefile10
-rw-r--r--devel/py-sniffio/distinfo6
-rw-r--r--devel/py-sniffio/files/patch-pyproject.toml10
3 files changed, 20 insertions, 6 deletions
diff --git a/devel/py-sniffio/Makefile b/devel/py-sniffio/Makefile
index c4140b862fc2..ae368461b728 100644
--- a/devel/py-sniffio/Makefile
+++ b/devel/py-sniffio/Makefile
@@ -1,23 +1,27 @@
PORTNAME= sniffio
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Sniff out which async library your code is running under
-WWW= https://github.com/python-trio/sniffio
+WWW= https://sniffio.readthedocs.io/en/latest/ \
+ https://github.com/python-trio/sniffio
LICENSE= APACHE20 MIT
LICENSE_COMB= dual
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.APACHE2
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE.MIT
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-scm>=6.4:devel/py-setuptools-scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}curio>=0:devel/py-curio@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes
diff --git a/devel/py-sniffio/distinfo b/devel/py-sniffio/distinfo
index 98231f5670a2..ee1d5ce17aed 100644
--- a/devel/py-sniffio/distinfo
+++ b/devel/py-sniffio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1662212176
-SHA256 (sniffio-1.3.0.tar.gz) = e60305c5e5d314f5389259b7f22aaa33d8f7dee49763119234af3755c55b9101
-SIZE (sniffio-1.3.0.tar.gz) = 17103
+TIMESTAMP = 1709390662
+SHA256 (sniffio-1.3.1.tar.gz) = f4324edc670a0f49750a81b895f35c3adb843cca46f0530f79fc1babb23789dc
+SIZE (sniffio-1.3.1.tar.gz) = 20372
diff --git a/devel/py-sniffio/files/patch-pyproject.toml b/devel/py-sniffio/files/patch-pyproject.toml
new file mode 100644
index 000000000000..52d7bdb89c38
--- /dev/null
+++ b/devel/py-sniffio/files/patch-pyproject.toml
@@ -0,0 +1,10 @@
+--- pyproject.toml.orig 2024-02-25 23:11:00 UTC
++++ pyproject.toml
+@@ -1,6 +1,6 @@ requires = [
+ [build-system]
+ requires = [
+- "setuptools >= 64",
++ "setuptools >= 61",
+ "setuptools_scm >= 6.4"
+ ]
+ build-backend = "setuptools.build_meta"