aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-08-03 18:23:49 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-08-03 18:24:51 +0000
commitefb7dee00c4ce3d6b7cd1d34b064579c6917b534 (patch)
treef51f284ed6d397ff5a3402c4ecd1915c341a9c4d
parentd15448a9532be5c1121b2d7382d7ca5caa37c196 (diff)
downloadports-efb7dee00c4ce3d6b7cd1d34b064579c6917b534.tar.gz
ports-efb7dee00c4ce3d6b7cd1d34b064579c6917b534.zip
mail/geary: Update to 40.0
-rw-r--r--mail/geary/Makefile50
-rw-r--r--mail/geary/distinfo6
-rw-r--r--mail/geary/files/patch-meson.build20
-rw-r--r--mail/geary/pkg-plist66
4 files changed, 117 insertions, 25 deletions
diff --git a/mail/geary/Makefile b/mail/geary/Makefile
index 149e6338aa8a..d6db1e8e83a6 100644
--- a/mail/geary/Makefile
+++ b/mail/geary/Makefile
@@ -1,10 +1,9 @@
# Created by: Gustau Perez <gustau.perez@gmail.com>
PORTNAME= geary
-PORTVERSION= 3.32.2
-PORTREVISION= 1
+PORTVERSION= 40.0
CATEGORIES= mail gnome
-MASTER_SITES= GNOME
+MASTER_SITES= GNOME/sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+)\..*/\1/}
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
@@ -13,32 +12,39 @@ COMMENT= Mail client for GNOME 3
LICENSE= BSD2CLAUSE CC-BY-3.0 LGPL21+
LICENSE_COMB= multi
-BUILD_DEPENDS= vapigen:lang/vala \
- itstool:textproc/itstool
-LIB_DEPENDS= libgmime-2.6.so:mail/gmime26 \
- libsoup-2.4.so:devel/libsoup \
- libunwind.so:devel/libunwind \
- libjson-glib-1.0.so:devel/json-glib \
- libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
- libgoa-1.0.so:net/gnome-online-accounts \
+BUILD_DEPENDS= itstool:textproc/itstool \
+ vapigen:lang/vala
+LIB_DEPENDS= libappstream-glib.so:devel/appstream-glib \
libcanberra.so:audio/libcanberra \
- libnotify.so:devel/libnotify \
- libgee-0.8.so:devel/libgee \
+ libenchant-2.so:textproc/enchant2 \
+ libfolks.so:net-im/folks \
libgcr-base-3.so:security/gcr \
+ libgee-0.8.so:devel/libgee \
+ libgmime-3.0.so:mail/gmime30 \
+ libgoa-1.0.so:net/gnome-online-accounts \
+ libgspell-1.so:textproc/gspell \
+ libhandy-1.so:x11-toolkits/libhandy \
+ libicuuc.so:devel/icu \
+ libjson-glib-1.0.so:devel/json-glib \
+ libnotify.so:devel/libnotify \
+ libpeas-gtk-1.0.so:devel/libpeas \
libsecret-1.so:security/libsecret \
- libenchant-2.so:textproc/enchant2 \
- libfolks.so:net-im/folks
-
-USES= compiler:c11 desktop-file-utils gettext gnome meson \
- pkgconfig python:3.5+,build shebangfix sqlite tar:xz
-USE_GNOME= cairo gtk30 libxml2
+ libsoup-2.4.so:devel/libsoup \
+ libstemmer.so:textproc/snowballstemmer \
+ libunwind.so:devel/libunwind \
+ libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
+ libytnef.so:converters/ytnef
+USES= compiler:c11 desktop-file-utils gettext gnome meson pkgconfig \
+ python:3.5+,build shebangfix sqlite tar:xz
+USE_GNOME= cairo gsound gtk30 libxml2
+GLIB_SCHEMAS= org.gnome.Geary.gschema.xml
+INSTALLS_ICONS= yes
USE_LDCONFIG= yes
SHEBANG_FILES= desktop/geary-attach
-INSTALLS_ICONS= yes
-BINARY_ALIAS= python3=${PYTHON_VERSION}
-GLIB_SCHEMAS= org.gnome.Geary.gschema.xml
+MESON_ARGS= -Dprofile=release
+BINARY_ALIAS= python3=${PYTHON_VERSION}
.include <bsd.port.mk>
diff --git a/mail/geary/distinfo b/mail/geary/distinfo
index c42f19ef2b19..150c659b2b89 100644
--- a/mail/geary/distinfo
+++ b/mail/geary/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1601040964
-SHA256 (gnome/geary-3.32.2.tar.xz) = f821632356f1c0f694e6fe7c301952fa393e3522a0151f718348ec80f01fe569
-SIZE (gnome/geary-3.32.2.tar.xz) = 2234052
+TIMESTAMP = 1628011356
+SHA256 (gnome/geary-40.0.tar.xz) = 3356203725a924d6cb358e0c29ad090f4177d8d7b7f8210412cf0250ca6856b0
+SIZE (gnome/geary-40.0.tar.xz) = 2490940
diff --git a/mail/geary/files/patch-meson.build b/mail/geary/files/patch-meson.build
new file mode 100644
index 000000000000..d6767378dd40
--- /dev/null
+++ b/mail/geary/files/patch-meson.build
@@ -0,0 +1,20 @@
+--- meson.build.orig 2021-04-23 03:57:02 UTC
++++ meson.build
+@@ -94,7 +94,7 @@ libmath = cc.find_library('m')
+ libpeas = dependency('libpeas-1.0', version: '>= 1.24.0')
+ libpeas_gtk = dependency('libpeas-gtk-1.0', version: '>= 1.24.0')
+ libsecret = dependency('libsecret-1', version: '>= 0.11')
+-libstemmer_dep = cc.find_library('stemmer')
++libstemmer_dep = cc.find_library('stemmer', dirs: [ '/usr/local/lib/' ])
+ libsoup = dependency('libsoup-2.4', version: '>= 2.48')
+ libunwind_dep = dependency(
+ 'libunwind', version: '>= 1.1', required: get_option('libunwind')
+@@ -114,7 +114,7 @@ webkit2gtk_web_extension = dependency('webkit2gtk-web-
+ icu_uc = declare_dependency(
+ dependencies: [
+ valac.find_library('icu-uc', dirs: [vapi_dir]),
+- cc.find_library('icuuc'),
++ cc.find_library('icuuc', dirs: [ '/usr/local/lib/' ]),
+ ],
+ )
+
diff --git a/mail/geary/pkg-plist b/mail/geary/pkg-plist
index 74e697a817f6..6a8e12314055 100644
--- a/mail/geary/pkg-plist
+++ b/mail/geary/pkg-plist
@@ -1,7 +1,23 @@
bin/geary
+lib/geary/libgeary-client-40.0.so
+lib/geary/plugins/desktop-notifications/desktop-notifications.plugin
+lib/geary/plugins/desktop-notifications/libdesktop-notifications.so
+lib/geary/plugins/email-templates/email-templates.plugin
+lib/geary/plugins/email-templates/libemail-templates.so
+lib/geary/plugins/folder-highlight/folder-highlight.plugin
+lib/geary/plugins/folder-highlight/libfolder-highlight.so
+lib/geary/plugins/mail-merge/libmail-merge.so
+lib/geary/plugins/mail-merge/mail-merge.plugin
+lib/geary/plugins/notification-badge/libnotification-badge.so
+lib/geary/plugins/notification-badge/notification-badge.plugin
+lib/geary/plugins/sent-sound/libsent-sound.so
+lib/geary/plugins/sent-sound/sent-sound.plugin
+lib/geary/plugins/special-folders/libspecial-folders.so
+lib/geary/plugins/special-folders/special-folders.plugin
lib/geary/web-extensions/libgeary-web-process.so
share/applications/geary-autostart.desktop
share/applications/org.gnome.Geary.desktop
+share/dbus-1/services/org.gnome.Geary.service
%%DATADIR%%/sql/version-001.sql
%%DATADIR%%/sql/version-002.sql
%%DATADIR%%/sql/version-003.sql
@@ -27,6 +43,11 @@ share/applications/org.gnome.Geary.desktop
%%DATADIR%%/sql/version-023.sql
%%DATADIR%%/sql/version-024.sql
%%DATADIR%%/sql/version-025.sql
+%%DATADIR%%/sql/version-026.sql
+%%DATADIR%%/sql/version-027.sql
+%%DATADIR%%/sql/version-028.sql
+%%DATADIR%%/sql/version-029.sql
+%%DATADIR%%/sql/version-030.sql
share/help/C/geary/accounts.page
share/help/C/geary/archive.page
share/help/C/geary/bugs.page
@@ -41,6 +62,20 @@ share/help/C/geary/search.page
share/help/C/geary/shortcuts.page
share/help/C/geary/star.page
share/help/C/geary/write.page
+share/help/ca/geary/accounts.page
+share/help/ca/geary/archive.page
+share/help/ca/geary/bugs.page
+share/help/ca/geary/contributing.page
+share/help/ca/geary/figures/geary.svg
+share/help/ca/geary/index.page
+share/help/ca/geary/label.page
+share/help/ca/geary/limits.page
+share/help/ca/geary/overview.page
+share/help/ca/geary/preferences.page
+share/help/ca/geary/search.page
+share/help/ca/geary/shortcuts.page
+share/help/ca/geary/star.page
+share/help/ca/geary/write.page
share/help/cs/geary/accounts.page
share/help/cs/geary/archive.page
share/help/cs/geary/bugs.page
@@ -111,6 +146,20 @@ share/help/fr/geary/search.page
share/help/fr/geary/shortcuts.page
share/help/fr/geary/star.page
share/help/fr/geary/write.page
+share/help/id/geary/accounts.page
+share/help/id/geary/archive.page
+share/help/id/geary/bugs.page
+share/help/id/geary/contributing.page
+share/help/id/geary/figures/geary.svg
+share/help/id/geary/index.page
+share/help/id/geary/label.page
+share/help/id/geary/limits.page
+share/help/id/geary/overview.page
+share/help/id/geary/preferences.page
+share/help/id/geary/search.page
+share/help/id/geary/shortcuts.page
+share/help/id/geary/star.page
+share/help/id/geary/write.page
share/help/it/geary/accounts.page
share/help/it/geary/archive.page
share/help/it/geary/bugs.page
@@ -181,12 +230,29 @@ share/help/tr/geary/search.page
share/help/tr/geary/shortcuts.page
share/help/tr/geary/star.page
share/help/tr/geary/write.page
+share/help/uk/geary/accounts.page
+share/help/uk/geary/archive.page
+share/help/uk/geary/bugs.page
+share/help/uk/geary/contributing.page
+share/help/uk/geary/figures/geary.svg
+share/help/uk/geary/index.page
+share/help/uk/geary/label.page
+share/help/uk/geary/limits.page
+share/help/uk/geary/overview.page
+share/help/uk/geary/preferences.page
+share/help/uk/geary/search.page
+share/help/uk/geary/shortcuts.page
+share/help/uk/geary/star.page
+share/help/uk/geary/write.page
share/icons/hicolor/scalable/actions/close-symbolic.svg
share/icons/hicolor/scalable/actions/detach-symbolic.svg
share/icons/hicolor/scalable/actions/edit-symbolic.svg
+share/icons/hicolor/scalable/actions/font-color-symbolic.svg
+share/icons/hicolor/scalable/actions/font-size-symbolic.svg
share/icons/hicolor/scalable/actions/format-ordered-list-symbolic-rtl.svg
share/icons/hicolor/scalable/actions/format-ordered-list-symbolic.svg
share/icons/hicolor/scalable/actions/format-text-remove-symbolic.svg
+share/icons/hicolor/scalable/actions/format-toolbar-toggle-symbolic.svg
share/icons/hicolor/scalable/actions/format-unordered-list-symbolic-rtl.svg
share/icons/hicolor/scalable/actions/format-unordered-list-symbolic.svg
share/icons/hicolor/scalable/actions/mail-archive-symbolic.svg