aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2022-11-09 18:20:40 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2022-11-09 18:20:40 +0000
commitefe0b339c9c72b2f55cbbca2dcb781a8ccec5930 (patch)
treef721ef70d22b079a24fb4463d9221bbc6a297c4d
parentf664b99381e43b7c7ccb4a9695f222deef64a8e8 (diff)
downloadports-efe0b339c9c72b2f55cbbca2dcb781a8ccec5930.tar.gz
ports-efe0b339c9c72b2f55cbbca2dcb781a8ccec5930.zip
net/keama: Kea migration assistant
-rw-r--r--net/Makefile1
-rw-r--r--net/keama/Makefile43
-rw-r--r--net/keama/distinfo3
-rw-r--r--net/keama/files/patch-confparse.c10
-rw-r--r--net/keama/files/patch-data.c10
-rw-r--r--net/keama/files/patch-eval.c10
-rw-r--r--net/keama/files/patch-keama.c10
-rw-r--r--net/keama/files/patch-parse.c10
-rw-r--r--net/keama/files/patch-reduce.c10
-rw-r--r--net/keama/pkg-descr3
10 files changed, 110 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 21984d666edf..b5af4861faa8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -307,6 +307,7 @@
SUBDIR += kdenetwork
SUBDIR += kdenetwork-filesharing
SUBDIR += kea
+ SUBDIR += keama
SUBDIR += keycloak
SUBDIR += kf5-kcalendarcore
SUBDIR += kf5-kcontacts
diff --git a/net/keama/Makefile b/net/keama/Makefile
new file mode 100644
index 000000000000..78c5306279bd
--- /dev/null
+++ b/net/keama/Makefile
@@ -0,0 +1,43 @@
+PORTNAME= keama
+ISCVERSION= 4.4.3-P1
+PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
+CATEGORIES= net
+MASTER_SITES= ISC/${PORTNAME}/${PORTVERSION:S/P/-P/g} \
+ ZI
+DISTNAME= dhcp-${ISCVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Kea migration assistant
+WWW= https://gitlab.isc.org/isc-projects/dhcp/-/wikis/kea-migration-assistant
+
+LICENSE= MPL20
+
+USES= cpe gmake
+
+CPE_VENDOR= isc
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--localstatedir=/var
+CPPFLAGS+= -D_PATH_DHCPD_CONF='\"${PREFIX}/etc/dhcpd.conf\"'
+CFLAGS+= -fPIC
+BUILD_WRKSRC= ${WRKSRC}/keama
+MAN_COMPRESSED= no
+SCRIPTS_ENV+= PKG_PREFIX=${PREFIX}
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
+
+PLIST_FILES= sbin/keama man/man8/keama.8.gz \
+ %%PORTDOCS%%%%DOCSDIR%%/ChangeLog.md \
+ %%PORTDOCS%%%%DOCSDIR%%/README.md \
+
+do-install:
+ ${SETENV} DESTDIR=${STAGEDIR} ${MAKE} -C ${WRKSRC}/keama install
+
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/keama/*.md ${STAGEDIR}/${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/net/keama/distinfo b/net/keama/distinfo
new file mode 100644
index 000000000000..01ef61ee7e7d
--- /dev/null
+++ b/net/keama/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1664982364
+SHA256 (dhcp-4.4.3-P1.tar.gz) = 0ac416bb55997ca8632174fd10737fd61cdb8dba2752160a335775bc21dc73c7
+SIZE (dhcp-4.4.3-P1.tar.gz) = 10081055
diff --git a/net/keama/files/patch-confparse.c b/net/keama/files/patch-confparse.c
new file mode 100644
index 000000000000..a03a60ba08aa
--- /dev/null
+++ b/net/keama/files/patch-confparse.c
@@ -0,0 +1,10 @@
+--- keama/confparse.c.orig 2022-09-28 14:39:15 UTC
++++ keama/confparse.c
+@@ -26,6 +26,7 @@
+ #include "keama.h"
+
+ #include <sys/errno.h>
++#include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <assert.h>
+ #include <ctype.h>
diff --git a/net/keama/files/patch-data.c b/net/keama/files/patch-data.c
new file mode 100644
index 000000000000..3dbd3e5b715e
--- /dev/null
+++ b/net/keama/files/patch-data.c
@@ -0,0 +1,10 @@
+--- keama/data.c.orig 2022-09-28 14:39:15 UTC
++++ keama/data.c
+@@ -23,6 +23,7 @@
+ #include "data.h"
+
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <assert.h>
+ #include <stdlib.h>
diff --git a/net/keama/files/patch-eval.c b/net/keama/files/patch-eval.c
new file mode 100644
index 000000000000..db504f8039a1
--- /dev/null
+++ b/net/keama/files/patch-eval.c
@@ -0,0 +1,10 @@
+--- keama/eval.c.orig 2022-09-28 14:39:15 UTC
++++ keama/eval.c
+@@ -25,6 +25,7 @@
+
+ #include <sys/errno.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <ctype.h>
+ #include <netdb.h>
diff --git a/net/keama/files/patch-keama.c b/net/keama/files/patch-keama.c
new file mode 100644
index 000000000000..4a3304f55a71
--- /dev/null
+++ b/net/keama/files/patch-keama.c
@@ -0,0 +1,10 @@
+--- keama/keama.c.orig 2022-09-28 14:39:15 UTC
++++ keama/keama.c
+@@ -22,6 +22,7 @@
+ */
+
+ #include <sys/errno.h>
++#include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <assert.h>
+ #include <fcntl.h>
diff --git a/net/keama/files/patch-parse.c b/net/keama/files/patch-parse.c
new file mode 100644
index 000000000000..8d56c0c69115
--- /dev/null
+++ b/net/keama/files/patch-parse.c
@@ -0,0 +1,10 @@
+--- keama/parse.c.orig 2022-09-28 14:39:15 UTC
++++ keama/parse.c
+@@ -24,6 +24,7 @@
+ #include "keama.h"
+
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <ctype.h>
+ #include <netdb.h>
diff --git a/net/keama/files/patch-reduce.c b/net/keama/files/patch-reduce.c
new file mode 100644
index 000000000000..4e07ebdda35f
--- /dev/null
+++ b/net/keama/files/patch-reduce.c
@@ -0,0 +1,10 @@
+--- keama/reduce.c.orig 2022-09-28 14:39:15 UTC
++++ keama/reduce.c
+@@ -25,6 +25,7 @@
+
+ #include <sys/errno.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <ctype.h>
+ #include <netdb.h>
diff --git a/net/keama/pkg-descr b/net/keama/pkg-descr
new file mode 100644
index 000000000000..49ea306c143c
--- /dev/null
+++ b/net/keama/pkg-descr
@@ -0,0 +1,3 @@
+Kea migration assistant is an experimental extension to ISC DHCP
+that is able to read an isc-dhcp configuration
+and produce a JSON configuration in Kea format.