aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDerek Schrock <dereks@lifeofadishwasher.com>2023-05-06 18:14:03 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-05-09 09:38:23 +0000
commitefe2cf37e62dedefdf9996990f197af13262bb2f (patch)
tree735e0def2069789362c5652fee66aa9616637e71
parent86768eb343516fd78f87ae149bbd2a636c79be24 (diff)
downloadports-efe2cf37e62dedefdf9996990f197af13262bb2f.tar.gz
ports-efe2cf37e62dedefdf9996990f197af13262bb2f.zip
mail/mutt: Remove QUOTE_PATCH option and future patch removal
* Removing QUOTE_PATCH due to logic issues and RFC3676 quoting. * Keep vvv initials patch from QUOTE_PATCH adding INITIALS_PATCH * Add depercation of other patches to be removed in future updates via UPDATING and pkg-message. See PR 271190 [1] comment 12 [2]. * SASL_NONE will now add --with-sasl=no (making portlint happy) * Update context on patches [1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=271190 [2] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=271190#c12 Context and discussion: https://lists.freebsd.org/archives/freebsd-ports/2023-May/003815.html PR: 271190 Reported by: kh@panix.com Differential Revision: https://reviews.freebsd.org/D39985
-rw-r--r--mail/mutt/Makefile23
-rw-r--r--mail/mutt/distinfo4
-rw-r--r--mail/mutt/files/extra-patch-ifdef10
-rw-r--r--mail/mutt/files/extra-patch-maildir-mtime4
-rw-r--r--mail/mutt/files/extra-patch-reverse_reply18
-rw-r--r--mail/mutt/files/extra-patch-smartdate4
-rw-r--r--mail/mutt/files/extra-smime-sender10
-rw-r--r--mail/mutt/files/patch-date-conditional6
-rw-r--r--mail/mutt/files/patch-dgc-deepif2
-rw-r--r--mail/mutt/pkg-message18
10 files changed, 58 insertions, 41 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index f63d38f61ee5..2dd624b27c0f 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mutt
DISTVERSION= 2.2.10
+PORTREVISION= 1
CATEGORIES+= mail
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
https://bitbucket.org/mutt/mutt/downloads/ \
@@ -47,12 +48,13 @@ CONFLICTS= ja-mutt ja-mutt-devel mutt-1.4* mutt-devel-lite mutt-lite \
INFO= ${PORTNAME}
OPTIONS_DEFINE= AUTOCRYPT DEBUG_LOGS DOCS EXAMPLES FLOCK GPGME \
- GREETING_PATCH HTML ICONV IDN IFDEF_PATCH LOCALES_FIX \
- MAILBOX_MANPAGES MAILDIR_MTIME_PATCH NLS QUOTE_PATCH \
- REVERSE_REPLY_PATCH SMART_DATE SMIME SMTP URLVIEW
+ GREETING_PATCH HTML ICONV IDN IFDEF_PATCH \
+ INITIALS_PATCH LOCALES_FIX MAILBOX_MANPAGES \
+ MAILDIR_MTIME_PATCH NLS REVERSE_REPLY_PATCH SMART_DATE \
+ SMIME SMTP URLVIEW
OPTIONS_DEFAULT= AUTOCRYPT DEBUG_LOGS GPGME GSSAPI_NONE HCACHE_LMDB HTML \
- ICONV IDN IFDEF_PATCH LOCALES_FIX MAILBOX_MANPAGES \
- MAILDIR_MTIME_PATCH NCURSES NLS QUOTE_PATCH \
+ ICONV IDN IFDEF_PATCH INITIALS_PATCH LOCALES_FIX \
+ MAILBOX_MANPAGES MAILDIR_MTIME_PATCH NCURSES NLS \
REVERSE_REPLY_PATCH SASL_CYRUS SMART_DATE SMIME SMTP \
URLVIEW
@@ -80,12 +82,12 @@ HCACHE_TOKYOCABINET_DESC= Use Tokyo Cabinet
HTML_DESC= HTML documentation
IDN_DESC= International Domain Names (implies ICONV)
IFDEF_PATCH_DESC= ifdef feature
+INITIALS_PATCH_DESC= Adds exando '%I' initials of author
LOCALES_FIX_DESC= Locales fix
MAILBOX_MANPAGES_DESC= Install mbox.5/mmdf.5 manpages
MAILDIR_MTIME_PATCH_DESC= Maildir mtime patch
NCURSES_DESC= Ncurses support
NLS_DESC= Native language support (implies ICONV)
-QUOTE_PATCH_DESC= Extended quoting
REVERSE_REPLY_PATCH_DESC= Reverse_reply
SASL_CYRUS_DESC= Cyrus SASL Authentication
SASL_GSASL_DESC= GNU SASL Authentication
@@ -161,6 +163,8 @@ IDN_CONFIGURE_WITH= idn2=${LOCALBASE}
IFDEF_PATCH_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ifdef
+INITIALS_PATCH_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.initials.xz:vvv
+
LOCALES_FIX_CONFIGURE_ON= --enable-locales-fix
MAILDIR_MTIME_PATCH_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-maildir-mtime
@@ -171,21 +175,18 @@ NLS_IMPLIES= ICONV
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-QUOTE_PATCH_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.initials.xz:vvv \
- mutt-${GREETING_PATCH_VERSION}.vvv.quote:vc
-QUOTE_PATCH_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-quote
-
REVERSE_REPLY_PATCH_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-reverse_reply
SASL_CYRUS_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
SASL_CYRUS_CONFIGURE_WITH= sasl=${LOCALBASE}
SASL_GSASL_LIB_DEPENDS= libgsasl.so:security/libgsasl
SASL_GSASL_CONFIGURE_WITH= gsasl=${LOCALBASE}
+SASL_NONE_CONFIGURE_WITH= sasl=no
# Handle ncurses/ncurses-port/slang
SLANG_LIB_DEPENDS= libslang.so:devel/libslang2
SLANG_CONFIGURE_ON= --with-slang=${LOCALBASE}
-SLANG_VARS= PKGMESSAGE=${FILESDIR}/pkg-message.slang
+SLANG_VARS= PKGMESSAGE+=${FILESDIR}/pkg-message.slang
SMART_DATE_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-smartdate
diff --git a/mail/mutt/distinfo b/mail/mutt/distinfo
index cade52884e7e..65836f119fc9 100644
--- a/mail/mutt/distinfo
+++ b/mail/mutt/distinfo
@@ -1,9 +1,7 @@
-TIMESTAMP = 1679779751
+TIMESTAMP = 1683312627
SHA256 (mutt/mutt-2.2.10.tar.gz) = 4d773f22422f79096f7b94b57bee45654ad9a25165dbb36463c58295b4cd3d88
SIZE (mutt/mutt-2.2.10.tar.gz) = 5530411
SHA256 (mutt/mutt-2.2.0.vc.greeting) = 7abb467cfaa0ccbfa1fa7cdf8585eefef94e039459ff95fb59efe23043d941d2
SIZE (mutt/mutt-2.2.0.vc.greeting) = 1979
SHA256 (mutt/patch-1.13.0.vvv.initials.xz) = 8b25ad6596bd57d94f6551e7e73ceb8da620468e96fb507b2f51545d5b3eaa02
SIZE (mutt/patch-1.13.0.vvv.initials.xz) = 720
-SHA256 (mutt/mutt-2.2.0.vvv.quote) = 4a3786921d11c931fa8db16b089398d72ef6ae0c42503e5d4884dbaa0e01032b
-SIZE (mutt/mutt-2.2.0.vvv.quote) = 2909
diff --git a/mail/mutt/files/extra-patch-ifdef b/mail/mutt/files/extra-patch-ifdef
index 90d893067df5..fffca3233f09 100644
--- a/mail/mutt/files/extra-patch-ifdef
+++ b/mail/mutt/files/extra-patch-ifdef
@@ -1,8 +1,8 @@
---- PATCHES.orig 2022-06-05 20:10:54 UTC
+--- PATCHES.orig 2023-05-05 18:53:08 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.4.cd.ifdef.1
---- init.c.orig 2022-05-11 16:57:07 UTC
+--- init.c.orig 2023-01-02 04:42:19 UTC
+++ init.c
@@ -715,6 +715,52 @@ static mbchar_table *parse_mbchar_table (const char *s
return t;
@@ -57,9 +57,9 @@
static int parse_unignore (BUFFER *buf, BUFFER *s, union pointer_long_t udata, BUFFER *err)
{
do
---- init.h.orig 2022-06-05 20:10:54 UTC
+--- init.h.orig 2023-03-25 19:50:20 UTC
+++ init.h
-@@ -4934,6 +4934,7 @@ static int parse_lists (BUFFER *, BUFFER *, union poin
+@@ -4926,6 +4926,7 @@ static int parse_lists (BUFFER *, BUFFER *, union poin
static int parse_unlists (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_alias (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_unalias (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
@@ -67,7 +67,7 @@
static int parse_echo (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_ignore (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
static int parse_unignore (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
-@@ -5001,6 +5002,7 @@ const struct command_t Commands[] = {
+@@ -4993,6 +4994,7 @@ const struct command_t Commands[] = {
{ "hdr_order", parse_list, {.p=&HeaderOrderList} },
#ifdef HAVE_ICONV
{ "iconv-hook", mutt_parse_hook, {.l=MUTT_ICONVHOOK} },
diff --git a/mail/mutt/files/extra-patch-maildir-mtime b/mail/mutt/files/extra-patch-maildir-mtime
index a2d4548bd477..ca79a416a04c 100644
--- a/mail/mutt/files/extra-patch-maildir-mtime
+++ b/mail/mutt/files/extra-patch-maildir-mtime
@@ -1,8 +1,8 @@
---- PATCHES.orig 2022-06-05 20:10:54 UTC
+--- PATCHES.orig 2023-05-05 18:53:08 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.7.ust.maildir-mtime.2
---- browser.c.orig 2022-06-05 18:00:36 UTC
+--- browser.c.orig 2023-03-25 19:50:20 UTC
+++ browser.c
@@ -32,6 +32,7 @@
#ifdef USE_IMAP
diff --git a/mail/mutt/files/extra-patch-reverse_reply b/mail/mutt/files/extra-patch-reverse_reply
index 0147778998ba..f781b96e31db 100644
--- a/mail/mutt/files/extra-patch-reverse_reply
+++ b/mail/mutt/files/extra-patch-reverse_reply
@@ -1,10 +1,10 @@
---- PATCHES.orig 2022-06-05 20:10:54 UTC
+--- PATCHES.orig 2023-05-05 18:53:09 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.6.cb.reverse_reply.2
---- init.h.orig 2022-06-05 20:10:54 UTC
+--- init.h.orig 2023-05-05 18:53:08 UTC
+++ init.h
-@@ -3431,6 +3431,13 @@ struct option_t MuttVars[] = {
+@@ -3422,6 +3422,13 @@ struct option_t MuttVars[] = {
** In either case, a missing real name will be filled in afterwards
** using the value of $$realname.
*/
@@ -18,9 +18,9 @@
{ "rfc2047_parameters", DT_BOOL, R_NONE, {.l=OPTRFC2047PARAMS}, {.l=1} },
/*
** .pp
---- mutt.h.orig 2022-06-05 20:10:54 UTC
+--- mutt.h.orig 2023-03-25 19:50:20 UTC
+++ mutt.h
-@@ -538,6 +538,7 @@ enum
+@@ -535,6 +535,7 @@ enum
OPTREVALIAS,
OPTREVNAME,
OPTREVREAL,
@@ -28,7 +28,7 @@
OPTRFC2047PARAMS,
OPTSAVEADDRESS,
OPTSAVEEMPTY,
---- protos.h.orig 2022-05-21 16:36:29 UTC
+--- protos.h.orig 2023-03-06 23:17:21 UTC
+++ protos.h
@@ -86,6 +86,7 @@ char* mutt_extract_message_id (const char *, const cha
ADDRESS *mutt_get_address (ENVELOPE *, char **);
@@ -38,7 +38,7 @@
ADDRESS *mutt_remove_adrlist_group_delimiters (ADDRESS *);
ADDRESS *mutt_expand_aliases (ADDRESS *);
ADDRESS *mutt_parse_adrlist (ADDRESS *, const char *);
---- send.c.orig 2022-05-11 16:57:07 UTC
+--- send.c.orig 2023-01-02 04:42:19 UTC
+++ send.c
@@ -744,6 +744,10 @@ void mutt_fix_reply_recipients (ENVELOPE *env)
/* the CC field can get cluttered, especially with lists */
@@ -51,9 +51,9 @@
env->cc = mutt_remove_xrefs (env->to, env->cc);
if (env->cc && !env->to)
---- sendlib.c.orig 2022-05-27 21:24:33 UTC
+--- sendlib.c.orig 2023-03-06 23:17:21 UTC
+++ sendlib.c
-@@ -3108,6 +3108,37 @@ static void set_noconv_flags (BODY *b, short flag)
+@@ -3117,6 +3117,37 @@ static void set_noconv_flags (BODY *b, short flag)
}
}
diff --git a/mail/mutt/files/extra-patch-smartdate b/mail/mutt/files/extra-patch-smartdate
index a0e81c699146..5279fca8f238 100644
--- a/mail/mutt/files/extra-patch-smartdate
+++ b/mail/mutt/files/extra-patch-smartdate
@@ -1,4 +1,4 @@
---- hdrline.c.orig 2022-06-05 20:10:54 UTC
+--- hdrline.c.orig 2023-05-05 18:53:08 UTC
+++ hdrline.c
@@ -249,6 +249,89 @@ static char *apply_subject_mods (ENVELOPE *env)
* %Y = `x-label:' field (if present, tree unfolded, and != parent's x-label)
@@ -105,7 +105,7 @@
if (!do_locales)
setlocale (LC_TIME, "");
---- mutt.h.orig 2022-06-05 20:10:54 UTC
+--- mutt.h.orig 2023-05-05 18:53:09 UTC
+++ mutt.h
@@ -168,6 +168,16 @@ typedef enum
MUTT_WRITE_HEADER_MIME
diff --git a/mail/mutt/files/extra-smime-sender b/mail/mutt/files/extra-smime-sender
index 5e689aa61ff7..175dd525aade 100644
--- a/mail/mutt/files/extra-smime-sender
+++ b/mail/mutt/files/extra-smime-sender
@@ -1,4 +1,4 @@
---- commands.c.orig 2022-05-11 16:57:07 UTC
+--- commands.c.orig 2023-01-02 04:42:19 UTC
+++ commands.c
@@ -302,7 +302,7 @@ int mutt_display_message (HEADER *cur)
{
@@ -9,9 +9,9 @@
mutt_message ( _("S/MIME signature successfully verified."));
else
mutt_error ( _("S/MIME certificate owner does not match sender."));
---- init.h.orig 2022-06-05 20:10:54 UTC
+--- init.h.orig 2023-05-05 18:53:09 UTC
+++ init.h
-@@ -3935,6 +3935,15 @@ struct option_t MuttVars[] = {
+@@ -3926,6 +3926,15 @@ struct option_t MuttVars[] = {
** to determine the key to use. It will ask you to supply a key, if it can't find one.
** (S/MIME only)
*/
@@ -27,9 +27,9 @@
{ "smime_self_encrypt_as", DT_SYN, R_NONE, {.p="smime_default_key"}, {.p=0} },
{ "smime_default_key", DT_STR, R_NONE, {.p=&SmimeDefaultKey}, {.p=0} },
/*
---- mutt.h.orig 2022-06-05 20:10:55 UTC
+--- mutt.h.orig 2023-05-05 18:53:09 UTC
+++ mutt.h
-@@ -622,6 +622,7 @@ enum
+@@ -619,6 +619,7 @@ enum
OPTSMIMEISDEFAULT,
OPTSMIMESELFENCRYPT,
OPTASKCERTLABEL,
diff --git a/mail/mutt/files/patch-date-conditional b/mail/mutt/files/patch-date-conditional
index d2845e668636..50ba71f97bd0 100644
--- a/mail/mutt/files/patch-date-conditional
+++ b/mail/mutt/files/patch-date-conditional
@@ -1,8 +1,8 @@
---- PATCHES.orig 2022-06-05 20:10:55 UTC
+--- PATCHES.orig 2023-05-05 18:53:09 UTC
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.0.ats.date_conditional.1
---- hdrline.c.orig 2022-06-05 20:10:55 UTC
+--- hdrline.c.orig 2023-05-05 18:53:09 UTC
+++ hdrline.c
@@ -428,6 +428,53 @@ hdr_format_str (char *dest,
const char *cp;
@@ -58,7 +58,7 @@
p = dest;
---- muttlib.c.orig 2022-05-21 16:36:29 UTC
+--- muttlib.c.orig 2023-01-02 04:42:19 UTC
+++ muttlib.c
@@ -1701,7 +1701,16 @@ void mutt_FormatString (char *dest, /* output buffer
if (*src == '?')
diff --git a/mail/mutt/files/patch-dgc-deepif b/mail/mutt/files/patch-dgc-deepif
index b9ca5a455924..91a7673908e3 100644
--- a/mail/mutt/files/patch-dgc-deepif
+++ b/mail/mutt/files/patch-dgc-deepif
@@ -1,4 +1,4 @@
---- muttlib.c.orig 2022-06-05 20:10:55 UTC
+--- muttlib.c.orig 2023-05-05 18:53:09 UTC
+++ muttlib.c
@@ -1744,6 +1744,12 @@ void mutt_FormatString (char *dest, /* output buffer
count = 0;
diff --git a/mail/mutt/pkg-message b/mail/mutt/pkg-message
new file mode 100644
index 000000000000..9376d168a883
--- /dev/null
+++ b/mail/mutt/pkg-message
@@ -0,0 +1,18 @@
+[
+{ type: install
+ message: <<EOM
+The patches included in the mail/mutt port will be removed in approximately a
+month making the port more inline with upstream. If you require any of these
+features most are available in mail/neomutt or it's possible to use
+EXTRA_PATCH_TREE to patch a port when building locally.
+EOM
+}
+{ type: upgrade
+ message: <<EOM
+The patches included in the mail/mutt port will be removed in approximately a
+month making the port more inline with upstream. If you require any of these
+features most are available in mail/neomutt or it's possible to use
+EXTRA_PATCH_TREE to patch a port when building locally.
+EOM
+}
+]