aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-29 22:34:15 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-29 23:20:55 +0000
commitf099cf5cb3173b0a9225ebd903025abd49dd5348 (patch)
tree321598e6bea9113ac20e60e749505214ab3ae283
parent1ffe18f965ccde7c91c27c645594b986ed1934d1 (diff)
downloadports-f099cf5cb3173b0a9225ebd903025abd49dd5348.tar.gz
ports-f099cf5cb3173b0a9225ebd903025abd49dd5348.zip
math/casadi: Remove redundant clause
There was USES=llvm and also *_DEPENDS with llvm ports. So these have been merged into USES=llvm/ USES=llvm now by default exports CC/CPP/CXX so remove those Approved by: portmgr (blanket)
-rw-r--r--math/casadi/Makefile13
1 files changed, 1 insertions, 12 deletions
diff --git a/math/casadi/Makefile b/math/casadi/Makefile
index 4bcfa10de880..570d96ffb215 100644
--- a/math/casadi/Makefile
+++ b/math/casadi/Makefile
@@ -48,7 +48,7 @@ BONMIN_LIB_DEPENDS= libbonmin.so:math/bonmin \
libOsi.so:math/osi
CLANG_DESC= Build with clang for JIT
-CLANG_USES= llvm:16
+CLANG_USES= llvm:16,build,run
CLANG_CMAKE_BOOL= WITH_CLANG
CLANG_CMAKE_ON= -DLLVM_INSTALL_PREFIX=${LLVM_PREFIX} -DOLD_LLVM=ON
CLANG_BROKEN= fails to find clang, see https://github.com/casadi/casadi/issues/3089
@@ -67,17 +67,6 @@ QPOASES_CMAKE_BOOL= WITH_QPOASES
QPOASES_LIB_DEPENDS= libopenblas.so:math/openblas
QPOASES_IMPLIES= LAPACK
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCLANG}
-# use clang from ports because cmake can't find base llvm for JIT
-BUILD_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
-RUN_DEPENDS+= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT}
-CPP= clang-cpp${LLVM_DEFAULT}
-CC= clang${LLVM_DEFAULT}
-CXX= clang++${LLVM_DEFAULT}
-.endif
-
PORTSCOUT= limit:^.*[1-9]\..* # prevent tags like ge2
.include <bsd.port.mk>