aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2024-06-19 15:39:57 +0000
committerLarry Rosenman <ler@FreeBSD.org>2024-06-19 15:42:26 +0000
commitf0b32d410a3087de33a81b19ea76d6aa5c97e073 (patch)
tree793d36afbdb6a2ca0f461c3f2f054543bc804df2
parented4a701cd7078342f84bc0e7749530f57f00b05e (diff)
downloadports-f0b32d410a3087de33a81b19ea76d6aa5c97e073.tar.gz
ports-f0b32d410a3087de33a81b19ea76d6aa5c97e073.zip
devel/cdecl: update to 17.0.1
ChangeLog: 16.4.1 -> 17.0 Abbreviated function template parameter packs Functions with auto parameters (abbreviated function templates) like: int f( auto x ) have been supported since cdecl 9.6; this release adds additional support for parameter packs like: int f( auto ...x ) Added help option suggestions Added suggestions to error messages for the help options commands, english, and options, for example: cdecl> help eglish ^ 6: "eglish": no such command or option; did you mean "english"? Constrained auto For abbreviated function templates, constrained auto declarations are now supported: c++decl> explain C auto x declare x as concept C c++decl> explain C auto ...x declare x as concept C parameter pack auto parameters in typedefs Use of auto in typedef function-like parameters is now correctly reported as an error: c++decl> typedef int F(auto) ^ 15: error: "auto" illegal in type definition decltype declarations Now recognizing decltype just to say it's not supported. Glob help The help text now defines "glob." GNU --version Now printing cdecl copyright year, author, license, free software statement, and no warranty statement to conform to the GNU Coding Standards; see https://www.gnu.org/prep/standards/html_node/_002d_002dversion.html. Structured binding declarations Structured binding declarations are now supported except that you don't assign them from anything (no = expression): c++decl> explain auto [x, y] declare x, y as structured binding c++decl> explain auto&& [x, y] declare x, y as rvalue reference to structured binding Fixed operator declaration core dump An invalid scoped operator name containing a keyword like: c++decl> explain bool int::operator!() would dump core; fixed. Fixed --west-decl=t for pointer to const pointer Given: c++decl --west-decl=t 'declare p as pointer to const pointer to int' you'd incorrectly get: int *const *p; You now correctly get: int* const* p; 17.0 -> 17.0.1: Fixed returning parameter packs Functions returning parameter packs is now correctly illegal.
-rw-r--r--devel/cdecl/Makefile2
-rw-r--r--devel/cdecl/distinfo6
2 files changed, 4 insertions, 4 deletions
diff --git a/devel/cdecl/Makefile b/devel/cdecl/Makefile
index b1a6590f75bc..c41470d19a96 100644
--- a/devel/cdecl/Makefile
+++ b/devel/cdecl/Makefile
@@ -1,5 +1,5 @@
PORTNAME= cdecl
-PORTVERSION= 16.4.1
+PORTVERSION= 17.0.1
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= devel
diff --git a/devel/cdecl/distinfo b/devel/cdecl/distinfo
index 4f0a066ccf2e..0c1bf6b3cee7 100644
--- a/devel/cdecl/distinfo
+++ b/devel/cdecl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1717598505
-SHA256 (paul-j-lucas-cdecl-cdecl-16.4.1_GH0.tar.gz) = d955a2b6115c49f39b006c06d330548a015541dc958317de2e4811d18f121f2b
-SIZE (paul-j-lucas-cdecl-cdecl-16.4.1_GH0.tar.gz) = 974214
+TIMESTAMP = 1718811582
+SHA256 (paul-j-lucas-cdecl-cdecl-17.0.1_GH0.tar.gz) = 36aa05c6372422c3daa36cb50c51919daf4dddf3ff3b4da8f5763483d66b3226
+SIZE (paul-j-lucas-cdecl-cdecl-17.0.1_GH0.tar.gz) = 989226