aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 23:26:31 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-30 23:26:31 +0000
commitf0c874797fd2e873d64cd531d7f3723d20e0fd6b (patch)
tree6d083d36f08b1728b6277a1f368f1497064ac7c4
parent5871047a1818e09695d57d8cb4e6beeefc74cced (diff)
downloadports-f0c874797fd2e873d64cd531d7f3723d20e0fd6b.tar.gz
ports-f0c874797fd2e873d64cd531d7f3723d20e0fd6b.zip
devel/py-zc.lockfile: Add py-zc.lockfile 3.0.post1
The zc.lockfile package provides a basic portable implementation of interprocess locks using lock files. The purpose if not specifically to lock files, but to simply provide locks with an implementation based on file-locking primitives. Of course, these locks could be used to mediate access to other files. For example, the ZODB file storage implementation uses file locks to mediate access to file-storage database files. The database files and lock file files are separate files.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-zc.lockfile/Makefile19
-rw-r--r--devel/py-zc.lockfile/distinfo3
-rw-r--r--devel/py-zc.lockfile/files/patch-setup.py10
-rw-r--r--devel/py-zc.lockfile/pkg-descr7
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d27aa49d2d78..8260ffb245b0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5857,6 +5857,7 @@
SUBDIR += py-ypy-websocket
SUBDIR += py-yunomi
SUBDIR += py-zarr
+ SUBDIR += py-zc.lockfile
SUBDIR += py-zclockfile
SUBDIR += py-zconfig
SUBDIR += py-zfp
diff --git a/devel/py-zc.lockfile/Makefile b/devel/py-zc.lockfile/Makefile
new file mode 100644
index 000000000000..8c4950f52d6b
--- /dev/null
+++ b/devel/py-zc.lockfile/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= zc.lockfile
+PORTVERSION= 3.0.post1
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Basic inter-process locks
+WWW= https://github.com/zopefoundation/zc.lockfile
+
+LICENSE= ZPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-zc.lockfile/distinfo b/devel/py-zc.lockfile/distinfo
new file mode 100644
index 000000000000..6e8f9b6f78df
--- /dev/null
+++ b/devel/py-zc.lockfile/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1696048420
+SHA256 (zc.lockfile-3.0.post1.tar.gz) = adb2ee6d9e6a2333c91178dcb2c9b96a5744c78edb7712dc784a7d75648e81ec
+SIZE (zc.lockfile-3.0.post1.tar.gz) = 10190
diff --git a/devel/py-zc.lockfile/files/patch-setup.py b/devel/py-zc.lockfile/files/patch-setup.py
new file mode 100644
index 000000000000..10dd9911b7e3
--- /dev/null
+++ b/devel/py-zc.lockfile/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2023-02-28 07:30:06 UTC
++++ setup.py
+@@ -50,7 +50,6 @@ setup(
+ package_dir={'': 'src'},
+ namespace_packages=['zc'],
+ python_requires='>=3.7',
+- install_requires='setuptools',
+ extras_require=dict(
+ test=[
+ 'zope.testing',
diff --git a/devel/py-zc.lockfile/pkg-descr b/devel/py-zc.lockfile/pkg-descr
new file mode 100644
index 000000000000..d15ebce3fdde
--- /dev/null
+++ b/devel/py-zc.lockfile/pkg-descr
@@ -0,0 +1,7 @@
+The zc.lockfile package provides a basic portable implementation of interprocess
+locks using lock files. The purpose if not specifically to lock files, but to
+simply provide locks with an implementation based on file-locking primitives. Of
+course, these locks could be used to mediate access to other files. For example,
+the ZODB file storage implementation uses file locks to mediate access to
+file-storage database files. The database files and lock file files are separate
+files.