aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2024-01-05 20:46:58 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2024-01-05 20:48:23 +0000
commitf1885a5e16f3ec91ade46d40035ae4c0a2a44cf8 (patch)
tree9f77ca57378746948960e7169fff1b92b849d817
parent4064f529750018be195bba4e010d0439723db85b (diff)
downloadports-f1885a5e16f3ec91ade46d40035ae4c0a2a44cf8.tar.gz
ports-f1885a5e16f3ec91ade46d40035ae4c0a2a44cf8.zip
security/bareos-*: Update to 22.1.3
- Fix pkg-plist [1] PR: 270967 Reported by: ddrinnon _at_ cdor.net [1]
-rw-r--r--sysutils/bareos-server/Makefile4
-rw-r--r--sysutils/bareos-server/distinfo6
-rw-r--r--sysutils/bareos-server/files/patch-core-cmake_BareosInstallConfigFiles.cmake80
-rw-r--r--sysutils/bareos-server/pkg-plist1
-rw-r--r--sysutils/py-python-bareos/Makefile2
-rw-r--r--sysutils/py-python-bareos/distinfo6
-rw-r--r--www/bareos-webui/Makefile2
-rw-r--r--www/bareos-webui/distinfo6
8 files changed, 56 insertions, 51 deletions
diff --git a/sysutils/bareos-server/Makefile b/sysutils/bareos-server/Makefile
index 62c22e675c83..b3df0a11aec7 100644
--- a/sysutils/bareos-server/Makefile
+++ b/sysutils/bareos-server/Makefile
@@ -1,6 +1,6 @@
PORTNAME= bareos
DISTVERSIONPREFIX= Release/
-DISTVERSION= 22.0.3
+DISTVERSION= 22.1.3
PORTREVISION?= 0
CATEGORIES?= sysutils
PKGNAMEPREFIX?= #
@@ -215,7 +215,7 @@ post-extract:
post-install:
.if defined(WITH_CLIENT_ONLY)
${MKDIR} ${STAGEDIR}${ETCDIR}/bconsole.d/
- ${MV} ${STAGEDIR}${ETCDIR}/bconsole.conf ${STAGEDIR}${ETCDIR}/bconsole.d/bconsole.conf.sample
+ ${MV} ${STAGEDIR}${ETCDIR}/bconsole.conf.sample ${STAGEDIR}${ETCDIR}/bconsole.d/bconsole.conf.sample
.else
${INSTALL_SCRIPT} ${FILESDIR}/chio-bareos ${STAGEDIR}${PREFIX}/sbin
${INSTALL_DATA} ${FILESDIR}/bareos-barcodes ${STAGEDIR}${ETCDIR}/bareos-barcodes.sample
diff --git a/sysutils/bareos-server/distinfo b/sysutils/bareos-server/distinfo
index 5663ab3f8511..e6ac2baf20d2 100644
--- a/sysutils/bareos-server/distinfo
+++ b/sysutils/bareos-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1680719160
-SHA256 (bareos-bareos-Release-22.0.3_GH0.tar.gz) = 3ea98d4ca78e4451ce4f4e2990547de0872330ab115eb27e1471c3af34380404
-SIZE (bareos-bareos-Release-22.0.3_GH0.tar.gz) = 14529338
+TIMESTAMP = 1704433438
+SHA256 (bareos-bareos-Release-22.1.3_GH0.tar.gz) = 765bf250a34296756051e896b28130b2ca3965cebaf310116c50e3e6c63d7d52
+SIZE (bareos-bareos-Release-22.1.3_GH0.tar.gz) = 14745204
diff --git a/sysutils/bareos-server/files/patch-core-cmake_BareosInstallConfigFiles.cmake b/sysutils/bareos-server/files/patch-core-cmake_BareosInstallConfigFiles.cmake
index 63a6f9eec824..85e738c8e9f4 100644
--- a/sysutils/bareos-server/files/patch-core-cmake_BareosInstallConfigFiles.cmake
+++ b/sysutils/bareos-server/files/patch-core-cmake_BareosInstallConfigFiles.cmake
@@ -1,33 +1,41 @@
---- core/cmake/BareosInstallConfigFiles.cmake 2020-12-16 02:46:16.000000000 -0500
-+++ core/cmake/BareosInstallConfigFiles.cmake 2020-12-23 22:41:21.832081000 -0500
-@@ -55,20 +55,12 @@
- get_filename_component(resname ${resdir} NAME)
- foreach(configfile ${configfiles})
- get_filename_component(fname ${configfile} NAME)
-- if(EXISTS ${DESTCONFDIR}/${resname}/${fname})
-- message(STATUS "${DESTCONFDIR}/${resname}/${fname} exists")
-- message(STATUS "rename ${configfile} to ${configfile}.new")
-- file(RENAME "${configfile}" "${configfile}.new")
--
-- message(STATUS "copy ${configfile}.new to ${DESTCONFDIR}/${resname}")
-- file(COPY "${configfile}.new" DESTINATION "${DESTCONFDIR}/${resname}")
-- file(RENAME "${configfile}.new" "${configfile}")
-- else()
-- message(
-- STATUS "${resname}/${fname} as ${resname}/${fname} (new installation)"
-- )
-- file(COPY "${configfile}" DESTINATION "${DESTCONFDIR}/${resname}")
-- endif()
-+ message(STATUS "${resname}/${fname} as ${resname}/${fname}.sample (new installation)")
-+ file(RENAME "${configfile}" "${configfile}.sample")
-+ file(
-+ COPY "${configfile}.sample"
-+ DESTINATION "${DESTCONFDIR}/${resname}"
-+ )
- endforeach()
- endforeach()
+--- core/cmake/BareosInstallConfigFiles.cmake 2023-12-13 07:48:37.000000000 -0500
++++ core/cmake/BareosInstallConfigFiles.cmake 2024-01-05 01:02:51.562611000 -0500
+@@ -27,27 +27,13 @@
+ endif()
-@@ -104,23 +96,12 @@
+ get_filename_component(fname ${configfile} NAME)
+- if(EXISTS ${DESTCONFDIR}${additionalconfigdir}/${fname})
+- message(
+- STATUS "${DESTCONFDIR}${additionalconfigdir}/${fname} already exists"
+- )
+- message(
+- STATUS
+- "Installing config: ${DESTCONFDIR}${additionalconfigdir}/${fname}.new"
+- )
+- file(RENAME "${configfile}" "${configfile}.new")
+- file(COPY "${configfile}.new"
+- DESTINATION "${DESTCONFDIR}${additionalconfigdir}"
+- )
+- file(RENAME "${configfile}.new" "${configfile}")
+- else()
+- message(
+- STATUS "Installing config: ${DESTCONFDIR}${additionalconfigdir}/${fname}"
+- )
+- file(COPY "${configfile}"
+- DESTINATION "${DESTCONFDIR}${additionalconfigdir}"
+- )
+- endif()
++
++ message(STATUS "${DESTCONFDIR}${additionalconfigdir}/${fname} as ${DESTCONFDIR}${additionalconfigdir}/${fname}.sample (new installation)")
++ file(RENAME "${configfile}" "${configfile}.sample")
++ file(
++ COPY "${configfile}.sample"
++ DESTINATION "${DESTCONFDIR}${additionalconfigdir}"
++ )
+ endfunction()
+
+ macro(BareosInstallConfigFiles CONFDIR CONFIGBASEDIRECTORY PLUGINS BACKENDS
+@@ -125,23 +111,12 @@
get_filename_component(dir ${configfile} DIRECTORY)
get_filename_component(fname ${configfile} NAME)
@@ -48,7 +56,7 @@
- DESTINATION "${DESTCONFDIR}/${dir}"
- )
- endif()
-+ message(STATUS "${configfile} as ${configfile}")
++ message(STATUS "${configfile} as ${configfile}.sample")
+ file(RENAME "${BackendConfigSrcDir}/${configfile}" "${BackendConfigSrcDir}/${configfile}.sample")
+ file(
+ COPY "${BackendConfigSrcDir}/${configfile}.sample"
@@ -57,7 +65,7 @@
endforeach()
file(
-@@ -130,7 +111,8 @@
+@@ -151,7 +126,8 @@
)
foreach(configfile ${configfiles})
get_filename_component(dir ${configfile} DIRECTORY)
@@ -67,22 +75,20 @@
if(EXISTS ${DESTCONFDIR}/${configfile})
message(STATUS "overwriting ${configfile}")
-@@ -138,9 +120,11 @@
+@@ -159,8 +135,10 @@
message(STATUS "${configfile} as ${configfile}")
endif()
- file(COPY "${BackendConfigSrcDir}/${configfile}"
- DESTINATION "${DESTCONFDIR}/${dir}"
-- )
+ file(RENAME "${BackendConfigSrcDir}/${configfile}" "${BackendConfigSrcDir}/${fsname}.conf.sample")
-+ file(
++ file(
+ COPY "${BackendConfigSrcDir}/${fsname}.conf.sample"
+ DESTINATION "${DESTCONFDIR}/${dir}"
-+ )
+ )
endforeach()
- endforeach()
-@@ -167,20 +151,13 @@
+@@ -188,20 +166,13 @@
string(REGEX MATCH "\\.in\$" IS_INFILE ${configfile})
if(NOT "${IS_INFILE}" STREQUAL ".in")
get_filename_component(fname ${configfile} NAME)
diff --git a/sysutils/bareos-server/pkg-plist b/sysutils/bareos-server/pkg-plist
index c6114abb9712..5fe4dcb666e8 100644
--- a/sysutils/bareos-server/pkg-plist
+++ b/sysutils/bareos-server/pkg-plist
@@ -45,7 +45,6 @@ bin/bwild
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/director/bareos-mon.conf.sample
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/messages/Standard.conf.sample
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/storage/bareos-sd.conf.sample
-%%PYTHON%%@sample(,bareos,640) %%ETCDIR%%/bsmc.conf
%%MTX%%@sample(,bareos,640) %%ETCDIR%%/mtx-changer.conf.sample
etc/logrotate.d/bareos-dir
lib/bareos/backends/libbareoscats-%%DBTYPE%%.so
diff --git a/sysutils/py-python-bareos/Makefile b/sysutils/py-python-bareos/Makefile
index ee81dd363e94..92fc480b93e2 100644
--- a/sysutils/py-python-bareos/Makefile
+++ b/sysutils/py-python-bareos/Makefile
@@ -1,5 +1,5 @@
PORTNAME= python-bareos
-PORTVERSION= 22.0.3
+PORTVERSION= 22.1.3
CATEGORIES= sysutils python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/sysutils/py-python-bareos/distinfo b/sysutils/py-python-bareos/distinfo
index cd59bc6235f1..dc44ef59006a 100644
--- a/sysutils/py-python-bareos/distinfo
+++ b/sysutils/py-python-bareos/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1680908895
-SHA256 (python-bareos-22.0.3.tar.gz) = 2988b4efb583538ee6679cfa956b907717c298c895ef91910f1b671c8ae91097
-SIZE (python-bareos-22.0.3.tar.gz) = 23622
+TIMESTAMP = 1704486902
+SHA256 (python-bareos-22.1.3.tar.gz) = e3ff6c7c9bc67898360315844afe128b8d176cb0f6d0df59b0ea6a9b43ec4350
+SIZE (python-bareos-22.1.3.tar.gz) = 35782
diff --git a/www/bareos-webui/Makefile b/www/bareos-webui/Makefile
index 272b633a662b..00a41fdf1469 100644
--- a/www/bareos-webui/Makefile
+++ b/www/bareos-webui/Makefile
@@ -1,6 +1,6 @@
PORTNAME= bareos
DISTVERSIONPREFIX= Release/
-DISTVERSION= 22.0.3
+DISTVERSION= 22.1.3
CATEGORIES?= www sysutils
PKGNAMESUFFIX= -webui
diff --git a/www/bareos-webui/distinfo b/www/bareos-webui/distinfo
index 76286a771f9f..fe4153fead46 100644
--- a/www/bareos-webui/distinfo
+++ b/www/bareos-webui/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1680995698
-SHA256 (bareos-bareos-Release-22.0.3_GH0.tar.gz) = 3ea98d4ca78e4451ce4f4e2990547de0872330ab115eb27e1471c3af34380404
-SIZE (bareos-bareos-Release-22.0.3_GH0.tar.gz) = 14529338
+TIMESTAMP = 1704486712
+SHA256 (bareos-bareos-Release-22.1.3_GH0.tar.gz) = 765bf250a34296756051e896b28130b2ca3965cebaf310116c50e3e6c63d7d52
+SIZE (bareos-bareos-Release-22.1.3_GH0.tar.gz) = 14745204