aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-03-27 06:48:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-03-27 07:32:12 +0000
commitf1c0313e583a782529019edd360169319cac8e26 (patch)
treeec17e079a260e74e53ac53a49fe94f09f3cca70f
parentcf52c401af31ec56beb36586713faff03710fc2f (diff)
downloadports-f1c0313e583a782529019edd360169319cac8e26.tar.gz
ports-f1c0313e583a782529019edd360169319cac8e26.zip
misc/onnx: update 1.14.1 → 1.16.0
Reported by: portscout
-rw-r--r--misc/onnx/Makefile6
-rw-r--r--misc/onnx/distinfo6
-rw-r--r--misc/onnx/files/patch-CMakeLists.txt11
-rw-r--r--misc/onnx/pkg-plist12
4 files changed, 17 insertions, 18 deletions
diff --git a/misc/onnx/Makefile b/misc/onnx/Makefile
index ce6121a3b273..ac48c98a07dc 100644
--- a/misc/onnx/Makefile
+++ b/misc/onnx/Makefile
@@ -1,7 +1,6 @@
PORTNAME= onnx
DISTVERSIONPREFIX= v
-DISTVERSION= 1.14.1
-PORTREVISION= 1
+DISTVERSION= 1.16.0
CATEGORIES= misc # machine-learning
MAINTAINER= yuri@FreeBSD.org
@@ -12,7 +11,8 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
#BUILD_DEPENDS= bash:shells/bash
-LIB_DEPENDS= libprotobuf.so:devel/protobuf
+LIB_DEPENDS= libabsl_base.so:devel/abseil \
+ libprotobuf.so:devel/protobuf
USES= cmake:testing compiler:c++17-lang python:build
diff --git a/misc/onnx/distinfo b/misc/onnx/distinfo
index dc63d858c00c..aab7a4987f38 100644
--- a/misc/onnx/distinfo
+++ b/misc/onnx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1693028136
-SHA256 (onnx-onnx-v1.14.1_GH0.tar.gz) = e296f8867951fa6e71417a18f2e550a730550f8829bd35e947b4df5e3e777aa1
-SIZE (onnx-onnx-v1.14.1_GH0.tar.gz) = 11570627
+TIMESTAMP = 1711521307
+SHA256 (onnx-onnx-v1.16.0_GH0.tar.gz) = 0ce153e26ce2c00afca01c331a447d86fbf21b166b640551fe04258b4acfc6a4
+SIZE (onnx-onnx-v1.16.0_GH0.tar.gz) = 12428161
diff --git a/misc/onnx/files/patch-CMakeLists.txt b/misc/onnx/files/patch-CMakeLists.txt
deleted file mode 100644
index fafb0e60da96..000000000000
--- a/misc/onnx/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2023-08-24 22:20:34 UTC
-+++ CMakeLists.txt
-@@ -58,7 +58,7 @@ endif()
- # Required to use /std:c++17 or higher on Windows
- # For other platforms, set C++11 as standard for the whole project
- if(NOT MSVC)
-- set(CMAKE_CXX_STANDARD 11)
-+ set(CMAKE_CXX_STANDARD 17)
- else()
- string(APPEND CMAKE_CXX_FLAGS " /std:c++17")
- endif()
diff --git a/misc/onnx/pkg-plist b/misc/onnx/pkg-plist
index 7df29da481e7..d0569c202351 100644
--- a/misc/onnx/pkg-plist
+++ b/misc/onnx/pkg-plist
@@ -11,15 +11,17 @@ include/onnx/common/ir_pb_converter.h
include/onnx/common/model_helpers.h
include/onnx/common/path.h
include/onnx/common/platform_helpers.h
+include/onnx/common/proto_util.h
include/onnx/common/status.h
-include/onnx/common/stl_backports.h
include/onnx/common/tensor.h
include/onnx/common/version.h
+include/onnx/common/visitor.h
include/onnx/defs/attr_proto_util.h
include/onnx/defs/controlflow/utils.h
include/onnx/defs/data_propagators.h
include/onnx/defs/data_type_utils.h
include/onnx/defs/function.h
+include/onnx/defs/generator/utils.h
include/onnx/defs/math/utils.h
include/onnx/defs/operator_sets.h
include/onnx/defs/operator_sets_ml.h
@@ -33,6 +35,8 @@ include/onnx/defs/shape_inference.h
include/onnx/defs/tensor/utils.h
include/onnx/defs/tensor_proto_util.h
include/onnx/defs/tensor_util.h
+include/onnx/defs/traditionalml/utils.h
+include/onnx/inliner/inliner.h
include/onnx/onnx-data.pb.h
include/onnx/onnx-data_pb.h
include/onnx/onnx-ml.pb.h
@@ -41,12 +45,15 @@ include/onnx/onnx-operators_pb.h
include/onnx/onnx_pb.h
include/onnx/proto_utils.h
include/onnx/py_utils.h
+include/onnx/shape_inference/attribute_binder.h
include/onnx/shape_inference/implementation.h
include/onnx/string_utils.h
include/onnx/version_converter/BaseConverter.h
include/onnx/version_converter/adapters/adapter.h
include/onnx/version_converter/adapters/axes_attribute_to_input.h
include/onnx/version_converter/adapters/axes_input_to_attribute.h
+include/onnx/version_converter/adapters/axis_attribute_to_input.h
+include/onnx/version_converter/adapters/axis_input_to_attribute.h
include/onnx/version_converter/adapters/batch_normalization_13_14.h
include/onnx/version_converter/adapters/broadcast_backward_compatibility.h
include/onnx/version_converter/adapters/broadcast_forward_compatibility.h
@@ -57,9 +64,12 @@ include/onnx/version_converter/adapters/dropout_11_12.h
include/onnx/version_converter/adapters/extend_supported_types.h
include/onnx/version_converter/adapters/gemm_6_7.h
include/onnx/version_converter/adapters/gemm_7_6.h
+include/onnx/version_converter/adapters/gridsample_19_20.h
+include/onnx/version_converter/adapters/group_normalization_20_21.h
include/onnx/version_converter/adapters/maxpool_8_7.h
include/onnx/version_converter/adapters/no_previous_version.h
include/onnx/version_converter/adapters/pad_10_11.h
+include/onnx/version_converter/adapters/q_dq_21_20.h
include/onnx/version_converter/adapters/remove_consumed_inputs.h
include/onnx/version_converter/adapters/reshape_4_5.h
include/onnx/version_converter/adapters/reshape_5_4.h