aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 02:10:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-10-03 02:10:16 +0000
commitf1f15ae8f1b94dc8f2eceb948aa977da61a88b19 (patch)
tree02fee6b3f66f7d5da6d44b24ae7a19b90b25e8f5
parentcdcb83bfbffa5c0ecf5135e9247f9f5c14915fec (diff)
downloadports-f1f15ae8f1b94dc8f2eceb948aa977da61a88b19.tar.gz
ports-f1f15ae8f1b94dc8f2eceb948aa977da61a88b19.zip
devel/p5-Test-Archive-Libarchive: Add p5-Test-Archive-Libarchive 0.02
Error handling for libarchive and Archive::Libarchive is fairly primitive. Most methods return an int which correspond to ARCHIVE_EOF, ARCHIVE_OK, ARCHIVE_RETRY, ARCHIVE_WARN, ARCHIVE_FAILED or ARCHIVE_FATAL. Some methods will also return the number of actual bytes written on success and one of these codes on failure. It can be tedious doing the necessary checks for each method call in a test, so this module provides tools for testing Archive::Libarchive method calls that follow this pattern.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Archive-Libarchive/Makefile24
-rw-r--r--devel/p5-Test-Archive-Libarchive/distinfo3
-rw-r--r--devel/p5-Test-Archive-Libarchive/pkg-descr7
-rw-r--r--devel/p5-Test-Archive-Libarchive/pkg-plist2
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6bd5c3949494..edeebb78b154 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3388,6 +3388,7 @@
SUBDIR += p5-Test-Able
SUBDIR += p5-Test-Able-Runner
SUBDIR += p5-Test-Aggregate
+ SUBDIR += p5-Test-Archive-Libarchive
SUBDIR += p5-Test-Assertions
SUBDIR += p5-Test-Auto
SUBDIR += p5-Test-Base
diff --git a/devel/p5-Test-Archive-Libarchive/Makefile b/devel/p5-Test-Archive-Libarchive/Makefile
new file mode 100644
index 000000000000..83b0b432312b
--- /dev/null
+++ b/devel/p5-Test-Archive-Libarchive/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= Test-Archive-Libarchive
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Testing tools for Archive::Libarchive
+WWW= https://metacpan.org/dist/Test-Archive-Libarchive
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Ref-Util>=0:devel/p5-Ref-Util \
+ p5-Test2-Suite>=0.000121:devel/p5-Test2-Suite
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Archive-Libarchive/distinfo b/devel/p5-Test-Archive-Libarchive/distinfo
new file mode 100644
index 000000000000..dffa12165233
--- /dev/null
+++ b/devel/p5-Test-Archive-Libarchive/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1663672730
+SHA256 (Test-Archive-Libarchive-0.02.tar.gz) = 2b1918671e05da2d9d222c10c7d917585a624186feafb8f84908599c34702751
+SIZE (Test-Archive-Libarchive-0.02.tar.gz) = 17622
diff --git a/devel/p5-Test-Archive-Libarchive/pkg-descr b/devel/p5-Test-Archive-Libarchive/pkg-descr
new file mode 100644
index 000000000000..9471d95e1149
--- /dev/null
+++ b/devel/p5-Test-Archive-Libarchive/pkg-descr
@@ -0,0 +1,7 @@
+Error handling for libarchive and Archive::Libarchive is fairly primitive. Most
+methods return an int which correspond to ARCHIVE_EOF, ARCHIVE_OK,
+ARCHIVE_RETRY, ARCHIVE_WARN, ARCHIVE_FAILED or ARCHIVE_FATAL. Some methods will
+also return the number of actual bytes written on success and one of these codes
+on failure. It can be tedious doing the necessary checks for each method call in
+a test, so this module provides tools for testing Archive::Libarchive method
+calls that follow this pattern.
diff --git a/devel/p5-Test-Archive-Libarchive/pkg-plist b/devel/p5-Test-Archive-Libarchive/pkg-plist
new file mode 100644
index 000000000000..c38485e81329
--- /dev/null
+++ b/devel/p5-Test-Archive-Libarchive/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Test/Archive/Libarchive.pm
+%%PERL5_MAN3%%/Test::Archive::Libarchive.3.gz