aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLewis Cook <lcook@FreeBSD.org>2022-04-05 20:59:45 +0000
committerLewis Cook <lcook@FreeBSD.org>2022-04-05 21:08:17 +0000
commitf204688efbf27343f71126c021b3a7bd5c370959 (patch)
tree46c347cb5db8e980a9794bf7831fb754f1cdaa40
parent439ced8ad218cb7d4853f6740dce3268a9f7c50e (diff)
downloadports-f204688efbf27343f71126c021b3a7bd5c370959.tar.gz
ports-f204688efbf27343f71126c021b3a7bd5c370959.zip
www/amfora: Resolve crash on startup if TERM not recognized
PR: 262863 Reported by: Alex Savage <keen.year0891@fastmail.com> MFH: 2022Q2
-rw-r--r--www/amfora/Makefile2
-rw-r--r--www/amfora/files/patch-vendor_github.com_gdamore_tcell_v2_terminfo_t_tmux_term.go68
2 files changed, 69 insertions, 1 deletions
diff --git a/www/amfora/Makefile b/www/amfora/Makefile
index 945bb3bac580..e2ec129831fd 100644
--- a/www/amfora/Makefile
+++ b/www/amfora/Makefile
@@ -1,7 +1,7 @@
PORTNAME= amfora
DISTVERSIONPREFIX= v
DISTVERSION= 1.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= lcook@FreeBSD.org
diff --git a/www/amfora/files/patch-vendor_github.com_gdamore_tcell_v2_terminfo_t_tmux_term.go b/www/amfora/files/patch-vendor_github.com_gdamore_tcell_v2_terminfo_t_tmux_term.go
new file mode 100644
index 000000000000..713cef8209d4
--- /dev/null
+++ b/www/amfora/files/patch-vendor_github.com_gdamore_tcell_v2_terminfo_t_tmux_term.go
@@ -0,0 +1,68 @@
+--- vendor/github.com/gdamore/tcell/v2/terminfo/t/tmux/term.go.orig 2022-04-05 20:54:39 UTC
++++ vendor/github.com/gdamore/tcell/v2/terminfo/t/tmux/term.go
+@@ -68,4 +68,65 @@ func init() {
+ Modifiers: 1,
+ AutoMargin: true,
+ })
++ terminfo.AddTerminfo(&terminfo.Terminfo{
++ Name: "tmux-256color",
++ Columns: 80,
++ Lines: 24,
++ Colors: 256,
++ Bell: "\a",
++ Clear: "\x1b[H\x1b[J",
++ EnterCA: "\x1b[?1049h",
++ ExitCA: "\x1b[?1049l",
++ ShowCursor: "\x1b[34h\x1b[?25h",
++ HideCursor: "\x1b[?25l",
++ AttrOff: "\x1b[m\x0f",
++ Underline: "\x1b[4m",
++ Bold: "\x1b[1m",
++ Dim: "\x1b[2m",
++ Italic: "\x1b[3m",
++ Blink: "\x1b[5m",
++ Reverse: "\x1b[7m",
++ EnterKeypad: "\x1b[?1h\x1b=",
++ ExitKeypad: "\x1b[?1l\x1b>",
++ SetFg: "\x1b[%?%p1%{8}%<%t3%p1%d%e%p1%{16}%<%t9%p1%{8}%-%d%e38;5;%p1%d%;m",
++ SetBg: "\x1b[%?%p1%{8}%<%t4%p1%d%e%p1%{16}%<%t10%p1%{8}%-%d%e48;5;%p1%d%;m",
++ SetFgBg: "\x1b[%?%p1%{8}%<%t3%p1%d%e%p1%{16}%<%t9%p1%{8}%-%d%e38;5;%p1%d%;;%?%p2%{8}%<%t4%p2%d%e%p2%{16}%<%t10%p2%{8}%-%d%e48;5;%p2%d%;m",
++ ResetFgBg: "\x1b[39;49m",
++ PadChar: "\x00",
++ AltChars: "++,,--..00``aaffgghhiijjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~",
++ EnterAcs: "\x0e",
++ ExitAcs: "\x0f",
++ EnableAcs: "\x1b(B\x1b)0",
++ StrikeThrough: "\x1b[9m",
++ Mouse: "\x1b[M",
++ SetCursor: "\x1b[%i%p1%d;%p2%dH",
++ CursorBack1: "\b",
++ CursorUp1: "\x1bM",
++ KeyUp: "\x1bOA",
++ KeyDown: "\x1bOB",
++ KeyRight: "\x1bOC",
++ KeyLeft: "\x1bOD",
++ KeyInsert: "\x1b[2~",
++ KeyDelete: "\x1b[3~",
++ KeyBackspace: "\u007f",
++ KeyHome: "\x1b[1~",
++ KeyEnd: "\x1b[4~",
++ KeyPgUp: "\x1b[5~",
++ KeyPgDn: "\x1b[6~",
++ KeyF1: "\x1bOP",
++ KeyF2: "\x1bOQ",
++ KeyF3: "\x1bOR",
++ KeyF4: "\x1bOS",
++ KeyF5: "\x1b[15~",
++ KeyF6: "\x1b[17~",
++ KeyF7: "\x1b[18~",
++ KeyF8: "\x1b[19~",
++ KeyF9: "\x1b[20~",
++ KeyF10: "\x1b[21~",
++ KeyF11: "\x1b[23~",
++ KeyF12: "\x1b[24~",
++ KeyBacktab: "\x1b[Z",
++ Modifiers: 1,
++ AutoMargin: true,
++ })
+ }