aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-05-09 08:40:33 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-05-09 08:41:41 +0000
commitf22e86fb1623e8385a767c124c372570635a97c8 (patch)
tree375323608f45a8c14327b186dda452637d33dde7
parentddcc71ca2065fc1561b3090362e01712668c0981 (diff)
downloadports-f22e86fb1623e8385a767c124c372570635a97c8.tar.gz
ports-f22e86fb1623e8385a767c124c372570635a97c8.zip
security/xca: Update to 2.4.0
-rw-r--r--security/xca/Makefile19
-rw-r--r--security/xca/distinfo6
-rw-r--r--security/xca/files/patch-img_Makefile10
-rw-r--r--security/xca/pkg-plist49
4 files changed, 42 insertions, 42 deletions
diff --git a/security/xca/Makefile b/security/xca/Makefile
index 48fe47fec1ea..4eb06fa09945 100644
--- a/security/xca/Makefile
+++ b/security/xca/Makefile
@@ -1,7 +1,7 @@
# Created by: Valentin Zahariev <curly@e-card.bg>
PORTNAME= xca
-PORTVERSION= 2.3.0
+PORTVERSION= 2.4.0
CATEGORIES= security
MASTER_SITES= https://github.com/${GH_ACCOUNT}/xca/releases/download/RELEASE.${PORTVERSION}/
@@ -15,8 +15,8 @@ BUILD_DEPENDS= gsed:textproc/gsed
LIB_DEPENDS= libltdl.so:devel/libltdl
USES= compiler:c++11-lang desktop-file-utils gmake localbase \
- pkgconfig qt:5 shared-mime-info shebangfix ssl
-USE_QT= buildtools_build core gui linguist_build sql widgets
+ pkgconfig qt:5 shared-mime-info ssl
+USE_QT= buildtools_build core gui help linguist_build sql widgets
USE_CXXSTD= c++11
GNU_CONFIGURE= yes
@@ -24,20 +24,15 @@ BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --with-openssl=${OPENSSLDIR} \
--with-qt=${PREFIX} \
--with-qt-version=5
-MAKE_ARGS= DOCTOOL="${TRUE}"
-SHEBANG_FILES= doc/code2html
GH_ACCOUNT= chris2511
OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} -e \
- '/^CFLAGS/s|-O2||' ${WRKSRC}/Local.mak.in
- @${REINPLACE_CMD} -e \
- '/install/s|-D|-c|' ${WRKSRC}/img/Makefile
+DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xca*
+post-patch:
+ @${REINPLACE_CMD} -e '/^CFLAGS/s|-O2 ||' \
+ ${WRKSRC}/Local.mak.in
.include <bsd.port.mk>
diff --git a/security/xca/distinfo b/security/xca/distinfo
index 59459ba0bbb0..008f7e85b5d3 100644
--- a/security/xca/distinfo
+++ b/security/xca/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588241325
-SHA256 (xca-2.3.0.tar.gz) = 3d168a225efaf9b2213e9ad2ba0abbccfcad139181dd2be668c2bbe21955a248
-SIZE (xca-2.3.0.tar.gz) = 1354154
+TIMESTAMP = 1620426109
+SHA256 (xca-2.4.0.tar.gz) = 66da8954fe9709ace965c6fcb1cfbb7b08ce75b7222988acb9e2b8b5fac7cf10
+SIZE (xca-2.4.0.tar.gz) = 1778572
diff --git a/security/xca/files/patch-img_Makefile b/security/xca/files/patch-img_Makefile
deleted file mode 100644
index a5a664b56225..000000000000
--- a/security/xca/files/patch-img_Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
---- img/Makefile.orig 2020-04-29 13:18:49 UTC
-+++ img/Makefile
-@@ -29,6 +29,7 @@ install-pixmaps: $(PIXMAPS)
- install-icons: $(ICONS)
- for SZ in 16 32 64; do \
- if [ -f xca-$${SZ}x$${SZ}.png ]; then \
-+ install -d $(DESTDIR)$(ICONDIR)/$${SZ}x$${SZ}/apps ; \
- install -D -m 0644 xca-$${SZ}x$${SZ}.png $(DESTDIR)$(ICONDIR)/$${SZ}x$${SZ}/apps/$(ICON_NAME).png ; \
- fi ; \
- done
diff --git a/security/xca/pkg-plist b/security/xca/pkg-plist
index 2b85f311d598..c5f3a5e8f74e 100644
--- a/security/xca/pkg-plist
+++ b/security/xca/pkg-plist
@@ -1,27 +1,42 @@
bin/xca
man/man1/xca.1.gz
share/applications/xca.desktop
-%%PORTDOCS%%%%DOCSDIR%%/xca-1.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-10.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-11.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-12.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-13.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-14.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-15.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-2.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-3.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-4.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-5.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-6.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-7.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-8.html
-%%PORTDOCS%%%%DOCSDIR%%/xca-9.html
-%%PORTDOCS%%%%DOCSDIR%%/xca.html
+share/bash-completion/completions/xca
+%%PORTDOCS%%%%DOCSDIR%%/arguments.html
+%%PORTDOCS%%%%DOCSDIR%%/certificate-input.html
+%%PORTDOCS%%%%DOCSDIR%%/certificates.html
+%%PORTDOCS%%%%DOCSDIR%%/changelog.html
+%%PORTDOCS%%%%DOCSDIR%%/commandline.html
+%%PORTDOCS%%%%DOCSDIR%%/common-actions.html
+%%PORTDOCS%%%%DOCSDIR%%/database.html
+%%PORTDOCS%%%%DOCSDIR%%/genindex.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/miscellaneous.html
+%%PORTDOCS%%%%DOCSDIR%%/object-ids.html
+%%PORTDOCS%%%%DOCSDIR%%/options.html
+%%PORTDOCS%%%%DOCSDIR%%/privatekey.html
+%%PORTDOCS%%%%DOCSDIR%%/requests.html
+%%PORTDOCS%%%%DOCSDIR%%/revocationlist.html
+%%PORTDOCS%%%%DOCSDIR%%/smartcard.html
+%%PORTDOCS%%%%DOCSDIR%%/step-by-step.html
+%%PORTDOCS%%%%DOCSDIR%%/template.html
+%%PORTDOCS%%%%DOCSDIR%%/xca.qch
+%%PORTDOCS%%%%DOCSDIR%%/xca.qhc
share/mime/packages/xca.xml
share/icons/hicolor/16x16/apps/xca.png
+share/icons/hicolor/16x16/mimetypes/x-xca-database.png
+share/icons/hicolor/16x16/mimetypes/x-xca-template.png
share/icons/hicolor/32x32/apps/xca.png
+share/icons/hicolor/32x32/mimetypes/x-xca-database.png
+share/icons/hicolor/32x32/mimetypes/x-xca-template.png
+share/icons/hicolor/48x48/apps/xca.png
+share/icons/hicolor/48x48/mimetypes/x-xca-database.png
+share/icons/hicolor/48x48/mimetypes/x-xca-template.png
share/icons/hicolor/64x64/apps/xca.png
-share/pixmaps/xca.xpm
+share/icons/hicolor/64x64/mimetypes/x-xca-database.png
+share/icons/hicolor/64x64/mimetypes/x-xca-template.png
+share/pixmaps/xca-32x32.xpm
%%DATADIR%%/CA.xca
%%DATADIR%%/TLS_client.xca
%%DATADIR%%/TLS_server.xca