aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2023-08-04 22:28:57 +0000
committerBrooks Davis <brooks@FreeBSD.org>2023-08-08 14:54:32 +0000
commitf2372e47ff2344a1ad1118210810669baebacf1c (patch)
tree79e724fd70b10f980a6488d582f37caa7bd79830
parent08500e7d1cff45467d5f3f77f41ca4755f3d5456 (diff)
downloadports-f2372e47ff2344a1ad1118210810669baebacf1c.tar.gz
ports-f2372e47ff2344a1ad1118210810669baebacf1c.zip
devel/llvm: drop support for LLVM_VERSION < 10
The last LLVM ports with major numbers less than 10 were removed in Jaunary with 21778d8958f518e2179b1053d75cfb6c71405558. Drop support for them in this symlink port.
-rw-r--r--devel/llvm/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/devel/llvm/Makefile b/devel/llvm/Makefile
index 1eac3e65cd17..7688ac3420f8 100644
--- a/devel/llvm/Makefile
+++ b/devel/llvm/Makefile
@@ -39,10 +39,7 @@ PLIST_FILES= ${COMMANDS:S|^|bin/|} \
LLVM_SUFFIX?= ${LLVM_DEFAULT}
-.if ${LLVM_SUFFIX:M[789]0}
-# Pre-LLVM 10 releases have a <Major><Minor> suffix
-LLVM_MAJOR=${LLVM_SUFFIX:C/0$//}
-.elif ${LLVM_SUFFIX:M[1-9][0-9]}
+.if ${LLVM_SUFFIX:M[1-9][0-9]}
# LLVM 10 and later have a <Major> suffix
LLVM_MAJOR=${LLVM_SUFFIX}
.elif exists(${.CURDIR}/../llvm${LLVM_SUFFIX}/Makefile.snapshot)