aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-04 09:04:28 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-04 09:04:28 +0000
commitf2536a4ffbdfdceebc980547255276da82dece3e (patch)
treeb5e97ce5752500a044dc0e86ea6f1067186e8723
parent4b84d3480c0d604c23b925f576fe66d0b406b9a2 (diff)
downloadports-f2536a4ffbdfdceebc980547255276da82dece3e.tar.gz
ports-f2536a4ffbdfdceebc980547255276da82dece3e.zip
devel/global: Fix shebang lines and ctags path
- Remove OPTIONS_DEFINE=DOCS - Bump PORTREVISION for package change
-rw-r--r--devel/global/Makefile6
-rw-r--r--devel/global/files/patch-plugin-factory-pygments_parser.py.in7
2 files changed, 4 insertions, 9 deletions
diff --git a/devel/global/Makefile b/devel/global/Makefile
index 3640b0a922d9..adfca6aade33 100644
--- a/devel/global/Makefile
+++ b/devel/global/Makefile
@@ -1,5 +1,6 @@
PORTNAME= global
PORTVERSION= 6.6.10
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GNU
@@ -12,6 +13,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= cpe libtool ncurses perl5 shebangfix
+CONFIGURE_ARGS= --with-exuberant-ctags=${LOCALBASE}/bin/exctags \
+ --with-python-interpreter=${LOCALBASE}/bin/python${PYTHON_DEFAULT} \
+ --with-universal-ctags=${LOCALBASE}/bin/uctags
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
TEST_TARGET= check
@@ -23,6 +27,4 @@ CPE_VENDOR= gnu
SHEBANG_GLOB= *.pl
-OPTIONS_DEFINE= DOCS
-
.include <bsd.port.mk>
diff --git a/devel/global/files/patch-plugin-factory-pygments_parser.py.in b/devel/global/files/patch-plugin-factory-pygments_parser.py.in
deleted file mode 100644
index 843c8b1f71d9..000000000000
--- a/devel/global/files/patch-plugin-factory-pygments_parser.py.in
+++ /dev/null
@@ -1,7 +0,0 @@
---- plugin-factory/pygments_parser.py.in.orig 2021-07-01 04:06:35 UTC
-+++ plugin-factory/pygments_parser.py.in
-@@ -1,4 +1,3 @@
--#!@PYTHON@
- #
- # Copyright (c) 2014
- # Yoshitaro Makise