aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-11-01 13:26:56 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-11-01 13:41:49 +0000
commitf2697f04076a3c58943a133242de74e3de3147a1 (patch)
tree264b87d2963ca7a2479cc26ff90d761a53487abe
parenta6e6bce388a13ab867cb5856e4fd4a0ac92567f7 (diff)
downloadports-f2697f04076a3c58943a133242de74e3de3147a1.tar.gz
ports-f2697f04076a3c58943a133242de74e3de3147a1.zip
science/py-eccodes: Fix 1f51ea42c4498e11ef9e4c41cb7b957783130862
- Update RUN_DEPENDS - Update USES=python
-rw-r--r--science/py-eccodes/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/py-eccodes/Makefile b/science/py-eccodes/Makefile
index ed9dc7ebbde1..737129fea3f9 100644
--- a/science/py-eccodes/Makefile
+++ b/science/py-eccodes/Makefile
@@ -16,13 +16,13 @@ LIB_DEPENDS= libeccodes.so:science/eccodes
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cffi>=0:devel/py-cffi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}findlibs>=0:devel/py-findlibs@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}numpy>=0,1<1.21,1:math/py-numpy@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-flakes>=0:devel/py-pytest-flakes@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}typing-extensions>=0:devel/py-typing-extensions@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
do-test: