aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-25 20:20:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-04-25 20:36:20 +0000
commitf289252e4fcff4b1c8d737614478f2bb832fa69a (patch)
tree0177d5c4c6140e53c7f72da842f1f0add36948aa
parent75693e763b689ceba386ec150fd334800c0e6806 (diff)
downloadports-f289252e4fcff4b1c8d737614478f2bb832fa69a.tar.gz
ports-f289252e4fcff4b1c8d737614478f2bb832fa69a.zip
net/rubygem-grpc: Update to 1.37.0
-rw-r--r--net/rubygem-grpc/Makefile4
-rw-r--r--net/rubygem-grpc/distinfo6
-rw-r--r--net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb14
3 files changed, 12 insertions, 12 deletions
diff --git a/net/rubygem-grpc/Makefile b/net/rubygem-grpc/Makefile
index 53ea4fde193f..77b83e9083b8 100644
--- a/net/rubygem-grpc/Makefile
+++ b/net/rubygem-grpc/Makefile
@@ -1,5 +1,5 @@
PORTNAME= grpc
-PORTVERSION= 1.36.0
+PORTVERSION= 1.37.0
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -11,7 +11,7 @@ LICENSE= BSD3CLAUSE
LIB_DEPENDS= libcares.so:dns/c-ares \
libgrpc.so:devel/grpc
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
- rubygem-google-protobuf>=3.14<4:devel/rubygem-google-protobuf \
+ rubygem-google-protobuf>=3.15<4:devel/rubygem-google-protobuf \
rubygem-googleapis-common-protos-types>=1.0<2:devel/rubygem-googleapis-common-protos-types
USES= gem gmake pkgconfig
diff --git a/net/rubygem-grpc/distinfo b/net/rubygem-grpc/distinfo
index 2f14032830a3..b45d2331f3cc 100644
--- a/net/rubygem-grpc/distinfo
+++ b/net/rubygem-grpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1614794444
-SHA256 (rubygem/grpc-1.36.0.gem) = 8cb6e31d285fe8ae1ee8013e3102ac97a150d7dd0a1aa1a2568be1ef1ca8e308
-SIZE (rubygem/grpc-1.36.0.gem) = 4657664
+TIMESTAMP = 1619198927
+SHA256 (rubygem/grpc-1.37.0.gem) = bbe862e2f41f2a8aef7bbf35e5f471196baab8c75765779dfa7dab4b26e1bcb6
+SIZE (rubygem/grpc-1.37.0.gem) = 4776448
diff --git a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
index 1c9f7cb9dbe2..b2fa8d04a855 100644
--- a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
+++ b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
@@ -1,8 +1,8 @@
---- src/ruby/ext/grpc/extconf.rb.orig 2019-11-22 13:44:33 UTC
+--- src/ruby/ext/grpc/extconf.rb.orig 2021-04-24 13:33:17 UTC
+++ src/ruby/ext/grpc/extconf.rb
-@@ -39,9 +39,9 @@ end
-
- ENV['AR'] = 'libtool -o' if RUBY_PLATFORM =~ /darwin/
+@@ -42,9 +42,9 @@ if RUBY_PLATFORM =~ /darwin/
+ ENV['ARFLAGS'] = '-o'
+ end
-ENV['EMBED_OPENSSL'] = 'true'
-ENV['EMBED_ZLIB'] = 'true'
@@ -10,10 +10,10 @@
+ENV['EMBED_OPENSSL'] = 'false'
+ENV['EMBED_ZLIB'] = 'false'
+ENV['EMBED_CARES'] = 'false'
+
ENV['ARCH_FLAGS'] = RbConfig::CONFIG['ARCH_FLAG']
- ENV['ARCH_FLAGS'] = '-arch i386 -arch x86_64' if RUBY_PLATFORM =~ /darwin/
- ENV['CPPFLAGS'] = '-DGPR_BACKWARDS_COMPATIBILITY_MODE'
-@@ -50,22 +50,23 @@ output_dir = File.expand_path(RbConfig::CONFIG['topdir
+ if RUBY_PLATFORM =~ /darwin/
+@@ -61,22 +61,23 @@ output_dir = File.expand_path(RbConfig::CONFIG['topdir
grpc_lib_dir = File.join(output_dir, 'libs', grpc_config)
ENV['BUILDDIR'] = output_dir