aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-08-22 07:37:11 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-22 07:45:12 +0000
commitf302216145c10a30b4d11951a1611cb7725b8297 (patch)
treed952ceb2ae71041ef068315fd7a6e1cae26946c1
parent7c5e84bb15cf4fc7c6b0388a28e9eb9711093583 (diff)
downloadports-f302216145c10a30b4d11951a1611cb7725b8297.tar.gz
ports-f302216145c10a30b4d11951a1611cb7725b8297.zip
emulators/yuzu: exclude on non-amd64 for now
In file included from src/common/wall_clock.cpp:7: src/./common/uint128.h:16:10: fatal error: x86intrin.h: No such file or directory 16 | #include <x86intrin.h> | ^~~~~~~~~~~~~ Reported by: pkg-fallout (cherry picked from commit 51c03a9dbe214e813cffd342fa040b9c753fc756)
-rw-r--r--emulators/yuzu/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 97a1f7212f69..38631790e3f9 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -18,8 +18,9 @@ LICENSE_FILE_LGPL21+ = ${_LICENSE_STORE}/LGPL21 # soundtouch
LICENSE_FILE_LGPL3+ = ${_LICENSE_STORE}/LGPL3 # sirit
LICENSE_FILE_MIT= ${WRKSRC}/externals/sirit/externals/SPIRV-Headers/LICENSE
-ONLY_FOR_ARCHS= aarch64 amd64 powerpc64
-ONLY_FOR_ARCHS_REASON= requires int128
+ONLY_FOR_ARCHS= aarch64 amd64
+ONLY_FOR_ARCHS_REASON= requires int128 and dynarmic backend
+BROKEN_aarch64= https://github.com/yuzu-emu/yuzu/issues/5290
BUILD_DEPENDS= catch>0:devel/catch \
boost-libs>0:devel/boost-libs \